Jump to content


Photo

"This media server is unavailable to you. Please check that you have permission to access this media server."


Best Answer marlowc, 19 March 2013 - 11:34 PM

I was having the same issue as well.  Mine started working after I did the following:

 

1. Plex Settings --> myPlex

2. Show Advanced Settings

3. Check "Require authentication on local networks"

4. Wait 60 seconds

5. UNCHECK "Require authentication on local networks"

 

Now I can manage my Plex library from any system in my house again, plus it also fixed the IOS app from not seeing my media server.  All seems well now.

Go to the full post


  • Please log in to reply
8 replies to this topic

#1 yankees8223

yankees8223

    Newbie

  • Members
  • Pip
  • 2 posts
  • Location: Tampa, FL

Posted 16 March 2013 - 07:08 PM

Over a month ago, I setup a Plex Media Server on my Ubuntu Server 12. It was working perfectly. I could stream movies, tv shows, various channels to my Roku device and to other devices in my house. No problems at all. After two weeks, it just stopped working. No matter what device I tried accessing it from, I would see the message "This media server is unavailable to you. Please check that you

have permission to access this media server."

 

The files are stored on a samba share with read/write/modify permissions for all. I can access the files through any pc manually without any access issues. Just not via plex. I've restarted the server, all devices, and router many times. I've made sure my router isn't blocking any ports and it has UPnP

enabled. I made sure these ports weren't being blocked on the server's firewall: http://wiki.plexapp....nable_access.3F

I triple-checked the samba permissions. I even removed plex and re-intalled it from scratch. I made sure I had the latest version of Plex. Still nothing.

 

Does anybody have any other suggestions? Thanks in advance.



#2 marlowc

marlowc

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 19 March 2013 - 11:34 PM   Best Answer

I was having the same issue as well.  Mine started working after I did the following:

 

1. Plex Settings --> myPlex

2. Show Advanced Settings

3. Check "Require authentication on local networks"

4. Wait 60 seconds

5. UNCHECK "Require authentication on local networks"

 

Now I can manage my Plex library from any system in my house again, plus it also fixed the IOS app from not seeing my media server.  All seems well now.



#3 yankees8223

yankees8223

    Newbie

  • Members
  • Pip
  • 2 posts
  • Location: Tampa, FL

Posted 31 March 2013 - 06:16 AM

Thanks, marlowc. I couldn't fix it using your exact steps since I am running ubuntu Server, which doesn't use a GUI. However, using your fix, I was able to do the equivalent. I edited the preferences.xml and added the line disableRemoteSecurity="1" Now it works.

 

Thank you.



#4 perpl3xed

perpl3xed

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 31 March 2013 - 11:46 AM

Thanks, marlowc. I couldn't fix it using your exact steps since I am running ubuntu Server, which doesn't use a GUI. However, using your fix, I was able to do the equivalent. I edited the preferences.xml and added the line disableRemoteSecurity="1" Now it works.

 

Thank you.

 

Hi,

 

I'm having the same issue on my Ubuntu 12.04 server installation.

 

I tried to add the line to the preferences.xml, but I'm not sure if I added it correctly since nothing changed.

 

Where exactly in the config line do you add the line?

 

Cheers



#5 sartem

sartem

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 02 April 2013 - 03:19 AM

I'm also having the same problem and the fixes above did not work for me. 



#6 br14n

br14n

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 08 April 2013 - 06:42 PM

Thanks, marlowc. I couldn't fix it using your exact steps since I am running ubuntu Server, which doesn't use a GUI. However, using your fix, I was able to do the equivalent. I edited the preferences.xml and added the line disableRemoteSecurity="1" Now it works.

 

Thank you.

 

The line is removed when you restart plex. 



#7 Trudge

Trudge

    Gone off to greener pastures....

  • Members
  • PipPipPipPipPipPip
  • 9403 posts

Posted 08 April 2013 - 06:47 PM

The line is removed when you restart plex. 

you need to stop the server before you edit the config - adding that line though is really not recommended, anyone connecting to your server from any network is now an admin.


Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
Airplay & PlexConnect Targets: 4 x ATV3

#8 RobertSmith

RobertSmith

    Dedicated Member

  • Members
  • PipPipPip
  • 407 posts
  • Location: Stockholm

Posted 19 May 2013 - 03:58 PM

Thanks, marlowc. I couldn't fix it using your exact steps since I am running ubuntu Server, which doesn't use a GUI. However, using your fix, I was able to do the equivalent. I edited the preferences.xml and added the line disableRemoteSecurity="1" Now it works.

 

Thank you.

THY !!!


Mac mini (2.3 GHz Quad-Core Intel Core i7) with Plex Media Server and Plex/Home Theater   Synology DS1512+ with SABnzbd  Sick Beard  CouchPotato

Receiver Marantz SR7007   3D Projector SONY HW55ES   Fixed Frame Screen ReAct 2.1   Speakers DLS of Sweden & Velodyne Ultra (white)

aTV2 with aTV Flash  iPhone 5  iPad mini with Plex/iOS  MacBook Pro  MacBook Air with Plex/Web


#9 bhutchins

bhutchins

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 20 June 2013 - 08:45 PM

Why though. I get the same issue now, both with Plex Media Server (PMS) version 0.9.7.28 and 0.9.8.0 (currently plexpass only).

 

I want to require authentication on my local network and not get media server is unavailable every time a secondary user logs in. This also doesn't happen only on my local network however, when accessing externally using any secondary account the same issue occurs. I basically cannot run a single request without having to hit reload a few times to get it to work.

 

It's obvious it's a server issue, has nothing to do with file access or permissions. If you use a network logger you can see that the requests are simply timing out, the Plex Media Server is not responding quickly enough. It honestly appears that the Plex Media Server's web server simply cannot handle many concurrent requests.

 

Just trying to load a static image included in the Plex Media Server, http://your-plex-ser...web/img/sad.png will cause an "ERR_CONNECTION_TIMED_OUT" error. You force it to happen you simply have to click refresh repeatedly about 5-10 times. Considering how few requests it takes to cause this to happen, I can image that the majority of the time you are using Plex/Web there are more than 10 resource files being loaded per page, and as you navigate new images, metadata and directory listings are being loaded asynchronously.

 

This is probably the single worst thing about Plex, because it makes it so I cannot actually share my plex server with friends. They try to access the media and get so annoyed with it they give up. I was previously hosting on a Ubuntu Server for about 6 months and this because so annoying I reformatted my old gaming desktop and I have now have Plex Media Server running on an overly beefy Windows 8 server edition and migrated my 6TB of data that was previously spread out over 5 hard drives to brand new Western Digital RED Nasware drives. The same thing happens. It clearly has nothing to do with processing capability or file access, file reading speed (as the media server caches are on an OCZ Vector Series SSD) and it entirely to do with some internal software bug.

 

I'd really like this one fixed. I wish I could fix it myself because of how annoying it is, but Plex isn't open source :-( I support the developers though, have now bought plex apps for Android, Google TV, Windows 8 and have a PlexPass subscription; but alas, the core bugs are not being fixed.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users