Jump to content


Photo

Where to install apps from Unofficial app store


  • Please log in to reply
28 replies to this topic

#1 mhipp

mhipp

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 04 May 2013 - 11:09 PM

Hello,

 

I am attempting to install plug-ins from this page http://wiki.plexapp....pported_plugins. I see where I can download these but I cannot figure out how to install them so Plex sees them. The first one I am attempting to install is called MTV_Shows.plexapp. Where would I put that file so Plex sees it to install it?

 

Thank you so much in advance for any help!



#2 tcviper

tcviper

    Plex Ninja

  • Plex Ninja
  • PipPipPipPipPip
  • 614 posts
  • Location: Netherlands

Posted 05 May 2013 - 02:35 PM

You simply drop the .bundle file into the plugins directory:

 

For Mac users this is: ~/Library/Application Support/Plex Media Server/Plug-ins.
For Windows users this is: ~\AppData\Local\Plex Media Server\Plug-ins.


Primary PMS: HP Quad Intel Xeon Ubuntu 12.04, 16Gb memory

Secondary PMS: Macmini 2012 i7, 16gb Ram, Fuzion Drive (1TB)

Storage Server 1: Synology RS3412xs with 20TB of WD Red Drives, AFP to Plex Server

Storage Server 2: Synology DS1511+ with 10TB of WD Black Drives, AFP to Plex Server (PMS 2)

DLNA/Airplay Clients: Sony KDL-55W905A | KDL-42W655A, Sony Receiver DN1040

Desktop Clients: 2 x Windows 8 24", 2 x 15" MBP, 2 x 13" MBPA, iMac i5 2011 27"

Mobile Clients: 2 x iPhone 5, 2 x Sony Xperia Z, 1x iPad 4 32Gb

Media Players: Sony NSZ-GS7 GTV, ATV3


#3 Mikedm139

Mikedm139

    Plugin Developer

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2898 posts
  • Location: Canada

Posted 05 May 2013 - 03:52 PM

I should point out, that particular file is a very old .plexapp installer file. Which means two things; 1.) it will only work on OSX to install the plugin, & 2.) the channel is very out of date and unlikely to work.

If you are having trouble with one or more channels, check here first.
If you are asked to provide logs, which you will be if you are having plugin problems, the help center has details on where to find them.
***************************************************************************************************************************************
Check out unofficial channels in the
UnSupported AppStore
Follow my efforts on Github and Twitter
Donate


#4 jimberkas

jimberkas

    Member

  • Members
  • PipPip
  • 39 posts

Posted 05 May 2013 - 07:42 PM

question on UAS, which is pretty awesome...

do new plug-ins automatically show up there?  or do i have do update it manually?

i ask because I'm pretty sure it has the same stuff in it since i installed it about 9 months ago.  i raed that some people are seeing the Navi-x plug-in available in UAS and it's not showing for me.  just don't want to be missing out on any cool new stuff...

thanks much for your work, by the way.



#5 Mikedm139

Mikedm139

    Plugin Developer

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2898 posts
  • Location: Canada

Posted 05 May 2013 - 08:44 PM

Generally, you can check for updates inside the Unsupported Appstore and it will tell you when there are updates available for plugins including the Appstore itself. There was however, an issue with some changes to the way updates were handled which prevented the older version from actually downloading any new updates. I don't remember off the top of my head when the new version with the fix for broken updates was released. It's probably a good idea to download and re-install to be sure that you're getting the proper updates.


If you are having trouble with one or more channels, check here first.
If you are asked to provide logs, which you will be if you are having plugin problems, the help center has details on where to find them.
***************************************************************************************************************************************
Check out unofficial channels in the
UnSupported AppStore
Follow my efforts on Github and Twitter
Donate


#6 jimberkas

jimberkas

    Member

  • Members
  • PipPip
  • 39 posts

Posted 05 May 2013 - 11:43 PM

Thanks, I think I will try re-installing it.  I do get notices when individual plug-ins have updates available.  the appstore itself doesn't seem to update though.  so maybe its all working fine. 

thanks for the fast reply



#7 jimberkas

jimberkas

    Member

  • Members
  • PipPip
  • 39 posts

Posted 06 May 2013 - 12:38 AM

OK, i re-installed it.  I don't see any thing new that I didn't have in my previous version.

 

So out of curiosity, is Navi-x supposed to show up in UAS?

 

I had it installed separately, but if its supposed to be in UAS, I'd like to get it there in case there are updates.



#8 Mikedm139

Mikedm139

    Plugin Developer

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2898 posts
  • Location: Canada

Posted 06 May 2013 - 01:22 AM

Yes it is. Did you check for updates after installing?

If you are having trouble with one or more channels, check here first.
If you are asked to provide logs, which you will be if you are having plugin problems, the help center has details on where to find them.
***************************************************************************************************************************************
Check out unofficial channels in the
UnSupported AppStore
Follow my efforts on Github and Twitter
Donate


#9 jimberkas

jimberkas

    Member

  • Members
  • PipPip
  • 39 posts

Posted 06 May 2013 - 03:26 AM

maybe I'm still missing something.  I did the "Download Updates", which appears to be all installed plug-ins.  does this update UAS as well?  I don't see any other options to update the UAS using a client or my Plex Media Manager.

 

still not seeing Navi-X in the UAS.



#10 Mikedm139

Mikedm139

    Plugin Developer

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2898 posts
  • Location: Canada

Posted 06 May 2013 - 02:47 PM

That's strange. "Download Updates" should definitely update the UAS itself as well as any other UAS-installed channels. Have you tried installing anything via you're most recent install of the UAS? If so, did it work? When you re-installed, did you download the latest version available from the forum post linked in my sig? Also, which version are you using? ie. does it show up as a Video plugin or an Application?


If you are having trouble with one or more channels, check here first.
If you are asked to provide logs, which you will be if you are having plugin problems, the help center has details on where to find them.
***************************************************************************************************************************************
Check out unofficial channels in the
UnSupported AppStore
Follow my efforts on Github and Twitter
Donate


#11 jimberkas

jimberkas

    Member

  • Members
  • PipPip
  • 39 posts

Posted 06 May 2013 - 10:07 PM

yeah, i think i have the most updated version from the forum.  the one linked on your first post.

i did install 4tube from there today and it installed fine.

how do I check which version of UAS I have installed?



#12 Mikedm139

Mikedm139

    Plugin Developer

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2898 posts
  • Location: Canada

Posted 06 May 2013 - 10:39 PM

Version numbering is something that I never bothered to implement since I use git (and github) for version control.

Navi-X should show up in the list of available video plugins or right between Library Updater and Newzworthy in the list of all plugins. Can you grab me a zip file of the UAS plugin log after attempting to download updates in the UAS? Check my sig for a link on how to find logs.


If you are having trouble with one or more channels, check here first.
If you are asked to provide logs, which you will be if you are having plugin problems, the help center has details on where to find them.
***************************************************************************************************************************************
Check out unofficial channels in the
UnSupported AppStore
Follow my efforts on Github and Twitter
Donate


#13 jimberkas

jimberkas

    Member

  • Members
  • PipPip
  • 39 posts

Posted 06 May 2013 - 10:54 PM

got it, thanks.  i went to the GitHub and downloaded directly from there, the one called ...bundle-master.  hopefully that was the correct one.  I removed the master from the end of it and it seems to be updated now.  at least I'm seeing the Navi-X channel now.

 

thanks so much for your help.

 

by the way, do you suggest I remove the older installed navi-x plug in?  i assume any updates will come through the UAS...



#14 Mikedm139

Mikedm139

    Plugin Developer

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2898 posts
  • Location: Canada

Posted 06 May 2013 - 11:24 PM

It shouldn't be necessary to remove the old install before installing via the UAS, but it also wouldn't hurt. The UAS will over-write an existing install as necessary.

The master branch should work fine. Technically, the release version will be one of either the applications or videos branches.

If you are having trouble with one or more channels, check here first.
If you are asked to provide logs, which you will be if you are having plugin problems, the help center has details on where to find them.
***************************************************************************************************************************************
Check out unofficial channels in the
UnSupported AppStore
Follow my efforts on Github and Twitter
Donate


#15 eugekiller

eugekiller

    Member

  • Members
  • PipPip
  • 43 posts

Posted 31 July 2013 - 04:12 PM

Can anyone help i cant seem to find the directory plug-in folder to add channels.



#16 Mikedm139

Mikedm139

    Plugin Developer

  • Plex Ninja
  • PipPipPipPipPipPip
  • 2898 posts
  • Location: Canada

Posted 31 July 2013 - 10:13 PM

Can anyone help i cant seem to find the directory plug-in folder to add channels.

 

Depends on what operating system you are running.

 

 

You simply drop the .bundle file into the plugins directory:

 

For Mac users this is: ~/Library/Application Support/Plex Media Server/Plug-ins.
For Windows users this is: ~\AppData\Local\Plex Media Server\Plug-ins.


If you are having trouble with one or more channels, check here first.
If you are asked to provide logs, which you will be if you are having plugin problems, the help center has details on where to find them.
***************************************************************************************************************************************
Check out unofficial channels in the
UnSupported AppStore
Follow my efforts on Github and Twitter
Donate


#17 eugekiller

eugekiller

    Member

  • Members
  • PipPip
  • 43 posts

Posted 03 August 2013 - 01:55 PM

Plex Media Server 0.9.7.28-f80a4a2 (On my PC)

IP on PC 192.168.3.107

IP on Smasung 192.168.3.108

Plex on tv is 1.006

Windows 7

 

Ye i put it in the right place. I unziped it then moved it in to plug-ins

 

but it doenst show up in PMS



#18 parsleymorris

parsleymorris

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 19 October 2013 - 01:23 PM

Hello, I'm a Roku and Plex newbie, and a Mac user (OSX 10.8.5) . I have been trying to add ITV Player and 4od  to Plex so that I can view them on my Roku1. Browsing through the forums, all the advice seems to be to download them into Plex's Plug-ins folder in Library>Application Support. But when I downloaded Plex Media Server it only downloaded a standalone app to go in my Applications folder and no plug-ins folder. Therefore, there doesn't seem to be anywhere I can put bundles. There's certainly no folder in Applications Support.

Can anyone help?



#19 institute11

institute11

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1397 posts
  • Location: Canada

Posted 19 October 2013 - 01:41 PM

You will have to run PMS at least once for the folders to be created. They will be in Library/Application Support/Plex Media Server

#20 parsleymorris

parsleymorris

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 19 October 2013 - 06:34 PM

You will have to run PMS at least once for the folders to be created. They will be in Library/Application Support/Plex Media Server

I'm not sure what you mean by 'running it'. PMS has loaded into my computer's browser and I've watched a Vimeo video through it to check it, if that's the sort of thing you mean. Still no folder created in Application Support though.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users