Jump to content


Photo

Plex server, port forwarding, Virgin Router difficulties

Plex server Port Forwarding Virgin netgear

Best Answer breezytm, 06 May 2013 - 05:30 AM

Yes it does sound like port forwarding issue.

Check your router settings to see if it supports uPnP. If it does ensure it is enable but if it doesn't you need to configure the port manually in plex and your router. You can reuse that 24469 port as a manual port.

uPnP allows the router to enable ports automatically as requested by any application. Go to the full post


  • Please log in to reply
14 replies to this topic

#1 mattjtemp

mattjtemp

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 05 May 2013 - 06:54 PM

Hi there,

 

I'm very new to Plex, I'm not very technical and whilst I love what this seems to offer me I can't get this working seamlessly and can't find anything that is simple enough for a dolt such as myself to follow.

 

I have;

 

  • Windows 7 laptop as plex server
  • Local content on a NAS drive
  • Windows Phone 7 with Plex client on
  • Virgin MEdia netgear router

 

My Plex server is up and running, it's scanned my content, it all looks great. When My phone is on my home wifi the client works like a dream and I can stream to the phone.

 

But, when I am off my wifi on another wifi or out and about on 3g my Windows Phone Plex client can not find my plex server, at home in settings the lex server says it's mapped to port 24469 (automatic, not manually set). I have a Virgin Media Netgear router, no port forwarding configured, Windows firewall is off, Norton firewall on the plex server laptop is set to allow Plex.

 

Weirdly, I have had connection from my phone to the Plex server over 3G when wifi is off on the phone, so had thought this is fixed, but perhaps that is a red herring, I wouldn't have thought it would be possible to connect to plex server over 3g if there was something not configured from a routing perspective? My brother has Plex, he is added as a friend and I've selected content to share but he can not access my server, again suggesting routing.

 

I have a dynamic dns account plus I've set a static IP for my laptop but I've not tried port forwarding as I'm not sure of the port numbers to add in for internal and external and am not sure this is even the problem, my brother had none of these issues, it just worked, so any help or troubleshooting tips would be really gratefully received.



#2 JamminR

JamminR

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1088 posts
  • Location: South East US

Posted 06 May 2013 - 05:17 AM

Much info/steps here - http://wiki.plexapp....ndex.php/MyPlex

You may need to teach/find out how to configure your router on your own.


MAKE SURE YOUR PLEX SERVER IS UP TO DATE - v .9.9.5 and above fix a major Security Exploit! (Latest public download)

Server - HW: Intel Core I5-4670K,16GB DDR3, 4TB RAID1 - SW: Win7x64 Ult. + PMS v0.9.9.10 - ISP: 5mbps up/300GB monthly cap

Clients - 3x Roku2 XS  (RARflix: modified Roku Channel) , 1x Win PHT, 1x Android, 1x iPhone 4s, 1x iPad 4

Shares - From: 7 - To: 2. - Proud PlexPass subscriber!

Agents/Plugins I frequently use - DVD Order Agent - Unsupported Appstore - BringThePopcorn - SS Plex (Watch your searches later!!!) - Yify

Common WIKI FAQs I answer - How do I find the Plug-Ins folder? - How do I manually install a channel?
 


#3 breezytm

breezytm

    Rock Star

  • Members
  • PipPipPipPipPip
  • 588 posts
  • Location: New York

Posted 06 May 2013 - 05:30 AM   Best Answer

Yes it does sound like port forwarding issue.

Check your router settings to see if it supports uPnP. If it does ensure it is enable but if it doesn't you need to configure the port manually in plex and your router. You can reuse that 24469 port as a manual port.

uPnP allows the router to enable ports automatically as requested by any application.

#4 mattjtemp

mattjtemp

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 06 May 2013 - 09:31 AM

Thanks for the tips, I haver my static IP, I have confirmed the router supports uPnP and is set to be on but just in case that is playing up I have added a port forwarding rule for 32400 on both internal and external to my fixed IP and the server connection is there, but it was there before, it was connecting automatically.

 

But though I can see my brother's content he can't see mine and I can't access mine when the client is off the home network, so something is still blocking, I've either done port forwarding wrong (but there is no error on the plex server) or possibly there is an issue with my NAS allowing access.

 

Could I have done port forwarding wrong, does this look ok?

33u7csx.jpg



#5 breezytm

breezytm

    Rock Star

  • Members
  • PipPipPipPipPip
  • 588 posts
  • Location: New York

Posted 06 May 2013 - 07:43 PM

Great. Forward port 32400 for plex when it is actually 'automatically' using 24469? If you want to use port 32400 on your router to use myplex on the web you need to change the PMS setting to 'Manually' configure the port and in the box you need to enter 32400. The port on the PMS and the one on the router must be identical. 

 

Can you post a screenshot of your PMS port setting as well as the router after you make these changes.



#6 joew

joew

    Dedicated Member

  • Members
  • PipPipPip
  • 160 posts

Posted 07 May 2013 - 09:06 AM

Not sure if you know this but most routers have two stages to port forwarding, the 'service' and the 'firewall'

 

The service is sending the content on a port to the designated IP address - port 32400 sends to 192.168.0.6

The firewall allows the internet access to the chosen port - allow all incoming connections to port 32400. 

 

Its common for people to miss out the second bit. Not sure if your router requires you to do it in two stages. If its the classic white netgear, rebranded, then it definitely does.

 

this might help 

 

Does your router look like this:

 

$(KGrHqN,!ikE4sbS5mlqBOOqZuq6bw~~_35.JPG

If so look here: http://portforward.c...edia_Server.htm

 

or this:

 

$(KGrHqJ,!qwFCS)K-G4!BQucnzZLFg~~60_35.J

if so look here: http://portforward.c...edia_Server.htm


If someone helps you like it or mark it as solved. 


#7 mattjtemp

mattjtemp

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 11 May 2013 - 06:33 AM

Guys, thanks very much, invaluable, I've got it working following these tips, it was simply my router needed the manual forwarding even though it should have configured at install.

 

Big thank you for taking time to help me.



#8 joew

joew

    Dedicated Member

  • Members
  • PipPipPip
  • 160 posts

Posted 11 May 2013 - 07:35 AM

OK great, remember to mark as solved whoever helped you!!


If someone helps you like it or mark it as solved. 


#9 breezytm

breezytm

    Rock Star

  • Members
  • PipPipPipPipPip
  • 588 posts
  • Location: New York

Posted 11 May 2013 - 04:02 PM

Glad we were able to help.

 

Make sure uPnP is supported on your router. If it is, enable it. That would prevent further headaches. Meaning whenever an application needs a port open, with uPnP enabled, the router would just open the port without your assistance.

 

Pretty much all new routers support it so yours should have it. It's most likely going to fall under Administration settings. 

 

 

As Joew said, don't forget to give credit to the one who helped you and mark the post as solved. 



#10 bigmtnskier

bigmtnskier

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 09 June 2013 - 08:12 AM

Glad we were able to help.

 

Make sure uPnP is supported on your router. If it is, enable it. That would prevent further headaches. Meaning whenever an application needs a port open, with uPnP enabled, the router would just open the port without your assistance.

 

Pretty much all new routers support it so yours should have it. It's most likely going to fall under Administration settings. 

 

 

As Joew said, don't forget to give credit to the one who helped you and mark the post as solved. 

Hello breezytm - I have read through countless post, regarding configuration and port forwarding etc, but I cannot seem to get my PMS to connect, either automatically or manually. My router is an ASUS NT-56U with uPnP enabled. I am running Windows 7 64 bit with NO anti-virus software. I have confirmed that my Windows Firewall has all rules enabled for all Plex services etc. again I have attempted multiple configurations and scenairos including clean installs after removing AVG completely.  I am also using the latest version of Google Chrome as well.

 

To be clear, I have set-up my router to port forward to 32400 as well, nothing works.

 

My eyes are shot, I have been at this for several hours, any suggestions would be greatly appreciated!!!  Thank you for reading my post.



#11 breezytm

breezytm

    Rock Star

  • Members
  • PipPipPipPipPip
  • 588 posts
  • Location: New York

Posted 09 June 2013 - 05:09 PM

Sounds like you having a nightmare buddy.  :D

 

Send me a quick screenshot of your router port forwarding settings as well as PMS port forward page with show advanced settings

 

Additionally, are you able to use any other application using port forwarding? 



#12 joew

joew

    Dedicated Member

  • Members
  • PipPipPip
  • 160 posts

Posted 09 June 2013 - 05:59 PM

Just to check have you forwarded your port in services AND opened a port in your firewall? Also check for conflicts created by uPnP by disabling it in the router settings temporarily.

If someone helps you like it or mark it as solved. 


#13 T-Law

T-Law

    Member

  • Members
  • PipPip
  • 30 posts
  • Location: Perth, Australia

Posted 18 July 2013 - 02:31 PM

Could someone please help me with my port fowarding issue?!

 

Im running PMS on a Windows 7 machine with the media stored on a Netgear ReadNAS.  My router is a Netgear D6300 and I cannot publish my library for access outside my network.  Im not a networking guru so a lot of this is beyond me.  I understand I need to open the port 32400 but I cant for the life of me figure this out.  Ive used the router interface to set up rules but it never works, I guess Im doing something wrong.

 

Please help!



#14 joew

joew

    Dedicated Member

  • Members
  • PipPipPip
  • 160 posts

Posted 18 July 2013 - 02:44 PM

Could someone please help me with my port fowarding issue?!

 

Im running PMS on a Windows 7 machine with the media stored on a Netgear ReadNAS.  My router is a Netgear D6300 and I cannot publish my library for access outside my network.  Im not a networking guru so a lot of this is beyond me.  I understand I need to open the port 32400 but I cant for the life of me figure this out.  Ive used the router interface to set up rules but it never works, I guess Im doing something wrong.

 

Please help!

 

Try here:

 

http://portforward.c...edia_Server.htm


If someone helps you like it or mark it as solved. 


#15 T-Law

T-Law

    Member

  • Members
  • PipPip
  • 30 posts
  • Location: Perth, Australia

Posted 21 July 2013 - 08:34 AM

Thanks joew, I had seen that site previously, it shows the port forwarding for the D6300 when in actual fact its for a different one.  The screen shots they posted for the procedure are similar to what I see when I log into my router but not quite the same.  Thanks for the help anyway







Also tagged with one or more of these keywords: Plex server, Port Forwarding, Virgin netgear

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users