Jump to content


Photo

OSX Server: Can't get Plex Connect to work


Best Answer SebSeb, 12 June 2013 - 06:36 PM

Here's a guide to how I solved it on OS X Server 10.7

 

http://forums.plexap...s-x-server-107/

Go to the full post


  • This topic is locked This topic is locked
51 replies to this topic

#1 HKMacs

HKMacs

    Dedicated Member

  • Members
  • PipPipPip
  • 108 posts
  • Location: Hong Kong SAR, PRC

Posted 02 June 2013 - 09:22 AM

ATV3

Firmware 5.2.1 (6025)

10.0.1.8

iMac Late 2011, Mountain Lion Server 10.8.3

10.0.1.8

iMac Late 2011, Mountain Lion Server 10.8.3

10.0.1.8

External Smartstor DS4600, Firewire

Plex Connect Templates from 6/1/2013 1.19 p.m.

 

When I run the script I get this:

 

 

hkmacs:PlexConnect-XML_templates admin$ sudo ./PlexConnect.py
PlexConnect : ***
PlexConnect : PlexConnect
PlexConnect : Press ENTER to shut down.
PlexConnect : ***
PlexConnect : IP_self: 10.0.1.8
PlexGDM : ***
PlexGDM : looking up Plex Media Server
PlexGDM : ***
PlexGDM : servers discovered: 1
DNSServer : Failed to create socket on UDP port 53: [Errno 48] Address already in use
PlexConnect : DNSServer not alive. Shutting down.
 
Can anyone help, please!

iMac 21.5" Mid 2011, 16 GB RAM, 2.5 GHz Intel Core i5, Mountain Lion Server OS X 10.8.5 (12F45), Plex Media Server 0.9.9.9 on  IP 10.0.1.8

Promise Smartstor DS4600, RAID 5, 6GB, Firewire 800

AppleTV 3 wireless

Airport Extreme (5th Generation), Cat 6 to iMac

Samsung 37" Model LA37B530P7MXZK

iPhone 5s, iPad 2 both running latest Plex for iOS

Plexify 1.1 RC running on MacBook Pro 13" (Mid 2011), 16 GB RAM, Mavericks OS X 10.9.1 on IP 10.0.1.11


#2 Trudge

Trudge

    Gone off to greener pastures....

  • Members
  • PipPipPipPipPipPip
  • 9403 posts

Posted 02 June 2013 - 09:31 AM

ATV3

Firmware 5.2.1 (6025)

10.0.1.8

iMac Late 2011, Mountain Lion Server 10.8.3

10.0.1.8

iMac Late 2011, Mountain Lion Server 10.8.3

10.0.1.8

External Smartstor DS4600, Firewire

Plex Connect Templates from 6/1/2013 1.19 p.m.

 

When I run the script I get this:

 

 

hkmacs:PlexConnect-XML_templates admin$ sudo ./PlexConnect.py
PlexConnect : ***
PlexConnect : PlexConnect
PlexConnect : Press ENTER to shut down.
PlexConnect : ***
PlexConnect : IP_self: 10.0.1.8
PlexGDM : ***
PlexGDM : looking up Plex Media Server
PlexGDM : ***
PlexGDM : servers discovered: 1
DNSServer : Failed to create socket on UDP port 53: [Errno 48] Address already in use
PlexConnect : DNSServer not alive. Shutting down.
 
Can anyone help, please!

are you already running a DNS server on the box?


Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
Airplay & PlexConnect Targets: 4 x ATV3

#3 elan

elan

    Sheriff of Plexville

  • Sheriff Of Plexville
  • PipPipPipPipPipPip
  • 7412 posts
  • Location: Maui

Posted 02 June 2013 - 09:41 AM

You've probably enabled the DNS server portion of Mountain Lion Server. Turn it off.

 

2013-06-01 at 11.42.24 PM.png


Instagram: @elan
The Plex blog.
The wife's photography site.
The brother's photography blog.
The dog's twitter feed.


#4 HKMacs

HKMacs

    Dedicated Member

  • Members
  • PipPipPip
  • 108 posts
  • Location: Hong Kong SAR, PRC

Posted 02 June 2013 - 10:58 AM

Will that effect the DNS of my network?


iMac 21.5" Mid 2011, 16 GB RAM, 2.5 GHz Intel Core i5, Mountain Lion Server OS X 10.8.5 (12F45), Plex Media Server 0.9.9.9 on  IP 10.0.1.8

Promise Smartstor DS4600, RAID 5, 6GB, Firewire 800

AppleTV 3 wireless

Airport Extreme (5th Generation), Cat 6 to iMac

Samsung 37" Model LA37B530P7MXZK

iPhone 5s, iPad 2 both running latest Plex for iOS

Plexify 1.1 RC running on MacBook Pro 13" (Mid 2011), 16 GB RAM, Mavericks OS X 10.9.1 on IP 10.0.1.11


#5 HKMacs

HKMacs

    Dedicated Member

  • Members
  • PipPipPip
  • 108 posts
  • Location: Hong Kong SAR, PRC

Posted 02 June 2013 - 11:12 AM

And the web server!

 

Something is happening but I just get this message:

 

Accessing Trailers.

 

Then...

 

Trailers is unavailable.

 

This is my terminal output so far...

 

Attached file.

 

This is not going to work.

 

 


iMac 21.5" Mid 2011, 16 GB RAM, 2.5 GHz Intel Core i5, Mountain Lion Server OS X 10.8.5 (12F45), Plex Media Server 0.9.9.9 on  IP 10.0.1.8

Promise Smartstor DS4600, RAID 5, 6GB, Firewire 800

AppleTV 3 wireless

Airport Extreme (5th Generation), Cat 6 to iMac

Samsung 37" Model LA37B530P7MXZK

iPhone 5s, iPad 2 both running latest Plex for iOS

Plexify 1.1 RC running on MacBook Pro 13" (Mid 2011), 16 GB RAM, Mavericks OS X 10.9.1 on IP 10.0.1.11


#6 HKMacs

HKMacs

    Dedicated Member

  • Members
  • PipPipPip
  • 108 posts
  • Location: Hong Kong SAR, PRC

Posted 02 June 2013 - 11:15 AM

Sorry forgot to upload attachment

Attached Files


iMac 21.5" Mid 2011, 16 GB RAM, 2.5 GHz Intel Core i5, Mountain Lion Server OS X 10.8.5 (12F45), Plex Media Server 0.9.9.9 on  IP 10.0.1.8

Promise Smartstor DS4600, RAID 5, 6GB, Firewire 800

AppleTV 3 wireless

Airport Extreme (5th Generation), Cat 6 to iMac

Samsung 37" Model LA37B530P7MXZK

iPhone 5s, iPad 2 both running latest Plex for iOS

Plexify 1.1 RC running on MacBook Pro 13" (Mid 2011), 16 GB RAM, Mavericks OS X 10.9.1 on IP 10.0.1.11


#7 f00b4r

f00b4r

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2717 posts

Posted 02 June 2013 - 11:55 AM

You have set your PMS and DNS server to the same IP.

Your DNS server should be something else.


Plex @ aTV - think different: PlexConnect

-> the missing link between Plex Media Server and your AppleTV - 2 or 3, jailbroken or not.

How to report an issue: click here

Sources: click here

Wiki: click here

 


#8 Baa

Baa

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2729 posts

Posted 02 June 2013 - 02:40 PM

>> Your DNS server should be something else.

"something else": like the google DNSServer (8.8.8.8), the one of your ISP or the one in your router...


Plex @ aTV - think different: PlexConnect

-> the missing link between Plex Media Server and your AppleTV - 2 or 3, jailbroken or not.

plex forums: [PlexConnect] -- github: [latest Sources], [Wiki] -- donations (paypal): [US-$][EUR]


#9 HKMacs

HKMacs

    Dedicated Member

  • Members
  • PipPipPip
  • 108 posts
  • Location: Hong Kong SAR, PRC

Posted 02 June 2013 - 11:41 PM

If I do that Mac OS X Server won't work and my domain name won't resolve and I lose all connection to the internet.


iMac 21.5" Mid 2011, 16 GB RAM, 2.5 GHz Intel Core i5, Mountain Lion Server OS X 10.8.5 (12F45), Plex Media Server 0.9.9.9 on  IP 10.0.1.8

Promise Smartstor DS4600, RAID 5, 6GB, Firewire 800

AppleTV 3 wireless

Airport Extreme (5th Generation), Cat 6 to iMac

Samsung 37" Model LA37B530P7MXZK

iPhone 5s, iPad 2 both running latest Plex for iOS

Plexify 1.1 RC running on MacBook Pro 13" (Mid 2011), 16 GB RAM, Mavericks OS X 10.9.1 on IP 10.0.1.11


#10 HKMacs

HKMacs

    Dedicated Member

  • Members
  • PipPipPip
  • 108 posts
  • Location: Hong Kong SAR, PRC

Posted 03 June 2013 - 04:18 AM

Has anyone got a fully-configured Mac OS X Server and Plex Connect to work together?

 

If so, how?


iMac 21.5" Mid 2011, 16 GB RAM, 2.5 GHz Intel Core i5, Mountain Lion Server OS X 10.8.5 (12F45), Plex Media Server 0.9.9.9 on  IP 10.0.1.8

Promise Smartstor DS4600, RAID 5, 6GB, Firewire 800

AppleTV 3 wireless

Airport Extreme (5th Generation), Cat 6 to iMac

Samsung 37" Model LA37B530P7MXZK

iPhone 5s, iPad 2 both running latest Plex for iOS

Plexify 1.1 RC running on MacBook Pro 13" (Mid 2011), 16 GB RAM, Mavericks OS X 10.9.1 on IP 10.0.1.11


#11 f00b4r

f00b4r

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2717 posts

Posted 03 June 2013 - 06:48 AM

Have you tried putting a host files entry for trailers.apple.com (pointing towards your server local IP) in your server's host file?

Plex @ aTV - think different: PlexConnect

-> the missing link between Plex Media Server and your AppleTV - 2 or 3, jailbroken or not.

How to report an issue: click here

Sources: click here

Wiki: click here

 


#12 HKMacs

HKMacs

    Dedicated Member

  • Members
  • PipPipPip
  • 108 posts
  • Location: Hong Kong SAR, PRC

Posted 03 June 2013 - 08:57 AM

That sounds like good idea but I'm not quite sure how to put in the correct syntax. I have Gasmask installed.

 

Would I add something like this:

 

10.0.1.8 trailers.apple.com

 

?


iMac 21.5" Mid 2011, 16 GB RAM, 2.5 GHz Intel Core i5, Mountain Lion Server OS X 10.8.5 (12F45), Plex Media Server 0.9.9.9 on  IP 10.0.1.8

Promise Smartstor DS4600, RAID 5, 6GB, Firewire 800

AppleTV 3 wireless

Airport Extreme (5th Generation), Cat 6 to iMac

Samsung 37" Model LA37B530P7MXZK

iPhone 5s, iPad 2 both running latest Plex for iOS

Plexify 1.1 RC running on MacBook Pro 13" (Mid 2011), 16 GB RAM, Mavericks OS X 10.9.1 on IP 10.0.1.11


#13 f00b4r

f00b4r

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2717 posts

Posted 03 June 2013 - 09:02 AM

Yeah try that and then flush the DNS cache on your Mac (you may want to reboot the ATV as well to make sure).


Plex @ aTV - think different: PlexConnect

-> the missing link between Plex Media Server and your AppleTV - 2 or 3, jailbroken or not.

How to report an issue: click here

Sources: click here

Wiki: click here

 


#14 HKMacs

HKMacs

    Dedicated Member

  • Members
  • PipPipPip
  • 108 posts
  • Location: Hong Kong SAR, PRC

Posted 03 June 2013 - 09:06 AM

Tried entering both:

 

10.0.1.8 trailers.apple.com

 

and

 

10.0.1.8:32400 trailers.apple.com

 

Neither worked as I still seem to have the DNS in use by OS X DNS Server.


iMac 21.5" Mid 2011, 16 GB RAM, 2.5 GHz Intel Core i5, Mountain Lion Server OS X 10.8.5 (12F45), Plex Media Server 0.9.9.9 on  IP 10.0.1.8

Promise Smartstor DS4600, RAID 5, 6GB, Firewire 800

AppleTV 3 wireless

Airport Extreme (5th Generation), Cat 6 to iMac

Samsung 37" Model LA37B530P7MXZK

iPhone 5s, iPad 2 both running latest Plex for iOS

Plexify 1.1 RC running on MacBook Pro 13" (Mid 2011), 16 GB RAM, Mavericks OS X 10.9.1 on IP 10.0.1.11


#15 f00b4r

f00b4r

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2717 posts

Posted 03 June 2013 - 09:52 AM

DNS servers have nothing to do with ports, they only resolve host names to IP addresses.

You must have to add the entry in your OSX DNS server then, i do not know how to do this as i have never used it on OSX.

 

EDIT: If you look at the picture Elan posted it looks as if you can add an entry there.


Plex @ aTV - think different: PlexConnect

-> the missing link between Plex Media Server and your AppleTV - 2 or 3, jailbroken or not.

How to report an issue: click here

Sources: click here

Wiki: click here

 


#16 croaker_1

croaker_1

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 03 June 2013 - 03:45 PM

I had similar problems on my server. Turning DNS off was the only solution...except the next problem is that OS X server seems to always have an httpd process running on port 80 (for server management I think) even if you turn off the Websites service. I haven't had time to do much research on this (or if there is a way to turn it off) but my temporary solutions is:

 

1. Turn off the DNS service (mine is not doing much at the moment so it was safe for me)

2. Turn of the Websites service

3. Kill all httpd processes (in Terminal or Activity Monitor)

4. Quickly launch PlexConnect.py and hope it loads before launchd reloads httpd

 

I'd like to have a look at having OS X Server the work of DNSServer.py and WebServer.py (since OS X Server is already running these services). It should be possible to make this happen so you can use PlexConnect without disrupting the DNS and Websites services. I don't know if I possess the mad skills to make this happen but I'll have a look at it when I have the time.

 

Good luck!



#17 HKMacs

HKMacs

    Dedicated Member

  • Members
  • PipPipPip
  • 108 posts
  • Location: Hong Kong SAR, PRC

Posted 04 June 2013 - 12:04 AM

I think for simplicity I'm best with my original solution which is to start Airplay then start Plex Home Theatre/Plex. The only problem with it is that I can't use the Apple Remote as it controls the Apple TV rather than Plex Home Theatre and consequently kills Airplay. So I use the bluetooth keyboard for the iMac instead as a controller. Fine for me in a room that has the TV and the iMac in close proximity (Hong Kong!!)  but not much of a solution for someone in a house or large apartment where they might be in separate rooms. I prefer to use Plex Home Theatre over the iPad or iPhone apps as I like to see the synopsis on pause.


iMac 21.5" Mid 2011, 16 GB RAM, 2.5 GHz Intel Core i5, Mountain Lion Server OS X 10.8.5 (12F45), Plex Media Server 0.9.9.9 on  IP 10.0.1.8

Promise Smartstor DS4600, RAID 5, 6GB, Firewire 800

AppleTV 3 wireless

Airport Extreme (5th Generation), Cat 6 to iMac

Samsung 37" Model LA37B530P7MXZK

iPhone 5s, iPad 2 both running latest Plex for iOS

Plexify 1.1 RC running on MacBook Pro 13" (Mid 2011), 16 GB RAM, Mavericks OS X 10.9.1 on IP 10.0.1.11


#18 HKMacs

HKMacs

    Dedicated Member

  • Members
  • PipPipPip
  • 108 posts
  • Location: Hong Kong SAR, PRC

Posted 04 June 2013 - 07:04 AM

I had similar problems on my server. Turning DNS off was the only solution...except the next problem is that OS X server seems to always have an httpd process running on port 80 (for server management I think) even if you turn off the Websites service. I haven't had time to do much research on this (or if there is a way to turn it off) but my temporary solutions is:

 

1. Turn off the DNS service (mine is not doing much at the moment so it was safe for me)

2. Turn of the Websites service

3. Kill all httpd processes (in Terminal or Activity Monitor)

4. Quickly launch PlexConnect.py and hope it loads before launchd reloads httpd

 

I'd like to have a look at having OS X Server the work of DNSServer.py and WebServer.py (since OS X Server is already running these services). It should be possible to make this happen so you can use PlexConnect without disrupting the DNS and Websites services. I don't know if I possess the mad skills to make this happen but I'll have a look at it when I have the time.

 

Good luck!

 

 

Please let me know if you have any success. Good luck!


iMac 21.5" Mid 2011, 16 GB RAM, 2.5 GHz Intel Core i5, Mountain Lion Server OS X 10.8.5 (12F45), Plex Media Server 0.9.9.9 on  IP 10.0.1.8

Promise Smartstor DS4600, RAID 5, 6GB, Firewire 800

AppleTV 3 wireless

Airport Extreme (5th Generation), Cat 6 to iMac

Samsung 37" Model LA37B530P7MXZK

iPhone 5s, iPad 2 both running latest Plex for iOS

Plexify 1.1 RC running on MacBook Pro 13" (Mid 2011), 16 GB RAM, Mavericks OS X 10.9.1 on IP 10.0.1.11


#19 Chris A.

Chris A.

    Plex Ninja Master Extreme

  • Plex Ninja
  • PipPip
  • 38 posts
  • Location: Auckland, New Zealand

Posted 04 June 2013 - 07:54 PM

I had similar problems on my server. Turning DNS off was the only solution...except the next problem is that OS X server seems to always have an httpd process running on port 80 (for server management I think) even if you turn off the Websites service. I haven't had time to do much research on this (or if there is a way to turn it off) but my temporary solutions is:

 

1. Turn off the DNS service (mine is not doing much at the moment so it was safe for me)

2. Turn of the Websites service

3. Kill all httpd processes (in Terminal or Activity Monitor)

4. Quickly launch PlexConnect.py and hope it loads before launchd reloads httpd

 

I'd like to have a look at having OS X Server the work of DNSServer.py and WebServer.py (since OS X Server is already running these services). It should be possible to make this happen so you can use PlexConnect without disrupting the DNS and Websites services. I don't know if I possess the mad skills to make this happen but I'll have a look at it when I have the time.

 

Good luck!

See my post here if you wish to disable the httpd service from being loaded by launchd.

 

http://forums.plexap...80/#entry404999


PMS: 2U custom chassis running virtualised Ubuntu PMS on ESXi 5.5
Media Storage: 4U Norco 4224 running Ubuntu 12.04.03 LTS with 48TB ZFS pool
Desktop Clients: 2011 Mac mini, 13" MacBook Air

Set-top Clients: Roku 3, Roku 2 XS, Apple TV 3 (PlexConnect)

Mobile Clients: iPhone 5s, iPhone 4, Galaxy S2, iPad 3


#20 elstreif

elstreif

    Dedicated Member

  • Members
  • PipPipPip
  • 438 posts
  • Location: Canada

Posted 05 June 2013 - 07:42 AM

Same problem here. PlexConnect doesn't work because I'm running OS X Server (10.6.8).

:(
 Mac mini 1.83 GHz (OS X Server 10.6.8)  Panasonic 32" LCD  SONY HT-CT150 Home Theater System 




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users