Jump to content


Photo

Internet access plex server without logging into myPlex


  • Please log in to reply
5 replies to this topic

#1 PlexName001

PlexName001

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 28 July 2013 - 05:26 PM

HI everyone. Newbie here. Setup my Plex sever mannualy - port forward etc, but it never the service never works unless I log into MYplex.

 

Why is that and is there any way round this???

 

Its a great cross platform service. I paid for the app. I want to use it with out being tied to myPlex.

 

All suggestions welcome.



#2 sa2000

sa2000

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 6936 posts
  • Location: UK

Posted 28 July 2013 - 05:36 PM

HI everyone. Newbie here. Setup my Plex sever mannualy - port forward etc, but it never the service never works unless I log into MYplex.

 

Why is that and is there any way round this???

 

Its a great cross platform service. I paid for the app. I want to use it with out being tied to myPlex.

 

All suggestions welcome.

 

It is called Security !



#3 FrozenDragoon

FrozenDragoon

    Dedicated Member

  • Members
  • PipPipPip
  • 289 posts
  • Location: Texas

Posted 28 July 2013 - 11:12 PM

Yea, you'd have to change the Allowed Networks without Authentication setting to all, I'd imagine.



#4 PlexName001

PlexName001

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 29 July 2013 - 12:14 AM

Not having to login to a thrid party server and broadcast my home collection and server name and device name every time I wanted to play a song would far more secure.

 

Stupid to claim otherwise.

 

Tried the authentication setting.

 

There seems to be a hidden setting I think so that Plex will always be able to snoop/control what ever I do?

 

Such a shame as is a good product.

 

I do fel let down as I paif for the app but it is unusual unless logged into there servers.

 

I might see if I can get my money back if no one can help.



#5 FrozenDragoon

FrozenDragoon

    Dedicated Member

  • Members
  • PipPipPip
  • 289 posts
  • Location: Texas

Posted 29 July 2013 - 06:38 AM

I get that feeling, kind of. Not so much with Plex, but with everything coming out as a whole, I get it.

 

What "hidden setting" are you referring to? Plex has never given any indication that they could could possibly even care about what you're doing.

 

Since you don't have a PlexPass banner, I assume you have another account that you have purchased PlexPass on?  Otherwise, what app did you pay for?

 

If you want to argue semantics and security, it IS more secure to have a third party server handle authentication and then pass the connection off as point to point.  It's certainly a hell of a lot better than always leaving your library open to anyone who can stumble across port 32400 (or whatever port you have manually set), but I digress.  

 

And REALLY.  This is your first post and it's been up less than 24 hours and you're already "threatening" you might want your money back? REALLY? Ugh.  No one is forcing you to use Plex, there are numerous alternatives, for almost every platform.  

 

 

I got it to work.  But next time, don't be like that after just two responses.

 

 

What I did: (Credit to Newbie69 in this thread for pointing me in the right direction: http://forums.plexap...tworks-setting/)

 

open your preferences.xml located... somewhere.

http://wiki.plexapp....ences#Windows_2  (I'm guessing you're on Windows? You didn't specify)

 

add the line disableRemoteSecurity="1" to it. Restart your server.

 

In your app (again, which platform? iOS? Android? Plex/Web?) specify your server/port manually.

 

Note: I did the line in preferences.xml AND added my remote IP manually to the allowed IP list, I'm not positive both are needed, in truth, both should not be. I could not get it to work with only adding the IP, I had to add the line to preferences.xml.

You MAY have to add your remote IP to the list of allowed IPs, or just use 0.0.0.0/0.0.0.0 to allow everything. (That works on most things like Cisco routers, but I don't know if it'll work for Plex)

 

EDIT: I was able to get it working by using 0.0.0.0/0.0.0.0 (Every host in every subnet)



#6 convas

convas

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1057 posts

Posted 29 July 2013 - 01:45 PM

Not having to login to a thrid party server and broadcast my home collection and server name and device name every time I wanted to play a song would far more secure.

 

Stupid to claim otherwise.

 

Tried the authentication setting.

 

There seems to be a hidden setting I think so that Plex will always be able to snoop/control what ever I do?

 

Such a shame as is a good product.

 

I do fel let down as I paif for the app but it is unusual unless logged into there servers.

 

I might see if I can get my money back if no one can help.

 

If you do not want to  use myPlex for remote streaming then all you need to do is setup a VPN server on your network and connect through that, a lot of routers have built in VPN servers these days.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users