Jump to content


Photo

How to ignore other Plex Servers on my home network

block rooomate server remove privcy filter lan not share dont

  • Please log in to reply
12 replies to this topic

#1 JazJon

JazJon

    Member

  • Members
  • PipPip
  • 14 posts

Posted 10 August 2013 - 08:22 AM

My roommate and I both have Plex Server installed on our own personal home servers.    How can I block his Library from showing up in my Library?    I deleted his library from my library not thinking it would affect the library view from his end.    Well I just fired up Plex 24 hours later and my stuff has been removed and his stuff is showing up again.     I don't see any settings to ignore his Plex server so our stuff is not combined.    What am I missing?    Do I need to go as far as editing hosts files etc?   Please list some work around(s) if there are no native solutions.   I googled around and it sounds like this is a "feature" we can't edit.  What's the logic behind that?  Sharing is caring and all but yeah.



#2 gertgerman

gertgerman

    Dedicated Member

  • Members
  • PipPipPip
  • 498 posts

Posted 10 August 2013 - 08:41 AM

I'm only guessing but have you both tried logging into PMS and activating the setting authentication on local network required? I think that way as long as you both log into your respective plex accounts you'll only see your own servers. If you then share servers with each other they'll show under the shared libraries section.

#3 BigWheel

BigWheel

    One Who Keeps Turning

  • Plex Ninja
  • PipPipPipPipPipPip
  • 3251 posts
  • Location: Sacramento, CA

Posted 10 August 2013 - 08:42 AM

in the settings of both servers under the setting>myPlex (show advanced settings) check "require authentication on local networks" and the clients will only see the servers they are logged into. ( unless the client is on same computer as server in which case it does not need to login)


Note to self- awesome software coupled with awesome user community.. worth putting up with a minor annoyance now and then.

Correlation does not imply causation 

Perfume: The Story of a Murderer   a crazy movie but so good

Media Prep , Server Logs , MEDIA INFO , Why can't find that Plex folder on OS X


#4 JazJon

JazJon

    Member

  • Members
  • PipPip
  • 14 posts

Posted 10 August 2013 - 08:47 AM

I'll give it a try thanks.

 

Wrench Icon upper right (settings) > Show Advanced Settings (upper right) > myPlex(on the left) > Check box: Require authentication on local networks



#5 JazJon

JazJon

    Member

  • Members
  • PipPip
  • 14 posts

Posted 10 August 2013 - 08:50 AM

The other Server is still showing up in the upper right from the pull down menu.     Hopefully it goes away after he checks the same Require authentication box when he returns after the weekend.   

 

For now at least my Library should stay put.



#6 JazJon

JazJon

    Member

  • Members
  • PipPip
  • 14 posts

Posted 10 August 2013 - 08:53 AM

I just went to double check that my settings stayed.

 

Under Network, the box for Require authentication disappeared. 

 

I now see "List of networks that are allowed without auth" 127.0.0.1/255.255.255.255

 

What happened to the box I had checked?  The above wasn't there beore



#7 BigWheel

BigWheel

    One Who Keeps Turning

  • Plex Ninja
  • PipPipPipPipPipPip
  • 3251 posts
  • Location: Sacramento, CA

Posted 10 August 2013 - 09:32 AM

its under myPlex, not Network  when you check it, it fills in those values under Network

 

Attached File  requireauth.png   211.7KB   9 downloads


Note to self- awesome software coupled with awesome user community.. worth putting up with a minor annoyance now and then.

Correlation does not imply causation 

Perfume: The Story of a Murderer   a crazy movie but so good

Media Prep , Server Logs , MEDIA INFO , Why can't find that Plex folder on OS X


#8 JazJon

JazJon

    Member

  • Members
  • PipPip
  • 14 posts

Posted 10 August 2013 - 09:34 AM

Whoops!  Thanks my brain remembered it being under Network.   I edited my post above



#9 JazJon

JazJon

    Member

  • Members
  • PipPip
  • 14 posts

Posted 10 August 2013 - 09:38 AM

So in the upper right you can select Servers.   I see both mine and my roommates.

I'm able to select his, and changed the same setting to require authentication on local network.

 

What does it take to make it not show his server from the drop down menu?  (or will that not matter?)   Again the ultimate goal is to not see each others library or be able to add/delete each others library settings.



#10 BigWheel

BigWheel

    One Who Keeps Turning

  • Plex Ninja
  • PipPipPipPipPipPip
  • 3251 posts
  • Location: Sacramento, CA

Posted 10 August 2013 - 09:41 AM

thats odd, not sure.  if you changed it from your server interface you might have to restart the server. i have only checked if before when i was on the actual machine with the server


Note to self- awesome software coupled with awesome user community.. worth putting up with a minor annoyance now and then.

Correlation does not imply causation 

Perfume: The Story of a Murderer   a crazy movie but so good

Media Prep , Server Logs , MEDIA INFO , Why can't find that Plex folder on OS X


#11 gertgerman

gertgerman

    Dedicated Member

  • Members
  • PipPipPip
  • 498 posts

Posted 10 August 2013 - 04:54 PM

I think you can see his because he hasn't checked that option yet. Once he does, you shouldn't be able to see his. Unless he's shared his with you and then it'll be under shared libraries.

#12 JazJon

JazJon

    Member

  • Members
  • PipPip
  • 14 posts

Posted 11 August 2013 - 03:46 AM

By require authentication, isn't that what it means? (all systems signed into the same MyPlex email account?)

 

Why can't my Laptop's Plex Desktop app connect to my HTPC-Jon Plex server?

 

I tried both the Standard Laptop Plex Desktop app, and Native windows 8 app.    Both apps are signed into the same MyPlex email address.  

 

 

WtEcA8Wl.jpg

4WP6Bjal.jpg

 

 

 

My iOS Plex app connects just fine. (via WiFi same network)



#13 JazJon

JazJon

    Member

  • Members
  • PipPip
  • 14 posts

Posted 11 August 2013 - 10:52 AM

I found the final peace to remove the other server from showing up.

 

https://my.plexapp.com/servers

 

You can remove the other server on that page.

 

Done and Done!







Also tagged with one or more of these keywords: block, rooomate, server, remove, privcy, filter, lan, not, share, dont

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users