Jump to content


Photo

Windows specific instructions for creating and installing the SSL cert


177 replies to this topic

#1 2600Sam

2600Sam

    Member

  • Members
  • PipPip
  • 13 posts

Posted 01 September 2013 - 12:43 AM

I'm using windows 7 64bit, Plex Media Server 0.9.8.4.125-ffe2a5d, Python version 2.7.5 and PlexConnect (latest version 3 hours old right now)

 

all the information I'm using was taken from here: http://langui.sh/201...sl-plexconnect/

 

you will need

 

1) Win32 OpenSSL from here: http://slproweb.com/...n32OpenSSL.html

..I used the Win32 OpenSSL v1.0.1e (The light version does work, although not verified by me)

2) iPhone Configuration Utility from here: http://support.apple.com/kb/DL1466

3) get the attached cert.create.txt file attached to this post and rename to cert.create.bat because i can't upload a .bat file it's a .txt file

 

let's get started

 

install programs listed in 1 and 2!

 

create a directory, I called mine "Cert"

copy the cert.create.txt to that directory and rename it to cert.create.bat

<THE FOLLOWING IS WIN7 SPECIFIC>

in windows explorer navigate to the directory and LEFT click on the screen below the name of the file you renamed so that no files are highlighted

press the shift key and RIGHT click on the screen you should see

cmd-prmpt.jpg

click on Open command window here

this will open a command prompt and start you in this particular directory

</THE FOLLOWING IS WIN7 SPECIFIC>

 

<OTHER WINDOWS USER>

open up a cmd prompt

naviate to where you placed the cert.create.bat file

</OTHER WINDOWS USERS>

 

I don't use above Window 7 so your kind of on your own there...sorry

 

run the cert.create.bat (alternate retype all the commands in the cert.create.txt file)

Attached File  cert.create.txt   364bytes   4689 downloads

before the batch file finished it will run the trailers.der one of the 3 files that was just created

click on the Install Certificate . . .  button (required for the next part to work correctly) go with the defaults for installation on this.

you can close the command prompt window now!

 

Your Cert directory should have 5-6 files now

select and copy the trailers.pem file

navigate to where you have PlexConnect installed on your machine

go to the assets directory and then go to the certificates directory and paste the copy of the trailers.pem file there

 

Start the iPhone Configuration Utility

and click on Configuration Profiles

config.jpg

 

the click on New+

new.jpg

 

Give it a Name and Identifier

name.jpg

 

scroll down and click on Credentials

down.jpg

 

click on Configure

scroll down to find the certificate you just created and installed

look for trailers.apple.com

here.jpg

 

click on it, then click OK

 

Now plug in your aTV to a power source and to the computer

Click on your device and then the Configuration Profiles tab

hnh.jpg

 

click the install button

inst.jpg

 

this button will change to Remove if everything worked!

remove.jpg

 

close the iPhone Configuration Utility

disconnect the aTV from the computer and connect it to your TV

restart PlexConnect.py

and try the Trailers it should be working now ...maybe.....Hopefully!!

 

HTH

Sam



#2 riche543

riche543

    Member

  • Members
  • PipPip
  • 73 posts

Posted 01 September 2013 - 02:01 AM

Hi sam

 

Going to try this , Thanks for posting but cannot see:  (attached cert.create.txt file attached to this post)

maybe I am  missing something?

 

Edit: Maybe it was still uploading your post, I have all related links,pics etc etc now.

 

Cheers

   Riche



#3 2600Sam

2600Sam

    Member

  • Members
  • PipPip
  • 13 posts

Posted 01 September 2013 - 04:50 AM

Hi sam

 

Going to try this , Thanks for posting but cannot see:  (attached cert.create.txt file attached to this post)

maybe I am  missing something?

 

Edit: Maybe it was still uploading your post, I have all related links,pics etc etc now.

 

Cheers

   Riche

/scarasm

yeah for super high speed servers

/scarasm

 

good luck!!



#4 riche543

riche543

    Member

  • Members
  • PipPip
  • 73 posts

Posted 01 September 2013 - 05:16 AM

Thanks sam

 

All up & running again ..  :rolleyes:

 

Cheers..

 

  Riche



#5 Gdowler

Gdowler

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 01 September 2013 - 06:52 AM

Thank you!
This worked for me as well on both my Apple TV 3's
I appreciate you taking the time to break out the instructions for a Windows environment!!



#6 2600Sam

2600Sam

    Member

  • Members
  • PipPip
  • 13 posts

Posted 01 September 2013 - 07:45 AM

Thanks sam

 

All up & running again ..  :rolleyes:

 

Cheers..

 

  Riche

 

 

Thank you!
This worked for me as well on both my Apple TV 3's
I appreciate you taking the time to break out the instructions for a Windows environment!!

 

I'm just happy it works for other people :D

we all have windows panes but that doesn't mean we should suffer..LOL



#7 mitch1001

mitch1001

    Member

  • Members
  • PipPip
  • 10 posts

Posted 01 September 2013 - 02:12 PM

Worked for me too, thanks a lot. ;)

#8 Puchdog

Puchdog

    Member

  • Members
  • PipPip
  • 51 posts

Posted 01 September 2013 - 03:55 PM

Work for me also. Great instructions.



#9 huiszeeland

huiszeeland

    Member

  • Members
  • PipPip
  • 25 posts

Posted 01 September 2013 - 06:46 PM

I did all the above mentioned things but without luck. 

 

20:40:35 PlexConnect: started: 20:40:35
20:40:35 PlexConnect: IP_self: 192.168.1.163
20:40:35 DNSServer: started: 20:40:35
20:40:35 DNSServer: ***
20:40:35 DNSServer: DNSServer: Serving DNS on port 53.
20:40:35 DNSServer: intercept: ['trailers.apple.com', 'atv.plexconnect'] => 192.168.1.163
20:40:35 DNSServer: restrain: ['mesu.apple.com', 'appldnld.apple.com', 'appldnld.apple.com.edgesuite.net'] => 127.0.0.1
20:40:35 DNSServer: forward other to higher level DNS: 8.8.8.8
20:40:35 DNSServer: ***
20:40:35 WebServer: started: 20:40:35
20:40:35 WebServer: ***
20:40:35 WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
20:40:35 WebServer: WebServer: Serving HTTPS on 0.0.0.0 port 443.
20:40:35 WebServer: ***
20:40:35 PlexGDM: ***
20:40:35 PlexGDM: looking up Plex Media Server
20:40:35 PlexGDM: ***
20:40:36 PlexGDM: servers discovered: 1
20:40:36 XMLConverter: PlexGDM - PMS: 192.168.1.163:32400
20:42:44 DNSServer: DNS request received!
20:42:44 DNSServer: Source: ('192.168.1.200', 61870)
20:42:44 DNSServer: Domain: iphonesubmissions.apple.com
20:42:44 DNSServer: ***forward request
20:42:44 DNSServer: -> DNS response from higher level
 
 
[PlexConnect]
logpath = .
enable_dnsserver = True
ip_webserver = 0.0.0.0
prevent_atv_update = True
enable_plexconnect_autodetect = True
port_pms = 32400
port_webserver = 80
ip_plexconnect = 0.0.0.0
certfile = ./assets/certificates/trailers.pem
ip_dnsmaster = 8.8.8.8
loglevel = Normal
ip_pms = 192.168.178.10
enable_plexgdm = True
port_ssl = 443
port_dnsserver = 53
 
regards
rob


#10 Gdowler

Gdowler

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 01 September 2013 - 08:37 PM

@ Rob I could be wrong but I think your cert path is off

 

"certfile = ./assets/certificates/trailers.pem"

 

I believe the ./ denotes an IOS path whereas these instructions are specific to Windows

 

Try changing it to certfile = c:/assets/certificates/trailers.pem

 

But even that might be off. You want to make sure that this path points towards directly to the file. For instance I have Plex Connect installed right in my C:/ drive so my path looks like

 

certfile = C:PlexConnect/assets/certificates/trailers.pem

 

Good luck!



#11 huiszeeland

huiszeeland

    Member

  • Members
  • PipPip
  • 25 posts

Posted 01 September 2013 - 08:48 PM

thanks Gdowler, 

 

modified it now to :

 

[PlexConnect]
logpath = .
enable_dnsserver = True
ip_webserver = 0.0.0.0
prevent_atv_update = True
enable_plexconnect_autodetect = True
port_pms = 32400
port_webserver = 80
ip_plexconnect = 0.0.0.0
certfile = C:/PlexConnect-master/assets/certificates/trailers.pem
ip_dnsmaster = 8.8.8.8
loglevel = Normal
ip_pms = 192.168.178.10
enable_plexgdm = True
port_ssl = 443
port_dnsserver = 53
 

 

 

22:45:19 PlexConnect: started: 22:45:19
22:45:19 PlexConnect: IP_self: 192.168.1.163
22:45:19 DNSServer: started: 22:45:19
22:45:19 DNSServer: ***
22:45:19 DNSServer: DNSServer: Serving DNS on port 53.
22:45:19 DNSServer: intercept: ['trailers.apple.com', 'atv.plexconnect'] => 192.168.1.163
22:45:19 DNSServer: restrain: ['mesu.apple.com', 'appldnld.apple.com', 'appldnld.apple.com.edgesuite.net'] => 127.0.0.1
22:45:19 DNSServer: forward other to higher level DNS: 8.8.8.8
22:45:19 DNSServer: ***
22:45:19 WebServer: started: 22:45:19
22:45:19 WebServer: ***
22:45:19 WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
22:45:19 WebServer: WebServer: Serving HTTPS on 0.0.0.0 port 443.
22:45:19 WebServer: ***
22:45:19 PlexGDM: ***
22:45:19 PlexGDM: looking up Plex Media Server
22:45:19 PlexGDM: ***
22:45:20 PlexGDM: servers discovered: 1
22:45:20 XMLConverter: PlexGDM - PMS: 192.168.1.163:32400
 
still without luck, I am using python 2.75,  pms 09.8.5 , windows 7 64 , at3 5.3
 
I don't know what to change anymore, spend 5 hours now to get it working ..... :(


#12 Gdowler

Gdowler

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 01 September 2013 - 08:52 PM

I typo'd my cert path (keep in mind that this is mine as an example, double check yours to make sure it maps correctly)

 

certfile = C:\PlexConnect-master\assets\certificates\trailers.pem
 

I forgot that I had to turn the slashes around



#13 huiszeeland

huiszeeland

    Member

  • Members
  • PipPip
  • 25 posts

Posted 01 September 2013 - 08:58 PM

22:53:16 PlexConnect: started: 22:53:16
22:53:16 PlexConnect: IP_self: 192.168.1.163
22:53:16 DNSServer: started: 22:53:16
22:53:16 DNSServer: ***
22:53:16 DNSServer: DNSServer: Serving DNS on port 53.
22:53:16 DNSServer: intercept: ['trailers.apple.com', 'atv.plexconnect'] => 192.168.1.163
22:53:16 DNSServer: restrain: ['mesu.apple.com', 'appldnld.apple.com', 'appldnld.apple.com.edgesuite.net'] => 127.0.0.1
22:53:16 DNSServer: forward other to higher level DNS: 8.8.8.8
22:53:16 DNSServer: ***
22:53:17 WebServer: started: 22:53:17
22:53:17 WebServer: ***
22:53:17 WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
22:53:17 WebServer: WebServer: Serving HTTPS on 0.0.0.0 port 443.
22:53:17 WebServer: ***
22:53:17 PlexGDM: ***
22:53:17 PlexGDM: looking up Plex Media Server
22:53:17 PlexGDM: ***
22:53:18 PlexGDM: servers discovered: 1
22:53:18 XMLConverter: PlexGDM - PMS: 192.168.1.163:32400
22:53:49 DNSServer: DNS request received!
22:53:49 DNSServer: Source: ('192.168.1.200', 61638)
22:53:49 DNSServer: Domain: p35-buy.itunes.apple.com.akadns.net
22:53:49 DNSServer: ***forward request
22:53:49 DNSServer: -> DNS response from higher level
22:53:51 DNSServer: DNS request received!
22:53:51 DNSServer: Source: ('192.168.1.200', 63691)
22:53:51 DNSServer: Domain: ax.init-cdn.itunes.apple.com.akadns.net
22:53:51 DNSServer: ***forward request
22:53:51 DNSServer: -> DNS response from higher level
22:53:51 DNSServer: DNS request received!
22:53:51 DNSServer: Source: ('192.168.1.200', 61447)
22:53:51 DNSServer: Domain: itunes-cdn.apple.com.akadns.net
22:53:51 DNSServer: ***forward request
22:53:51 DNSServer: -> DNS response from higher level
22:54:16 DNSServer: DNS request received!
22:54:16 DNSServer: Source: ('192.168.1.200', 51224)
22:54:16 DNSServer: Domain: a771.da1.akamai.net
22:54:16 DNSServer: ***forward request
22:54:16 DNSServer: -> DNS response from higher level
22:54:17 DNSServer: DNS request received!
22:54:17 DNSServer: Source: ('192.168.1.200', 56638)
22:54:17 DNSServer: Domain: trailers.apple.com
22:54:17 DNSServer: ***intercept request
22:54:17 DNSServer: -> DNS response: 192.168.1.163


#14 huiszeeland

huiszeeland

    Member

  • Members
  • PipPip
  • 25 posts

Posted 01 September 2013 - 09:05 PM

i'm quite desperated at this stage.... :(



#15 drewbie

drewbie

    Dedicated Member

  • Members
  • PipPipPip
  • 341 posts

Posted 01 September 2013 - 11:05 PM

Huiszeeland,

 

If you browse to your Plexconnect machine on https://192.168.1.163

 

What happens?  Unless you have installed your certificate on the machine you are browsing from you should get a Certificate warning.

 

This proves that plexconnect can locate the trailers.pem file.

 

The next step would be to redo the profile on the apple TV to make sure that the trailers.cer file is correctly installed.



#16 Gdowler

Gdowler

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 02 September 2013 - 01:59 AM

What Drewbie is suggesting is spot on. In my case what ultimately being the culprit was the cert on the Apple TV. And the steps above resolved that although I did stumble at first.



#17 huiszeeland

huiszeeland

    Member

  • Members
  • PipPip
  • 25 posts

Posted 02 September 2013 - 05:30 AM

hi Drewbie and Gdowler  i am receiving an error saying that i need a certificate. Strange because i followed steps above to get certicicate on my atv 3. 

I will try again . btw i 've used https : //192.168.163:32400



#18 huiszeeland

huiszeeland

    Member

  • Members
  • PipPip
  • 25 posts

Posted 02 September 2013 - 05:43 AM

Hi Drewbie, i have modified my settings now :

 

[PlexConnect]
logpath = .
enable_dnsserver = True
ip_webserver = 0.0.0.0
prevent_atv_update = True
enable_plexconnect_autodetect = True
port_pms = 32400
port_webserver = 80
ip_plexconnect = 0.0.0.0
certfile = C:\PlexConnect-master\assets\certificates\trailers.pem
 ip_dnsmaster = 8.8.8.8
loglevel = Normal
ip_pms = 192.168.178.10
enable_plexgdm = True
port_ssl = 443
port_dnsserver = 53


#19 drewbie

drewbie

    Dedicated Member

  • Members
  • PipPipPip
  • 341 posts

Posted 02 September 2013 - 06:03 AM

Huiszeeland,

 

I suggest you stop cross posting everywhere, keep your issue to one thread its a lot eaiser for people to help you and see what has been suggested.  I would actually also suggest you start your own thread rather than jumping on someone else's as again its easier to see what answers are for you.

 

I have just posted more to one of the other threads you are posting on.  (http://forums.plexap...trailers/page-2)



#20 huiszeeland

huiszeeland

    Member

  • Members
  • PipPip
  • 25 posts

Posted 02 September 2013 - 06:15 AM

ok drewbie, from now on i will use one post.

sorry





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users