Jump to content


Photo

Synology 412+ and Sony Blu-ray BDP-S3100

synlogy s3100 99% CPU DLNA

  • Please log in to reply
4 replies to this topic

#1 veestan

veestan

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 16 September 2013 - 03:11 PM

Currently I am testing both mp4 and mkv of a Blu-ray ripped Les Miserables on my Synlogy 412+ and all devices including different versions of Windows, wife’s iPad, kid’s iPhones, Apple laptop, etc works great with my ripped versions. The only devices that are not working are our Blu-ray players which are all BDP-S3100. It will start to play and looks good for about 10 seconds then freezes.

 

Current software versions and configuration;

Plex Media Server: 0.9.8.6.175-88ffbb2

BDP-S3100: M14.R.0160

 

Plex/Web: 

LQ=8Mbps, 1080p

RQ=8Mbps, 1080p

Direct Play = checked

Direct Stream = checked

Allow Direct Play of AC3 Audio = checked

Nothing else checked or configured from default

Test MKV Movie = approx 9.31 GB

Test MP4 Movie = approx 8.77 GB

 

Hardware and Infrastructure;

Synlogy 412+ DSM Version DSM4.2-3211

NTP time.nist.gov (synced)

Duel CAT5E (bond) from 412+ directly to Netgear ProSafe 16 port 100mb Switch (FS116)

Switch via CAT5E to Blue-ray player (BDP-S3100)

 

Here is what I have found so far;

Blue-ray sees Media Station

Movie plays at 320kbs, Dolby Digital 5.1, shows up as M2TS

Synlogy CPU maxes at 96%

11 “Plex New Transcoder” processes start

 

If someone can tell me where the raw logs are I would be more then happy to attach. I couldn’t find anything in /var/log

 

Does anyone have any ideas because I've tried all I know to resolve?



#2 veestan

veestan

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 16 September 2013 - 07:36 PM

I read the BDP manual and I will try and rip the movie to M2TS and try that, it states that is the only one that supports Dolby Digital format files from a DNLA server . Has anyone configured a xml DLNA Profile for the BPD-S3100 and it work?

 

I am assuming that transcoding is happening because of some type of audio conversion. If I am making any changes of audio for testing purposes I only have to make changes on the Blu-ray player not the TV, correct? 



#3 veestan

veestan

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 17 September 2013 - 12:22 PM

Ok, tried another rip using DVDFAB 9.0.6.3 and changed the audio to 2 channel stereo, still stutters, cpu still at 99%;

 

MKV

Video Codec - h264

Resolution - 1920 x 1080

Frame Rate - Same as source

Audio Codec- AAC

Sample Rate - 48000 HZ

Audio Channels - Stereo

Bit Rate - 128 kbps

 

Any ideas. Guys/Gals I'm pretty new at this whole DVD ripping thing and any help would be greatly appreciated. Once I figure this out would like to get all the kids movies up on PMS because between the kids and dogs they don't last that long in our house.



#4 Trucker380

Trucker380

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 15 December 2013 - 09:31 AM

Hi veestan,

 

Here the same problem with PMS on Synology DS1513.

 

When I use Synology's Media Server and set the profile for my Sony BPD-S4100

to "generic DLNA device" the file shows up as "MKV" and streams correctly.

 

When I use the profile "Sony Blu-ray player" the file shows up as "M2TS" and it won't play.

My quess is that in the  "Sony Blu-ray player" profile, it tells the thing it can't play MKV so

transcoding starts. But the truth is it can play MKV, so if you select  "generic DLNA device"

there won't be transcoding and it wil play the MKV file.

 

How to stop transcoding in PMS, I don't know yet. If you do please let me know.



#5 veestan

veestan

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 16 December 2013 - 11:29 PM

Trucker380-

 

I gave up on mp4 and just went mkv for all my files. My Blu-ray players are working ok with this format so far. I am using the following to rip both Blu-ray's and regular DVDs;

 

DVDFab9

Version 9.1.1.5

Codec - h264

Frame Rate - 60

Encoding Method - Fast encoding

Video Quality - High Quality

 

 

Like I said dvd players, apple devises all seam to like this format.

 

 







Also tagged with one or more of these keywords: synlogy, s3100, 99% CPU, DLNA

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users