Jump to content


Photo

Running the new PlexConnect together with Apache


5 replies to this topic

#1 Joel Fernandes

Joel Fernandes

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 18 September 2013 - 01:45 PM

Hey guys,

 

I have Apache installed on my machine (OSX) and until the Apple's update regarding the certificates I was able to use PlexConnect together with Apache.

 

Now, I've updated the PlexConnect and it works perfectly if I shutdown Apache. However, I've made a few changes in order to have it working with Apache and no luck, I always get the "Trailers not available" message.

 

This is my Settings.cfg

 

[PlexConnect]
logpath = .
enable_dnsserver = True
prevent_atv_update = True
port_dnsserver = 53
enable_plexconnect_autodetect = True
port_pms = 32400
port_webserver = 8085
ip_plexconnect = 0.0.0.0
certfile = ./assets/certificates/trailers.pem
ip_dnsmaster = 8.8.8.8
loglevel = Normal
ip_pms = 192.168.178.10
enable_plexgdm = True
port_ssl = 443
ip_webserver = 0.0.0.0

 

And this is the setting I have on my Apache configuration for the 80 port forwarding

 

<VirtualHost *:80>
    ServerName trailers.apple.com
    ProxyPreserveHost On
    ProxyPass / http://192.168.0.14:8085/
    ProxyPassReverse / http://192.168.0.14:8085/
</VirtualHost>

 

What am I missing?

 

Thanks in advance



#2 wahlman.j

wahlman.j

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2795 posts
  • Location: Chicago

Posted 18 September 2013 - 02:59 PM

You must change your apache port to something besides port 80. Look here for your answer http://forums.plexap...bserver-on-osx/

 

I run osx as well and have a webserver running 24/7 on a dif port such as 5555 since trailers uses port 80 by default and there is no way to change that on atv2/3


OSX apps : OpenPlex // UAS installer OpenPlex by Wahlman.j (Source Code), CyberGhost84 (GUI) & Flipman6 (Obj-C)

iOS Firmware links: Firmware // Firmware Limits OpenPlex app or assistance donations appreciated US-$ // EUR

Click my username and message me to setup a time if you need help installing or troubleshooting anything. Teamviewer.gif <----Install this first for assistance.

(1) Locally owned PMS Mac 10.9.5 i7-4770k haswell 32gb 1866 ddr3 with e-sata rocket raid 2302 Raid-5 set of (4) 5TB HD (15TB usable) in a Trayless enclosure iStarUSA v7age420-es (1) Remotely owned PMS Window 8 internal raid-5 set with (6) 500gb disks (2.5tb usable) (3) Jailbroken (portable PlexConnect host's) aTV2's on iOS 5.3 (6.1.4) running my modified dev-theme for Big posters and All Libraries (merged lib's) & (9) aTV3's on mixed iOS all running my custom theme (1) iPad 3, (1) iPad mini 2 retina, (2) iPhone 4s, (1) iPhone 4 all jailbroken on 8.1.1 except for iPhone 4 jailbroken on 7.1.2 all running latest official Plex for iOS. Airbubble.apk (265 initial buffer frames) for droid or airfloat for iOS devices to airplay aTV audio to Sol Republic Tracks HD V10.


#3 iice64

iice64

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 18 September 2013 - 03:18 PM

Hello Joel,
you have to enable ssl in conf/http.conf and insert VirtalHosts in conf/extra/httpd-vhosts.conf

First entry is for your default domain with your certificates for your domain
Second entry is for trailers.apple.com with your certificates for atv
Third entry is for atv.plexconnect with your certificates for atv

 

Change Settings.cfg

[PlexConnect]
port_ssl = 8448  or anything else, but must not 443, because apache2 is now listing on port 443

 

Apache2 now redirects all request for trailers.apple.com and atv.plexconnect to PlexConnect Webserver via http on port 8085

 

best regards

iice64

<VirtualHost *:443>
    SSLEngine on
    SSLProtocol -ALL +SSLv3 +TLSv1
    SSLCipherSuite ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:!LOW:!SSLv2:!EXPORT    
    SSLCertificateFile      "<your_path>/server.crt"
    SSLCertificateKeyFile   "<your_path>/server.key"

    DocumentRoot "<your_path>/www"
</VirtualHost>

<VirtualHost *:443>
    SSLEngine on
    SSLProtocol -ALL +SSLv3 +TLSv1
    SSLCipherSuite ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:!LOW:!SSLv2:!EXPORT    
    SSLCertificateFile      "<your_path>/trailers.cer"
    SSLCertificateKeyFile   "<your_path>/trailers.key"
    
    ProxyPreserveHost On
    ProxyPass / http://192.168.0.14:8085/
    ProxyPassReverse / http://192.168.0.14:8085/
    ServerName trailers.apple.com
</VirtualHost>

<VirtualHost *:443>
    SSLEngine on
    SSLProtocol -ALL +SSLv3 +TLSv1
    SSLCipherSuite ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:!LOW:!SSLv2:!EXPORT    
    SSLCertificateFile      "<your_path>/trailers.cer"
    SSLCertificateKeyFile   "<your_path>/trailers.key"
    
    ProxyPreserveHost On
    ProxyPass / http://192.168.0.14:8085/
    ProxyPassReverse / http://192.168.0.14:8085/
    ServerName atv.plexconnect
</VirtualHost>

 


#4 drewbie

drewbie

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1108 posts
  • Location: Melbourne Australia

Posted 18 September 2013 - 11:02 PM

Dont forget that PlexCOnnect had an update before the HTTPS change by apple that requires you to also have atv.plexconnect as a host name to be redirected to plexconnect if you are not using plexconnect on port 80.

 

<VirtualHost *:80>
ServerName atv.plexconnect
ProxyPreserveHost On
ProxyPass / http://192.168.0.14:8085/
ProxyPassReverse / http://192.168.0.14:8085/
</VirtualHost>


#5 tcviper

tcviper

    Plex Ninja

  • Plex Ninja
  • PipPipPipPipPip
  • 816 posts
  • Location: Netherlands

Posted 14 October 2013 - 12:54 PM

Can someone please sum up the complete guide on how to make this work now with SSL and the whole thing on OSX Server? Cause im totally lost here with all the different documents and things to do :(



#6 guitarman_usa

guitarman_usa

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 23 April 2015 - 08:24 AM

Hey everyone, not sure if you're still looking for a writeup answer for this one, but I ran into this same issue and solved it using http redirects.  Apache is still running on port 80/443 but uses redirects to forward requests for trailer.apple.com to the plexconnect server listening on ports 9999 and 8443.  Full step by step writeup is over on my blog.  http://www.linuxtoolbox.ninja/?p=60


  • guitarman_usa likes this



Reply to this topic