Jump to content


Photo

No sound when streaming mkv files


  • Please log in to reply
5 replies to this topic

#1 emeralds

emeralds

    Member

  • Members
  • PipPip
  • 10 posts

Posted 27 September 2013 - 12:32 AM

Is there an easy fix on this that doesn't involve modifying the files themselves? Streaming off a mac mini to a roku 3. No sound out of the tv or the headphone jack. No external speakers hooked up to the tv.



#2 ljunkie

ljunkie

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2021 posts
  • Location: Washington

Posted 27 September 2013 - 01:35 AM

Is there an easy fix on this that doesn't involve modifying the files themselves? Streaming off a mac mini to a roku 3. No sound out of the tv or the headphone jack. No external speakers hooked up to the tv.

 

Is audio stream DTS? If so and the device plugged directly into the Roku doesn't support DTS, then you must disable the DTS option in the Plex Audio Preferences on the Roku


plexWatch (v0.2.8): GitHub :: plexForums: linux/osx/other :: windows

RARflix (v3.2.4) plex/Roku: rarflix.com :: help forum :: wishlist :: rarflix tools

Donations Welcome! roku logs howto

#3 emeralds

emeralds

    Member

  • Members
  • PipPip
  • 10 posts

Posted 27 September 2013 - 04:57 AM

Where do I disable DTS? I don't see any option for that in the preferences.



#4 ljunkie

ljunkie

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2021 posts
  • Location: Washington

Posted 27 September 2013 - 05:24 AM

Where do I disable DTS? I don't see any option for that in the preferences.


Maybe not the issue then. Do you see an option for 5.1? If not then your Roku is already set to stereo. Can you try forcing the video to transcode? If audio still fails, then it's definitely another issue.
plexWatch (v0.2.8): GitHub :: plexForums: linux/osx/other :: windows

RARflix (v3.2.4) plex/Roku: rarflix.com :: help forum :: wishlist :: rarflix tools

Donations Welcome! roku logs howto

#5 emeralds

emeralds

    Member

  • Members
  • PipPip
  • 10 posts

Posted 27 September 2013 - 05:33 AM

Transcode works. Never considered it because I thought that was worse quality than direct play. So is there still something else I can do?



#6 ljunkie

ljunkie

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2021 posts
  • Location: Washington

Posted 27 September 2013 - 06:00 AM

Transcode works. Never considered it because I thought that was worse quality than direct play. So is there still something else I can do?


Maybe the DTS toggle in plex never made it to the official channel? Try the PlexTest channel. You should see an option for Audio Prefs: Ac3 and or DTS. I really thought that had made it to the official channel though.

You could also try my modified channel which includes trailers and a bit more :) Link is in my signature. I'll be pushing a new version soon with another set of nice updates.
plexWatch (v0.2.8): GitHub :: plexForums: linux/osx/other :: windows

RARflix (v3.2.4) plex/Roku: rarflix.com :: help forum :: wishlist :: rarflix tools

Donations Welcome! roku logs howto




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users