Jump to content


Photo

Stream to Player over LAN without myPlex


  • Please log in to reply
9 replies to this topic

#1 JackieUK

JackieUK

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 15 October 2013 - 08:38 AM

Up until about a year ago I never had this issue but since then have had to enable UpNP on my router and also sign into myPlex on both the server and client PCs in order to get streaming to work :wacko: . My issue is that I want to disable UpNP due to the security risks and would like to only stream over my local LAN using manual port forwards. Is it even possible to do this without signing into myPlex?

 

Really hoping someone on here can help or point me in the right direction. I would like to stream from a Plex Media Server (running on a server PC) to a Plex Media Player installation (on a different client PC) over my LAN without using myPlex or UpNP. (Both PC's are running Windows 7.) 

 

I have read a number of threads on these forums and also followed the guide found here to no avail. I've setup port forwards (both TCP and UDP) from port 32400 to port 32400 to my server PC. I did also ensure that "Require authentication on local networks" is not checked on the Plex Media Server.

 

Any help would be greatly appreciated. Thanks in advance for taking the time to read this.  :)



#2 George Jolliffe

George Jolliffe

    Rock Star

  • Members
  • PipPipPipPipPip
  • 744 posts
  • Location: UK

Posted 15 October 2013 - 09:23 AM

You do not need to be signed into myplex on either client or server to use plex privately. Consequently you don't need to setup any port forwarding rules on your router.

 

Are you saying the client can't see the server when you sign out?



#3 JackieUK

JackieUK

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 15 October 2013 - 09:46 AM

You do not need to be signed into myplex on either client or server to use plex privately. Consequently you don't need to setup any port forwarding rules on your router.

 

Are you saying the client can't see the server when you sign out?

 

Thanks for your reply George. Correct - client can't see the server when I sign out out of myPlex. Only way I can get it to work is by using myPlex.

 

When I sign out of myPlex on both the client and server and disable UpNP on my router - whether I use manual port forwarding or not - I can't get the client to see the server. This started happening around a year ago or so (used Plex for about a year before that over my LAN without issue).



#4 George Jolliffe

George Jolliffe

    Rock Star

  • Members
  • PipPipPipPipPip
  • 744 posts
  • Location: UK

Posted 15 October 2013 - 09:54 AM

Ok, well firstly remain signed out of myplex on both client and server and make an attempt with any software firewall's disabled (we can enable them again later but for testing fully disable) also make sure windows firewall is disabled. Its important that this step is completed so if you can't find an obvious 'disable' option then please let us know what software firewall you're using so we can find another way to disable it.

 

You can completely ignore the port forwarding on the router for the moment. It won't have any impact on the local connection which we are trying.



#5 JackieUK

JackieUK

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 15 October 2013 - 12:08 PM

Ok, well firstly remain signed out of myplex on both client and server and make an attempt with any software firewall's disabled (we can enable them again later but for testing fully disable) also make sure windows firewall is disabled. Its important that this step is completed so if you can't find an obvious 'disable' option then please let us know what software firewall you're using so we can find another way to disable it.

 

You can completely ignore the port forwarding on the router for the moment. It won't have any impact on the local connection which we are trying.

 

Ok, thanks for the suggestions. I'll give this a go as soon as I get home. I'm using Norton Internet Security on both PCs. Will try disabling both Windows firewall + the Norton firewall and will post the result back here.



#6 JackieUK

JackieUK

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 16 October 2013 - 05:35 AM

Ok, well firstly remain signed out of myplex on both client and server and make an attempt with any software firewall's disabled (we can enable them again later but for testing fully disable) also make sure windows firewall is disabled. Its important that this step is completed so if you can't find an obvious 'disable' option then please let us know what software firewall you're using so we can find another way to disable it.

 

You can completely ignore the port forwarding on the router for the moment. It won't have any impact on the local connection which we are trying.

 

 

Ok, thanks for the suggestions. I'll give this a go as soon as I get home. I'm using Norton Internet Security on both PCs. Will try disabling both Windows firewall + the Norton firewall and will post the result back here.

 

So I signed out of myPlex on both the Media Server and Media Player, disabled Windows Firewall and the Norton firewall on both PCs, restarted the network connection on both machines and restarted the Media Server and the Media Player - still no joy. Media Player just shows "Search" in the menus. (I'm using Plex Aeon skin on the player BTW not that I think that would make a difference).



#7 George Jolliffe

George Jolliffe

    Rock Star

  • Members
  • PipPipPipPipPip
  • 744 posts
  • Location: UK

Posted 16 October 2013 - 01:03 PM

If you get the private IP address of each machine and then try to ping one from the other.

 

Verify that you can ping server-to-client and client-to-server.



#8 convas

convas

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 1055 posts

Posted 16 October 2013 - 01:15 PM

Do you have "Require authentication on local networks" ticked in PMS ?

 

If so try unticking it.



#9 JackieUK

JackieUK

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 17 October 2013 - 07:35 AM

If you get the private IP address of each machine and then try to ping one from the other.

 

Verify that you can ping server-to-client and client-to-server.

 

ping server-to-client and client-to-server were both successful.

 

 

Do you have "Require authentication on local networks" ticked in PMS ?

 

If so try unticking it.

 

it was already unticked.



#10 George Jolliffe

George Jolliffe

    Rock Star

  • Members
  • PipPipPipPipPip
  • 744 posts
  • Location: UK

Posted 17 October 2013 - 09:04 AM

Do you have any other plex clients in your home? Another computer? iOS/Android device?

 

I'd be interested to know if they see the server broadcasting itself. Again, make sure you try with Norton disabled if it doesn't work first time.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users