Jump to content


Photo

Plex App doesn't work on OSX Maverick

Mavericks

  • Please log in to reply
11 replies to this topic

#1 bignotch

bignotch

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 25 October 2013 - 02:02 AM

The PMS works just fine. But the actual player always quite unexpectedly. I did a fresh install of mavericks yesterday and it STILL quits everything I start it up. I can even launch it at all anymore.

#2 hoomanbahrani

hoomanbahrani

    Member

  • Members
  • PipPip
  • 16 posts

Posted 25 October 2013 - 02:40 AM

I'm having issues as well. I can move around and play, but once I play a TV show, or movie, then try to ESC back a menu, it freezes. 



#3 magnusalex

magnusalex

    Member

  • Members
  • PipPip
  • 38 posts

Posted 25 October 2013 - 09:23 AM

Could it be that you experience the same error as I do? Check this thread: http://forums.plexap...ection-failure/

 

Nothing to do with Mavericks, but it happened at the same time as Mavericks was released - so you might THINK it's Mavericks.



#4 Powertowerpro

Powertowerpro

    Dedicated Member

  • Members
  • PipPipPip
  • 193 posts
  • Location: SF

Posted 25 October 2013 - 05:00 PM

Plex needs to support full screen. The best part of Mavericks is that displays can have separate spaces. When this option is enabled the white menu bar is visible over the interface. We need a fix for this ASAP.



#5 Zillion_

Zillion_

    Member

  • Members
  • PipPip
  • 14 posts
  • Location: Belgium

Posted 26 October 2013 - 09:24 AM

Temporarily switch to another skin, e.g. Simplex or the default skin; the problem is in PlexAEON.



#6 d112570

d112570

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 26 October 2013 - 09:57 AM

I can play tv-shows all day, but when I watch youtube movies online like Fox, after so many minutes it freezes, its not random, its a fixed freeze.



#7 Herr+Trigger

Herr+Trigger

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 27 October 2013 - 09:04 PM

I'm having an issue as well.  Not sure if it's simply a setting that i've borked in the process of trying to fix things, or if it's the new Mavericks os x update or something to do exclusively with the Plex media player.  

 

I'm unable to play any videos with plex anymore. 

 

My setup:

 

late 2012 mac mini 2.6 GHz core i7

16 GB ram

Intel HD graphics 4000

OS X (10.9)

OS is on an ssd (crucial I think, it's been awhile since i installed it),

4x western digital elements external USB drives (2x2 TB,2x1TB)

 

I just deleted and reinstalled the plex client so I'm running the latest version.

 

doesn't seem to matter what sort of format I try to play, .mkv .avi .mp4 I get nothing, no video or audio at all anymore.

 

The app previously played everything I threw at it flawlessly.  Any suggestion on what to try to fix this?

 

The app doesn't crash when i try to open a video, it just open up to the menu and stops, I'm able to navigate the menu fine, but nothing i've done seems to get me anywhere.



#8 wahlman.j

wahlman.j

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2594 posts
  • Location: Chicago

Posted 29 October 2013 - 04:30 AM

Im working fine here on mavericks.

OSX apps : OpenPlex // UAS installer  // GIT CRIT FIX // Python Updater // Purge OpenPlex by Wahlman.j (Source Code), CyberGhost84 (GUI) Flipman6 (Obj-C)

iOS Firmware links: Firmware //  Firmware Limits // OSX // aTVPlexConnect host
Donations for OpenPlex app or my assistance US-$ // EUR  Click my username and send me a message to setup a time if you need help installing or troubleshooting anything. remoteassistance.gif <-----Install this first so I can assist you if desired.
If you enjoy any of the apps and cannot afford to donate you can always share your plex library. Just login to the site here http://plex.tv then click launch, click your user icon at the top right then click users in the dropdown, click friends then invite my name Wahlman.j (You can also do it from iOS devices as well, and maybe others)

 

(1) Locally owned PMS Mac 10.9.5 i7-4770k haswell 16gb ddr3 with e-sata rocket raid 2302 Raid-10 set of (4) 2TB HD (4TB usable) in a Trayless enclosure iStarUSA v7age420-es (1) Remotely owned PMS Window 8 internal raid-5 set with (6) 500gb disks (2.5tb usable) 

(2) Jailbroken (portable PlexConnect host's) aTV2's on iOS 5.3 (6.1.4) running my modified dev-theme for Big posters and All Libraries (merged lib's) & (4) aTV3's on iOS 6.2 (7.1.2) all running CyberGhost84's custom theme

(1) iPad 3, (1) iPad mini 2 retina, (2) iPhone 4s, (1) iPhone 4 all jailbroken on 8.1.1 except for iPhone 4 jailbroken on 7.1.2 all running latest official Plex for iOS. How I automate my Home on a budget using only iOS devices for control


#9 Lasmamoe

Lasmamoe

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 01 November 2013 - 06:37 PM

I'm having the exact same issue as 'Herr+Trigger'.

 

The app opens up fine, but the video doesn't play. Theres only a black screen and a menu on the left.

 

Plex worked fine for me until i updated to Mavericks, and it's really annoying because i have searched for hours, and Plex is the only app that is able to play 1080 mkv files without any lag.



#10 Almarma

Almarma

    Member

  • Members
  • PipPip
  • 37 posts

Posted 01 November 2013 - 08:02 PM

Same problem here :'(. The other day I tried, as somebody posted here in the forum, to go to Preferences -> Mission Control, and disable "The screens has different spaces" (sorry if the text is not 100% exact! because my Mac is in Spanish ;). After doing that and rebooting, it worked with a clean Plex app. Then I changed the skin to Retroplex, and the problem came back. Then I deleted the Retroplex folder, but the problem is here yet: it crash continuously offering to send a report to Apple. I'll try to delete it again, including the "Library -> Application support -> Plex" to see if it works again with the default skin and settings :(

UPDATE: after deleting that folder, deleting the .app, and copying a new copy, the problem is still there for me. Really sad :(

#11 Lasmamoe

Lasmamoe

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 02 November 2013 - 09:15 PM

Almarma: I just tried unchecking the "display has different spaces" and it didn't work :/



#12 Pezman

Pezman

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 20 November 2013 - 06:11 AM

I have the same issue.   I've detailed what I tried here.  I'm up for any advice: http://forums.plexap...media/?p=502783







Also tagged with one or more of these keywords: Mavericks