Jump to content


Photo

OSX Mavericks (OSX Server 3.0) plexconnect not working

Mavericks OSX Server PlexConnect

5 replies to this topic

#1 jansink

jansink

    Member

  • Members
  • PipPip
  • 39 posts

Posted 27 October 2013 - 01:52 PM

Hi,

 

I have upgraded to Mavericks (clean install) and run OSX server 3.0 on it with it's own dns and webserver. On Mountain Lion this setup works great with PlexConnect, but now it is not working anymore... :-(

 

  • Your ATV model (2 or 3) and firmware version (found under the ATV settings > general > about > Apple TV software):
    6.0.1 (6646.80.1)

  • The DNS server set on the ATV (found under the ATV settings > general > network > DNS):
    10.0.1.2

  • The device and operating system (including version number) that PlexConnect is installed on:
    OSX Mavericks 10.9 (OSX Server 3.0)

  • The local IP address of the device that PlexConnect is installed on:
    10.0.1.2

  • The device and operating system (including version number) that the Plex media server (PMS) is installed on:
    OSX Mavericks 10.9 (OSX Server 3.0)

  • The Plex media server (PMS) version number you are running (do not put 'latest'):
    0.9.8.9

  • The local IP address of the device that the Plex media server (PMS) is installed on:
    10.0.1.2

  • The PlexConnect version number. If using Github source then a time and date of download (look at the creation date of the folder) and if you are using any testing branch e.g. the Elan/PlexInc one.
    Github source 27-10-2013 14:45

  • The content of your 'Settings.cfg' file (if you do not have this file you are running an old version, please update)

    [PlexConnect]
    enable_webserver_ssl = False 
    logpath = .
    enable_dnsserver = False 
    prevent_atv_update = True
    port_dnsserver = 53
    enable_plexconnect_autodetect = False 
    port_pms = 32400
    port_webserver = 9999 
    ip_plexconnect = 10.0.1.2 
    certfile = ./assets/certificates/trailers.pem
    ip_dnsmaster = 10.0.1.2 
    loglevel = Normal
    ip_pms = 127.0.0.1 
    enable_plexgdm = True
    port_ssl = 443
    ip_webserver = 10.0.1.2
     
  • detailed description of the issue (the clearer you can make this the better):
    Unable to connect to my pms server. In log: No Response from Plex Media Server

    14:49:02 PlexAPI: We failed to reach a server. Reason: no host given
    On my AppleTV when clicking on Trailers I get the message "Trailers unavailable" on screen instantly.
    This is the response i got from PlexConnect:

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<atv>
<body>
<dialog id="com.sample.error-dialog">
<title>PlexConnect</title>
<description>No Response from Plex Media Server</description>
</dialog>
</body>
</atv>
  • Ensure you post your 'PlexConnect.log' file to pastebin and post the link ('PlexConnect.log' is located in your PlexConnect folder). If possible, follow these steps to create a "more detailed fresh" one:
    http://pastebin.com/8XbCZ4pP



#2 bwynants

bwynants

    Dedicated Member

  • Members
  • PipPipPip
  • 293 posts
  • Location: Belgium

Posted 27 October 2013 - 02:58 PM

You must have used a vhost in apache that is disabled by the server upgrade. Check your apache configurations trailer.apple.com must be redirected to port 9999

#3 jansink

jansink

    Member

  • Members
  • PipPip
  • 39 posts

Posted 27 October 2013 - 03:18 PM

I have:

 

RequestHeader set User-Agent AppleTV

ProxyRequests off

ProxyPass / http://trailers.apple.com:9999/

ProxyPassReverse / http://trailers.apple.com:9999/

 

In both my 0000_any_80_trailers.apple.com.conf and 0000_any_80_atv.plexconnect.conf, is that what you mean?



#4 bwynants

bwynants

    Dedicated Member

  • Members
  • PipPipPip
  • 293 posts
  • Location: Belgium

Posted 28 October 2013 - 08:54 AM

and how is apache loading those files? did you uncomment something in the httpd.conf file in the past? Mavericks has made it comment again ....



#5 jsink

jsink

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 01 November 2013 - 11:19 AM

I uncomment that in httpd.conf, but without succes.... any other suggestions?



#6 f00b4r

f00b4r

    Plex Star

  • Members
  • PipPipPipPipPipPip
  • 2717 posts

Posted 16 December 2013 - 08:52 PM

https://forums.plexa...dnode/?p=510730


Plex @ aTV - think different: PlexConnect

-> the missing link between Plex Media Server and your AppleTV - 2 or 3, jailbroken or not.

How to report an issue: click here

Sources: click here

Wiki: click here

 




Reply to this topic



  



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users