Jump to content


Photo

The Damn Display Sleep Option


  • Please log in to reply
8 replies to this topic

#1 Kevin Jr

Kevin Jr

    Member

  • Members
  • PipPip
  • 23 posts

Posted 10 March 2010 - 12:08 AM

I know this topic has been mentioned many times, especially by me.

I would like to add a note however.

WHEN and IF the display option is fixed, I was hoping that the programers won't forget to sleep the PLEX program as well. Because many of us use the background music option, if PLEX isn't put to sleep as well, then the background music will still play through the output.

So, just a heads up on an additional option that would be worthy.

Thanx.

#2 elan

elan

    Sheriff of Plexville

  • Sheriff Of Plexville
  • PipPipPipPipPipPip
  • 7411 posts
  • Location: Maui

Posted 10 March 2010 - 03:07 AM

Hi Kevin, thanks for the post. Can you point me to a Lighthouse bug on the problems you're having (if there is one) or a forum topic?

Thanks :)

Instagram: @elan
The Plex blog.
The wife's photography site.
The brother's photography blog.
The dog's twitter feed.


#3 skyy99

skyy99

    Member

  • Members
  • PipPip
  • 41 posts

Posted 27 March 2010 - 08:55 PM

Hi Kevin, thanks for the post. Can you point me to a Lighthouse bug on the problems you're having (if there is one) or a forum topic?

Thanks :)


There is a bug here, but it seems to be for when the system sleep function works and keeps sleeping after wake.

What I think Kevin is talking about is the problem where "sleep display" doesn't work, as described here. In fact, the display does sleep for about 5 seconds, but then something triggers the display to come back (and thus not sleep). So it's not much of an energy saver.

If it's not already obvious, I'm experiencing the same issue and would be more than happy to file a lighthouse bug if necessary. I didn't see it in lighthouse yet.

Thanks,
Matt

#4 Abbot

Abbot

    Member

  • Members
  • PipPip
  • 12 posts

Posted 03 April 2010 - 03:16 AM

Ditto.

/I think i've chimed in on every single forum thread regarding this issue (there've been at least 3) - A bag of the finest kava to the champion that fixes this issue.

#5 elan

elan

    Sheriff of Plexville

  • Sheriff Of Plexville
  • PipPipPipPipPipPip
  • 7411 posts
  • Location: Maui

Posted 03 April 2010 - 03:18 AM

Ha ha...duly noted :)

Instagram: @elan
The Plex blog.
The wife's photography site.
The brother's photography blog.
The dog's twitter feed.


#6 Kevin Jr

Kevin Jr

    Member

  • Members
  • PipPip
  • 23 posts

Posted 18 April 2010 - 06:25 PM

Sorry guys been busy with life for a bit...

I didn't notice the responses from everyone.

And because I'm so green , i do not even know what the Lighthouse thingy is. Best guess it is for error reporting. I would be happy to write something like this up if no one has yet. I think this bug is a worthwhile fix and could make PLEX a one stop shop multimedia platform. I am getting reading to move into a new house and want to set up the entire house via PLEX. I have (4) MACS and would like to have PLEX be on each computer as they wake and sleep...as if is the only platform available.

Please notify me if anything need to be done in the reporting sense. I had another thread on it...

Kevin

#7 Kevin Jr

Kevin Jr

    Member

  • Members
  • PipPip
  • 23 posts

Posted 18 April 2010 - 08:17 PM

Dear Elan:

I think I created a Lighthouse Ticket properly. here is the link: https://plexapp.ligh...ep#ticket-814-1

As noted in the ticket, I've possibly thought of an easier fix for now, and something probably even more usable for us hardcore PLEX users.

Because many of us network our computers and need them on constantly (to share files, and as in my case, to use AirFoil) the System Sleep Option is not in fact a viable option. If in Preferences/Skins there was an option to have the menu show a manual "Display Sleep" option (rather than just the System Sleep option) this would be one far step closer to what we need. Maybe even the only step.

Right now, I have to stop what i am watching in PLEX, exit out of PLEX (because I have the background music selected) and then get up from my lazy boy lol, sleep the computer display and turn the LCD of connected to it. If we had a workable Display Sleep option, it would be as easy as one click. No shutting down multiple programs and off buttons, and no turning a bunch of components back on just to get up and running again.

From my tests, "option-shift-eject" from the mac keyboard puts the display to sleep with PLEX running, and even shuts down the audio output. (However, I tried running a macro from Hippo Remote and could not get it to work properly. I'm sure that's something between Hippo Remote and the Hippo VNC).

Anyway, so my idea is have an option under PLEX preferences for Display Sleep to be displayed on the main menu, and further, some type of option (maybe) to have the apple remote sleep the display when the play key is held down.

Thanx guys.

And I certainly second the motion to offer the finest kava to whoever fixes this, plus a $100 GIFT CARD. I'm serious to any takers. This is an option that would make my entire system work a lot smoother throughout my entire house. Much thanx to anyone who takes this...

#8 skyy99

skyy99

    Member

  • Members
  • PipPip
  • 41 posts

Posted 22 April 2010 - 10:03 PM

Dear Elan:

I think I created a Lighthouse Ticket properly. here is the link: https://plexapp.ligh...ep#ticket-814-1

As noted in the ticket, I've possibly thought of an easier fix for now, and something probably even more usable for us hardcore PLEX users.

Because many of us network our computers and need them on constantly (to share files, and as in my case, to use AirFoil) the System Sleep Option is not in fact a viable option. If in Preferences/Skins there was an option to have the menu show a manual "Display Sleep" option (rather than just the System Sleep option) this would be one far step closer to what we need. Maybe even the only step.

Right now, I have to stop what i am watching in PLEX, exit out of PLEX (because I have the background music selected) and then get up from my lazy boy lol, sleep the computer display and turn the LCD of connected to it. If we had a workable Display Sleep option, it would be as easy as one click. No shutting down multiple programs and off buttons, and no turning a bunch of components back on just to get up and running again.

From my tests, "option-shift-eject" from the mac keyboard puts the display to sleep with PLEX running, and even shuts down the audio output. (However, I tried running a macro from Hippo Remote and could not get it to work properly. I'm sure that's something between Hippo Remote and the Hippo VNC).

Anyway, so my idea is have an option under PLEX preferences for Display Sleep to be displayed on the main menu, and further, some type of option (maybe) to have the apple remote sleep the display when the play key is held down.

Thanx guys.

And I certainly second the motion to offer the finest kava to whoever fixes this, plus a $100 GIFT CARD. I'm serious to any takers. This is an option that would make my entire system work a lot smoother throughout my entire house. Much thanx to anyone who takes this...


I believe this has been fixed. See blog. I think Elan deserves credit.

Thanks,
Matt

#9 eithe

eithe

    Dedicated Member

  • Members
  • PipPipPip
  • 124 posts
  • Location: Stavanger, Norway

Posted 11 October 2010 - 08:38 AM

I'm experiencing this bug again on Plex Nine. Anyone else?

I've set the OS's Energy Settings to never sleep, and Plex's setting to sleep display after 10 minutes. Plex screen saver is set to "Dim" after 3 mins and I always have Plex open in full screen. However, it never dims nor sleeps the display. I've unplugged all input devices to test.

If I reboot it works again, but it starts acting up anywhere between some hours or a day or two. Restarting Plex does not solve it, either, needs complete reboot.

Author of the Plex plugins TellSticker and NRK (co-author).





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users