15 Second Delay With Autoplay

chromecast

#1

Hi I've done quite a bit of searching and can't find anywhere that I can adjust or remove this delay between the starting of the next video.

I can understand implementing this feature on internet streamed content (netflix or hulu) so as not to start the next stream but I don't find it necessary for locally stored content where date usage isn't a concern.

Is there a fix for this that I can do on my end or could it be an option added to the app.

Cheers

Damien


#2

Ditto ... any resolution?


#3

The ability to change this would be incredibly helpful.


#4

If you're on Linux, go to /usr/lib/plexmediaserver/Resources/Plug-ins-*/WebClient.bundle/Contents/Resources/js
Open main*.js file and search for C=10 (case matters). In my file it's line 4496, column 304.
Replace with: C=0

Haven't tested it on Windows, but it should work the same way, just the folder path will be a bit different.


#5

For Windows(7) the file is located
C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-f54242b6b\WebClient.bundle\Contents\Resources\js


#6

In trying to find a solution to this I came across multiple requests for this feature. Yes, some like it, but I would love a way to adjust this setting without editing files if possible!

I only recently started seeing the 15 second delay in the Plex Media Player, not sure why the update added this in. Sorry for bringing up an old thread!


#7

I’d like to necro this thread as well. C=10 doesn’t exist in the js anymore for a new version of the web player. I’m halfway inclined to revert and find it so I can get the area of code it’s in, because that almost seems easier than searching through a massive minified js file to find it… but I’ll probably just search.

If anyone has changed this and knows where the value now lies, please respond. Otherwise I’ll update with my findings.

edit

The value appears in w=10 on line 4642. I tried changing this, but it didn’t work. I am hoping it’s because I’m playing through the remote app.plex.tv version and it’ll work when I get home. Then I can figure out how to play direct again through my firewall.

w is used in the next line in r.state={…secondsLeft:w} so you can reliably find these lines by searching “secondsLeft”, “postPlay” or “utoPlay” case sensitive (or “autoPlay” case insensitive since it appears in both forms). secondsLeft (for now) is the best way to find these lines as it only appears on 4642 and 4643.

edit 2

This does work for playing from the web player (browser) direct from your plex machine, but not through app.plex.tv, as that loads the web player from plex.tv not from your server.

There are probably further edits that can be done to skip “postPlay” and go directly to the next episode, but a delay of 0 is pretty quick (actually 1 second, same as setting it to 1). To actually get a delay of 0, you have to edit the setInterval call on those lines and change 1e3 (1000 milliseconds) to something lower, like 1, and or edit other code to not do the setInterval at all and just directly call playVideo.

P.S.

Plex employees, 10 seconds is a really long time to wait for the next video to start for some of us. I would like 0, and setting repeat-all and other settings no longer works, if it did in the past. Please expose this value in the settings menu.

And don’t tell me it’s for buffering/transcoding purposes. It’s not. It waits 10 seconds, then it opens the video and starts buffering it, same as if you had opened the video to play any other way.


#8

@FinalDoom said:
I’d like to necro this thread as well. C=10 doesn’t exist in the js anymore for a new version of the web player. I’m halfway inclined to revert and find it so I can get the area of code it’s in, because that almost seems easier than searching through a massive minified js file to find it… but I’ll probably just search.

If anyone has changed this and knows where the value now lies, please respond. Otherwise I’ll update with my findings.

edit

The value appears in w=10 on line 4642. I tried changing this, but it didn’t work. I am hoping it’s because I’m playing through the remote app.plex.tv version and it’ll work when I get home. Then I can figure out how to play direct again through my firewall.

w is used in the next line in r.state={…secondsLeft:w} so you can reliably find these lines by searching “secondsLeft”, “postPlay” or “utoPlay” case sensitive (or “autoPlay” case insensitive since it appears in both forms). secondsLeft (for now) is the best way to find these lines as it only appears on 4642 and 4643.

edit 2

This does work for playing from the web player (browser) direct from your plex machine, but not through app.plex.tv, as that loads the web player from plex.tv not from your server.

There are probably further edits that can be done to skip “postPlay” and go directly to the next episode, but a delay of 0 is pretty quick (actually 1 second, same as setting it to 1). To actually get a delay of 0, you have to edit the setInterval call on those lines and change 1e3 (1000 milliseconds) to something lower, like 1, and or edit other code to not do the setInterval at all and just directly call playVideo.

P.S.

Plex employees, 10 seconds is a really long time to wait for the next video to start for some of us. I would like 0, and setting repeat-all and other settings no longer works, if it did in the past. Please expose this value in the settings menu.

And don’t tell me it’s for buffering/transcoding purposes. It’s not. It waits 10 seconds, then it opens the video and starts buffering it, same as if you had opened the video to play any other way.

I’m using Plex version 1.12.1.4885 with web version 3.39.5
I can’t find a “w=” in the main*.js anywhere near the lines with “secondsLeft”.
Which version are you using and do you have any insight into where I else I could look?
Also, can you share the segment of code where you found the “w=”?
Thanks


#9

I’m not sure how this is a Chromecast issue - changing the countdown time in the web app will not change the countdown time in the receiver.


#10

@“Dom C” said:
I’m not sure how this is a Chromecast issue - changing the countdown time in the web app will not change the countdown time in the receiver.

Yes this confused me too. In any case - it’s an easy fix - just send the requested delay along with the play request - and on the receiver stick with the hardcoded value - unless a different value has been sent over the websocket connection with the play request. It’s probably best to make this a Plex account setting - rather than a Plex Server setting.