2.009: Always transcoding with local server until *any* setting is changed

samsung-smart-hub

#1

Hi,

Since I updated to 2.009, Plex will transcode every file, even the most basic ones (720p, mp3 stereo, no subtitles). Before the update, these files would have been direct played. As soon as I go to the settings, and change any setting (no matter what), I get the correct behavior (transcoding only if necessary). I have to do this each time I use the app, i.e., I start the app, and have to go to the settings, otherwise it would always transcode.

I have to mention though that I'm using a very old version of PMS, because my old Mac Mini cannot run newer versions.

TV: F-Series
Plex app: 2.009
PMS: 0.9.16.6

Cheers,
Martin

PS: Thanks for the great app! :)


#2

Looks to me your TV is not longer saving the settings.
This could happen if your TV’s cache got corrupted somehow.
Please unplug the TV from the wallsocket and leave it without power for a few minutes to deplete the condensers that keep the cache in memory. Not sure this will fix it, but worth a shot.


#3

Thanks for your reply!

I tried that, but it didn’t help.

The settings are actually saved:

  1. I turn on my TV and start the app
  2. I play any video -> Plex is transcoding no matter what the file contains
  3. I go to settings and disable, let’s say, transition animations
  4. I play the same video before -> direct play
  5. Next time I turn on my TV and start the app, transition animations are disabled
  6. Plex is always transcoding until I go to settings again and change any value, e.g. by disabling smart control.

I didn’t have this issue with the version before (2.008 I suppose).

Cheers,
Martin


#4

Could be because of a bug in the visual representation of the “Auto adjust Transcoding quality” setting.
It might look off, but could be on under the hood. To make sure it’s saved as disabled, open the setting, switch it to ON and then switch it back to OFF the app will save the setting correctly but next time you open it, it will show a s OFF again.

Now leave the preferences and tried again.
If you want to check why it’s transcoding set the preferences > general setting 'Send Debug to PMS" to ON.
Now start playback and find the Plex media server.log and attach it here so I can have a look.


#5

Thanks for your suggestions!
While there actually seems to be a bug with rendering of the above mentioned settings, turning ot on and off again didn’t solve the issue.

The log file says that direct play is disabled. I have an old PMS - could this still be the issue with the samsung.xml? Wouldn’t explain why it worked with 2.008 though…


#6

Yep that seems to be the problem. Looks like your PMS doesn’t have an MDE (Media Decision Engine)

[PlexforSamsung] [Player.js] - DirectPlay profile check
[PlexforSamsung] [Player.js] - [Container  : mp4] --> OK
[PlexforSamsung] [Player.js] - [Video codec: h264] --> OK
[PlexforSamsung] [Player.js] - [Audio codec: aac] --> OK
[PlexforSamsung] [Player.js] - [DirectPlay possible]

[PlexforSamsung] [Player.js] - Server is remote, checking for allowed bandwidth
[PlexforSamsung] [Player.js] - Server decision: 0: Unknown

In that case the app doesn’t known what to do and does the safe thing, which is transcoding.

The newer servers have a new feature that allow a streaming limitation to be set by the administrator.
If the bandwidth or number of connected clients gets to high, the server will force you to use a lower bitrate, which again is only possible with transcoding. The old app didn’t support this feature yet, but the new ones have to, to be compatible.

The short answer:

Upgrade your PMS to the latest version and it should be fixed.
The app will then be able to request, if the server thinks it’s OK to use the required bitrate
If you don’t set any limits, the server will allow it and the app will Direct Play.

BTW : Plex only supports server > v 1.0, below that are considered alpha/beta


#7

Hi Orca,

Thanks for the analysis!

0.9.16.6 is unfortunately the latest PMS version that supports my hardware.

One thing I realized is that the Plex client seems to assume that my server is a remote server, which it is not. I suppose this comes from the fact that my PMS receives a WOL from my router when the official plex servers try to access my PMS instance. So I don’t bother of turning it on manually. However, since a few weeks, this seems to confuse the plex client.
As soon as I change any setting, the client seems to realize that the server is local. Does this sound plausible?

As I didn’t have the issue with older versions, is there a way to downgrade?

Cheers,
Martin


#8

The indication if a server is local comes from the response the app gets from Plex.tv (your account)
A server can have multiple possible connections. The app will try them one by one until it finds a working one.
In order to find the fastest connection it does some magic to decide which connection it should use.
The connections that are local are preferred, however if the server is not awake yet, it may fail on the first few tries and ends up finding the server over an outside connection. That is not optimal.
We don’t want to wait forever, so the local servers have a shorter timeout then the remote ones.
Lucky for you, I added a setting under preferences > general which allows the app to wait a bit longer for the server to wake up.
I suggest you increase the timeout a bit, so it will be able to detect the local connection.
If that doesn’t work, you may want to check if something is blocking the local connection (firewall?)


#9

Thanks, Orca, but that doesn’t help. I set the extra time to 30s, but after 15s my machine wakes from sleep by the call from plex.tv and then the Plex client treats it as remote. When I start the client AFTER I did wake up the machine myself, it is correctly treated as local though.

If the decision between remote and local is done by plex.tv, then a downgrade to 2.008 wouldn’t help, right? Is it a coincidence that this happens for me since 2.009?

Cheers,
Martin


#10

This doesn’t work if the server is completely off like when using WOL.
When it’s really off, the server is not there to accept the request and the request will just fail.
This only helps when the server is in sleep mode.

There is nothing in the older version that would make this work.


#11

I never turn my mac off, it’s always just going to sleep mode. I’m just wondering why it worked until a few weeks ago…?