2.009 Audio Selection Issue

samsung-smart-hub

#1

Since upgrading the client app to version 2.009 the audio selection does not work anymore.

Independent of the audio selection always the first audio track within the MKV container is used. The issue seems to be related to the Samsung client as on other clients (Android, Web/Browser) the selection works as expected.

My settings are:
Hardware: BD-H6500 (2014 modell)
Client: 2.009
PMS: 1.9.4.4325-1bf24oa65 running on a QNAP NAS


#2

New insights:
The problem only occurs with “auto” and “direct play”.
The audio selection works when using “direct streaming” or “transcoding”.


#3

I have noticed that too but didn’t have another file to test. Had to manually change the audio by using the green button (at least that works for me)


#4

Same issue on my TV… very very annoying, unable to select the language, or correct subtitles. To bypass I found the same workaround than you I use the direct streaming option or transcoding. But performance really bad on my side.
So with auto or direct play that issue appears, @Orca are you awared about that ?


#5

Tried using the green button during playback to change it? Does that work?


#6

No when you try do that the input for audio is set to “unknow” and the subtitles are locked to 1/1 (however more are present), and set on which subtitles selected before you launch the movie/file.
This doen’t appears for each movie/file, just for some kind of .mkv files, and no issue with other players (Ios, android, web…).
Following 3 mkv files details, the first without issue and the other with… maybe it’s linked with AC3 audio format.




#7

I checked it and the audio selection is working fine, as far as I can see.
(the audio output switching (DTS/DD/PCM) is still broken though in 2.009)

I can see why the app would have issues with these videos.

What kind of subtitles are subt , those are not supported.
Also your TV doesn’t support DTS HD or the A52 codec.

The only way (possibly) to play these files is with transcoding.
(which is what the other players do by default, that’s why they work)

I would advise to use more normalized settings (MKV, H264, DTS/AC3, SRT/ASS) when you rip files.


#8

@Orca However what I noticed is that if you have 2 languages in your mkv, and you have, lets say french as the first, regardless of what I set in the app it’ll play the french. I can then switch it to english using the green button? Have you seen that happen in your tests?


#9

I can’t reproduce that. I have a movie with 3 different language tracks.
If I select the they will keep that setting and play the correct language.

You can check if the app is able to update the server correctly by doing this:

  • Open the video in Plex web and check what track is currently selected.
  • Open the video on the TV app and make a change to the audio track.
  • Now refresh the webpage by going back and then re-selecting the video.
  • The track should now show the change you made in the app.

If that’s not the case you might have an issue with some firewall that is blocking inbound requests to your server.
Also check if maybe the track labeled as language X is actually recorded in language X.


#10

@chaosmaker, @orca :

Audio track selection using the green button works for me too but only if the first track was chosen in the app.
If the second track was chosen then I can’t change the audio track in “Audio and Subtitle Settings” menu.

Interestingly in both cases “Audio unknown” is displayed in the “Audio and Subtitle Settings” menu. In the first case, I can change “unknown” to any of the two available audio tracks and the spoken language changes immediately. In the second case, no selection is available at all.

I don’t know if it is of any relevance for this problem but I recently have also updated the firmware of my BD-H6500 to version 1113.


#11

Thanks for explaining what you did, I could reproduce the problem that way.
When the second stream was selected. I could not always select the first track any more.
The track two and three still worked fine. Weird, because I can see in the log, the actions work correctly.
I’ll see if I can figure it out.


#12

Looks like it’s a timing issue. The Samsung API is firing the “stream is ready” event before it does have all tracks loaded.
If I wait half a second before changing the tracks, the problem is gone. The problem doesn’t occur on the first track, because it’s already the correct one and no changing is needed when starting playback.


#13

Hi @Orca,

Thanks for the invest, and thanks to @WeBo69 for help, it always hard to explain an issue.
I hope you will be able to patch that issue in next release, on my side I use “direct streaming” or “transcoding” to bypass. Or I use the mobile or web client to stream on chromecast.


#14

Hi all,
Thanks for the above as it got me in the right direction.
I am also having the same issue with the unknown audio.
Most of the movies I have only have DCA6 (DTS) track and the sound output is only coming in 2 channels through to the receiver. DTS had previously worked flawlessly.

In some files, where I have multiple tracks (AAC 2 + AC3 6), I can make surround work.

@Orca, Is there any way to revert back to an earlier version of the PMP?
As I understand this may be related to PMP 2.009, right?

My setup is:
Samsung UE48H6500, running PMP 2.009
Samsung HT-BD1255
Synology DS214play, running PMS v1.9.7.4460


#15

Some additional info to my previous post:

  1. When a DTS track is on the 1st track, it is also shown as unknown (when pressing the green button) and does not allow to choose the second (AAC2) track.
  2. When the file has a single AC3 6 track, then it plays in surround (although it still shows as Audio Unknown on the Audio and Subtitle options).
  3. Transcoding seems to work but the Synology keeps buffering, which renders it unusable.

Unfortunately, I couldn’t find a file with AAC2 on track 1 and DCA on track 2 to test if it works like the AC3.


#16

It’s a bug that got introduced in v 2.009. A fix is coming in v 2.010


#17

Great news!
Many thanks for your investigation and work on this issue!


#18

I have the same issue on my Samsung UE60JU6900 with 2.009 client. Also because of this my TV doesn’t switch to DTS automatically. Besides that I also noticed that my DTS stream has issues. Every now and then it gives a hickup. I’m not sure if that is related to all of this, but it started happenign in client 2.009. I always use Direct Play as my NAS (QNAP 253a) is not strong enough to transcode. I never had issues so far.


#19

Thank you for your great job!

Meanwhile, could we get the 2.008 file in order to downgrade to fix this issue? My NAS is not powerful enough to transcode, and my kids can’t watch their movies :disappointed:


#20

Woow… great news… have troubles with this tiny issue for some time already… good to know a patched version is coming… any estimate when? Thank you for all the hard work! :slight_smile: