# 500 Internal Server Error only when trying to download logs/database

**URL:** <https://forums.plex.tv/t/500-internal-server-error-only-when-trying-to-download-logs-database/898482>\
**Category:** Plex Media Server\
**Tags:** server-unraid\
**Created:** [December 10, 2024, 3:28pm UTC](https://forums.plex.tv/t/500-internal-server-error-only-when-trying-to-download-logs-database/898482 "2024-12-10T15:28:13Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![eshudnow](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/eshudnow/32/109016_2.png) [@eshudnow](https://forums.plex.tv/u/eshudnow)\
**Post date:** [December 10, 2024, 3:28pm UTC](https://forums.plex.tv/t/500-internal-server-error-only-when-trying-to-download-logs-database/898482/1 "2024-12-10T15:28:13Z")

</div>

Server Version#: 4.142.1

I recently built an Unraid Server and installed binhex-plexpass. Everything is working great. Libraries working well, playing, adding media, etc. all working great. Kometa is even working great.

But I noticed ImageMaid was failing to run getting a 500 Internal Server Error from Plex when trying to download the Plex Database. That led me to going into Plex Web and going to Manage \> Troubleshooting and noticed both Download Logs and Download Database both return a 500 Internal Error.

I do see the following in the Plex logs (went there through the file system):

Dec 10, 2024 09:26:07.473 [22571307428664] ERROR - [Req#68fa] Error creating directory “/config/tmp/tempLogsebe04aea-e5fb-4441-bf53-b9bebfc0c387”: Permission denied

Dec 10, 2024 09:26:07.474 [22571307428664] ERROR - [Req#68fa] Error creating directory “/config/tmp/tempLogsebe04aea-e5fb-4441-bf53-b9bebfc0c387/PMS Plugin Logs”: Permission denied

Dec 10, 2024 09:26:07.474 [22571307428664] ERROR - [Req#68fa] Couldn’t copy file “/config/Plex Media Server/Logs/Plex Media Server.log” to “/config/tmp/tempLogsebe04aea-e5fb-4441-bf53-b9bebfc0c387/Plex Media Server.log”: No such file or directory  
Bunch of other similar no such file or directory messages.  
Dec 10, 2024 09:26:07.475 [22571307428664] WARN - [Req#68fa] Diagnostics: Could not open zip “/config/tmp/logs.zipab2c8f90-eee7-469b-8b7a-fcf78176c444” for write

Dec 10, 2024 09:26:07.475 [22571307428664] WARN - [Req#68fa] Diagnostics: Error zipping files for Plex Media [Server Logs\_2024-12-10\_09-26-07.zip](https://support.plex.tv/articles/200250417-plex-media-server-log-files/)

Dec 10, 2024 09:26:07.475 [22571463351096] DEBUG - Completed: [192.168.1.217:3896] 500 GET /diagnostics/logs (5 live) #68fa TLS GZIP 1ms 405 bytes (pipelined: 1)

Dec 10, 2024 09:26:07.528 [22571463351096] DEBUG - WebSocket: client initiated close

Dec 10, 2024 09:26:07.528 [22571463351096] DEBUG - handleStreamRead code 1: stream truncated

Dec 10, 2024 09:26:07.528 [22571463351096] DEBUG - NotificationStream: Removing because of error

Dec 10, 2024 09:26:07.528 [22571463351096] DEBUG - Completed after connection close: [192.168.1.217:3818] -3 GET /:/websockets/notifications (5 live) #4402 TLS GZIP 175492ms 218466 bytes

Definitely a permission issue. But not sure how to fix.

---

<div class="post-metadata">

**Author:** ![eshudnow](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/eshudnow/32/109016_2.png) [@eshudnow](https://forums.plex.tv/u/eshudnow)\
**Post date:** [December 10, 2024, 4:13pm UTC](https://forums.plex.tv/t/500-internal-server-error-only-when-trying-to-download-logs-database/898482/2 "2024-12-10T16:13:13Z")

</div>

Fixed issue. On the /tmp directory, updated permissions and now it’s working.

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [March 10, 2025, 4:13pm UTC](https://forums.plex.tv/t/500-internal-server-error-only-when-trying-to-download-logs-database/898482/3 "2025-03-10T16:13:17Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
