AC3 5.1 audio not playing on TX3 Mini

android-tv
fire-tv

#1

Hi I’m gonna need some help with the issue I’m having since after 2 weeks of trying out different stuff and browsing the forum for potential solutions I am jsut not able to resolve it.

I bought this cheap little TV Box for my workroom TV, installed Plex Player and only issue I’m having is that files with AC3 5.1 dont have any sound. wich is a bummer since most of the TV shows I watch have this audio format.

I also installed VLC media player and when I connect to the Plex Server through it it plays the audio normally.

After some investigation it turns out that when i run the Plex Player on the TV Box it uses Direct Play to get the files from Plex Server, while when i use the VLC Plaer it uses Direct Stream for video and Transcodes the audio.

Attaching the screenshot from Now Playing Status.

I tried looking in the settings on the Plex Server and Plex Player on the TV Box but no option fixes the issue, also tried editing the device profiles but I’m not sure how exactly to do it and my winging it didnt give any results. I really need some help to fix this since its realyl bugging me and transcoding all these files manually is just not an option.

Some info on the devices:

TX3 Mini -A with Android 7.1.2 running Plx Media Player 6.5.3.2115

Desktop PC with Windows 10 running Plex Media Server 1.9.2.4285

Let me know if there is any more info I can provide and thanks for any help in advance!


#2

There are issues with 5.1 on many android devices, including the Fire TV Gen 2 boxes. The only way to fix it right now is go back to an earlier version of Plex on your device. If you dig in this forum you will find others posting how to do it.


#3

You could try installing Kodi on the TX3 and then installing Plex for Kodi. I findPlex for Kodi plays AC3 when Plex for Android fails.


#4

Same problem here,
i’m using plex for kodi or kodi reading from upnp,
but plex app cannot play any audio if audio is ac3.


#5

nothing changed even with the new firmware (http://freaktab.com/forum/tv-player-support/amlogic-based-tv-players/s905x/662654-tanix-tx3-mini-amlogic-s905w-new-soc-android-7-1-1/page44) , but Emby player with emby server solved the problem.


#6

My solution.
1.I reset all data of the application(for step 2).
2.I launched it in mobile mode.
3.I disabled support for ac3 and dts.

4.After that there was a sound.


#7

We have added an AC3 software decoder in 6.13, you should be able to playback on your device with this. If not, please fetch logs from the device whilst running in TV mode.


#8

@sixones said:
We have added an AC3 software decoder in 6.13, you should be able to playback on your device with this. If not, please fetch logs from the device whilst running in TV mode.
6.12.**** - Current version on android market.


#9

I’m using a T95Z Android TV box (v 6.0) , and Plex Media Server (v1.10.1.4602) on Windows 10. I was using v6.12 of the Plex Media Player on the Android box, and having the same trouble, ie video OK but no sound if the audio is AC3. I saw the above re added AC3 decoder, and checked Playstore where there was indeed an update dated February 10. I uninstalled v6.12 and installed the new version which turned out to be 6.13.6.3452. This did not solve the problem, so I rebooted the Android - unfortunately the same result. Anything else I should be doing?


#10

@BreRo1 said:
I’m using a T95Z Android TV box (v 6.0) , and Plex Media Server (v1.10.1.4602) on Windows 10…
I have same configuration. You can try my solution as temporary.
https://forums.plex.tv/discussion/comment/1612615/#Comment_1612615


#11

I don’t have sound when watching an ac3 show on my android box with Plex. It works if I use VLC as the client. Even using the Plex media server on the backend. But the Plex client has no sound for ac3/dts media. Older media plays fine. I tried many things. Nothing works.

I tried the below… .

@flex004 said:
My solution.
1.I reset all data of the application(for step 2).
2.I launched it in mobile mode.
3.I disabled support for ac3 and dts.

**4.After that there was sound

But Where do you disable support for ac3 and dts?


#12

@allanweinman said:
I don’t have sound when watching an ac3 show on my android box with Plex. It works if I use VLC as the client. Even using the Plex media server on the backend. But the Plex client has no sound for ac3/dts media. Older media plays fine. I tried many things. Nothing works.

But Where do you disable support for ac3 and dts?

In **mobile mode ** (not in TV MODE)
settings-advances-media player- support of sound - (uncheck ac3\dts)
The menu names are approximate. Exact names I can say later.


#13

how active “mobile mode” on a Androi TV?

If plex had the same option in the two modes it would solve a lot of problems

I tested the version 6.13 on my Beelink GT1 with Android TV (custom) still no sound in AC3


#14

Could you try using 6.13.6 and disabling passthrough, this should allow your device to use the AC3 software decoder. If not could you fetch some logs so we can investigate?


#15

@Alexis67 said:
how active “mobile mode” on a Androi TV?

If plex had the same option in the two modes it would solve a lot of problems

I tested the version 6.13 on my Beelink GT1 with Android TV (custom) still no sound in AC3

Go to android settings of app.
Kill app.
Clear all data.
After restart plex do not choose TV mode.


#16

@sixones said:
Could you try using 6.13.6 and disabling passthrough, this should allow your device to use the AC3 software decoder. If not could you fetch some logs so we can investigate?

OK i testing tonight

@flex004 said:
Go to android settings of app.
Kill app.
Clear all data.
After restart plex do not choose TV mode.

ok but on a REAL Android TV (not a android normally with custom launcher) that does not normally work, I check tonight


#17

@Alexis67 said:
ok but on a REAL Android TV

PLex has another bug. After selecting the interface mode once, it will not be changed any more without data cleaning, and this will reset the sound settings. (maybe through the root you can set the settings manually, in the red tv not all settings, to my regret and surprise). In any case, you can run the video remotely from your smartphone, in the form of a temporary solution, if necessary.( i have real android and can not check this)


#18

the data cleaning to switch mobile or tv interface on Android TV is not work !!!

I use 6.13.6 and disabling passthrough… but ac3 does not work

how can i provide you with the log for more information on the problem ???


#19

I found how to make a log file

I launched a movie with the sound in ac3 5.1 that does not work on my box Android TV

If it can help


#20

I have belink gt1 and have problems with audio also. THe only solution so far is to watch only with 480p quality. If I want to switch 720 or 1080 I have problems. It looks like iam missing audio channels with higher quality streaming. Any other way around.