After recent build update - Agent Matching has a bug that affects Movies and TV metadata gathering.

server-windows

#1

It's apparently affecting a lot of people with Plex installed on Windows machines.

The Bug: Matching - which worked before is no longer working. Its as if the agent is no longer connecting.

Movies: No metadata gathering at all. Matching does not connect to any agent match for movies, regardless of file naming structure. It won't even pull the data out of an M4V or MP4 file and I know is in there.

TV shows, it is getting ONLY the poster and the episode titles - no other metadata.

What does not fix the problem:
* Plex Dance: useless. It has no effect. I even did the Plex dance on the whole Movies sub directory. Now, movies that previously had meta data on Plex now have nothing.
* I religiously use FileBot with {plex} foprmatting on all TV and Movie files. Still, changing the name and subfolder structure of media files has zero effect in regard to agent match . "No matches were found using this agent." is the only result ever given.
* Manual matching with (even using the IMDB or TMDB shortcodes) always returns "No matches found" - no matter what data is entered in the manual search data windows.
* Agent contribution list check/uncheck or preference order has no effect.
* Optimizing the DB - no effect

The fact that I get partial results on TV shows tells me is likely not a connectivity or permissions issue on the user end.
The fact that this problem - at least for me - only started after a recent update makes me think it's a software bug either introduced in the code or caused by a faulty file overwrite in the installation of the latest Plex update.


#2

This is a TV file that is correct:


#3

This is how new TV shows appear:


#4

How movies appear:

A shot of the metadata within my m4V file:


#5

Agent settings:




#6

Matching:
Note - lack of “fix Match” option as no matching has happened.

Auto Match Attempt: (regardless of option)

Manual Match Attempt: (regardless of using title or shortcodes)


Always returns this result:


#7

@davodd said:
Agent settings:

The ‘Local Media Assets’ are missing from here.
Something is not right about your installation.

  • Quit Plex Server using its trask tray icon
  • deinstall it using the regular Windows ‘Apps’ control panel (do not use Uninstaller software like ‘Revo’ etc.)
  • reboot Windows
  • download a new installer file from the DOWNLOADS link above and install it

Your library will be unaffected by this!

If the LMA agent is still absent after this, reset your agent settings with this procedure:


#8

I had the same issue and I found on another thread a suggestion to disable IPV6. Worked for me.