Album Art was there, after adding more music, it is now gone. How do I get it back?

server-synology

#1

Album Art was there, after adding more music, it is now gone. I have been slowly adding my music collection to PMS on a synology DS918 with 4 8TB drives. This is my second attempt at doing this. The first time I just dumped all my music in and it choked PMS. It took it about 5 days to finish and when it did I was missing tonnes of information. I decided to rebuild the PMS and add each letter in and then do an optimize database. Well that worked great until I got up into the P's and then it choked again.

I have about 90,000 tracks right now and it is painfully slow even after a day of sitting. Also almost all of my album art is just a gray box. It used to be populated, I was checking as I was going, so not sure what to do. Any help would be appreciated.


#2

You can’t throw a huge amount of content at a Synology and expect it to be as quick as a Desktop computer. Yours has just over 2000 Passmarks. That’s 1/4 of a 5 year old i7 @ 2.7 Ghz. https://www.cpubenchmark.net/cpu.php?cpu=Intel+Celeron+J3455+%40+1.50GHz

I suggest the following to get you through this. In the future, add in blocks of no more than 2000-3000 tracks, paying careful attention to Optimize the Database after each new block completes.

For now:

  1. Cancel Scan
  2. Optimize Database
  3. Restart PMS
  4. Start Scan again.

You may have to repeat this several times depending on how much you added at once.


#3

@Blokhead said:
Album Art was there, after adding more music, it is now gone. I have been slowly adding my music collection to PMS on a synology DS918 with 4 8TB drives. This is my second attempt at doing this. The first time I just dumped all my music in and it choked PMS. It took it about 5 days to finish and when it did I was missing tonnes of information. I decided to rebuild the PMS and add each letter in and then do an optimize database. Well that worked great until I got up into the P’s and then it choked again.

I have about 90,000 tracks right now and it is painfully slow even after a day of sitting. Also almost all of my album art is just a gray box. It used to be populated, I was checking as I was going, so not sure what to do. Any help would be appreciated.

You are better off making sure your music files are properly tagged and you enable ‘Use Embedded tags’ in the Music library settings. I also recommend using a regular Music library instead of a Premium one.

It is also important that your files/folders are correctly named. That is, they are spelled correctly, no typos, and they match with common examples found using Google for that Artist and Album etc.

Your files should also be stored in Artist/Album folders like so:

Media
…|_ Music
…|_ AC-DC
…|_ Back In Black
…|_ AC-DC - 01 - Hells Bells.mp3
…|_ AC-DC - 02 - Shoot To Thrill.mp3
…|_ Pink Floyd

Minimum tags for Plex:

Artist
Album Artist … (Leave blank for Various Artist albums only, all other tracks MUST contain this tag)
Album
Title
Year
Genre
Track Number
Cover Art

I recommend using only the tags above. Other tags may be included, but may not be used by Plex.