Alexa Control Inconsistent

alexa
voice-control

#1

Hello,

I currently have two programs in my Plex Library to test it out and i'm trying it with Alexa.

One program i can ask to play everytime (Impratical Jokers) and it almost always plays it first time and i can stop, pause, play etc fine with voice commands. The other program (Stargate SG-1) i have never got to play by voice control, mostly it doesn't recognize what i'm saying and sometime it reads it back perfectly but says it's not in my library even though it suggests it when i ask for suggestions.

What is the issue here and how do i fix it? I have even tried changing the program name and it still doesn't work with the new name.

Thank,
Thomas


#2

Does anyone have any tips/success with changing the names of TV Shows in plex and then using that new name to ask for the show?.


#3

Based on logs the devs looked at, it appears that when Alexa returns the processed show title, it's as Stargate SG1 (rather than "SG-1" - both of which would, of course, sound the same when Alexa speaks them). Unfortunately, that must not be returning the correct result when a search is actually performed on the server.

It's definitely an area we're working to improve in the future. The easiest workaround for you right now would probably be to simply go into the show in your web app, Edit it, and then change the name to Stargate SG1.


#4

Chris thanks for your reply.

I will try this later and then report back on here.


#5

I've just changed the name and at first it didn't work. But then I restarted the server and now it seems to recognise it perfectly.