Alexa finds server and player but not much beyond that



I am running PMS 1.7.5 on Windows 10. I recently got a Echo Dot and downloaded the Plex skill from Alexa. Alexa is able to find my plex server and player (PMP/IOS/Web Firefox) with now issues.

However the moment I ask plex what's on deck or to play a movie, I get the following error:

"Uh oh! Something weird just happened. Alarm bells are ringing around the world as Plex engineers are rushing to fix this issue"

If I play a movie and tell Alexa to pause/play it does work so the connectivity appears to be there.

Things that I have done to try and resolve the issue:

Set secure connections to preferred
Set allow failback to insecure connections to "on same network as server"
Made sure the player was signed in with my main (managed user environment) and running
Removed and enabled the plex skill about 5 times already

Any ideas on what the issue may be or what I can look at to help guide me to the cause of this issue? Thanks in advance.


I used to get this issue then it changed to "I'm having trouble accessing your Plex skill right now".
Nothing works for me at all. Never has.'

WTF Plex?


Did you ever find out anything with this issue? I'm experiencing the same thing. When I had Plex Media Server on a Windows box, the Alexa Plex skill worked, but since I've moved it to a Docker, seems to not be working. Like you said, It will Pause/Play, but it will not actually start playing a movie or tell me whats on Deck. Get the infamous "Uh oh! Something weird just happened. Alarm bells are ringing around the world as Plex engineers are rushing to fix this issue"


Has anyone found a fix for this? I am also experiencing this issue. All plex commands are met with "Sorry, I'm having trouble accessing the Plex skill right now"


hours of searching for a solution has got me no where. I'm not sure what the issue is, it WAS working when it first came out.


I tested out Alexa with Plex a few weeks ago by installing the Alexa Plex Skill via the Alexa app, and then controlling plex via voice commands in the Amazon app... That worked well, so I just bought an Echo... Now all of a sudden Alexa says "Your Plex Server does not meet the minimum requirements." I'm running the most up-to-date version of Plex Server of MacOS... Did a recent version of the Plex Server break things? Alexa can discover the server just fine -- but if I ask it to do anything other than discover the server (e.g. ask it to find or play any media), it shouts "Your Plex server doesn't meet the minimum requirements to work with Alexa!" Every time. Anyone got any ideas?


Same issue @1.8 gonna update to 1.9 to see if the problem persists. Not sure if the issue is with the skill or PMS side though. As far as I could tell there is no update to the skill itself.


Yeah upgrading to the latest 1.9 version of Plex Server fixed it for me.