Alexa Skill Availability - Geographical Restrictions?

alexa
voice-control

#1

I’m located in Belgium and a few days ago, I purchased an Echo Dot from amazon.de (since they made it available to a lot more countries, including Belgium, this month).

My Echo Dot is linked to amazon.co.uk, so if I want to enable a skill, I get always redirected to the UK Alexa Skill Store. Now when I’m trying to enable the Plex Skill, I get this message:

Is there any reason on why it isn’t available in Belgium? My Echo Dot language is set to English-US.
I’m an Amazon (Alexa) developer myself, so I know there is a “Publishing Information” - section where you can select in which countries the skill should be available in. The only requirement is that the primary language for that country should be supported, and, since Alexa doesn’t speak dutch, that primary language for Belgium is English-UK.

So is there any other reason that it isn’t available in Belgium?
I’m a huge fan of Plex and use it already for a very long time.


#2

I concur.

Dear Plex,
WHY WHY WHY did you enable geographical restirictions?
I bought my Echo from US, I have a US amazon account, oh what’s that you live in Asia so you can’t load Plex skill.
Please look after your loyal Plex Pass people and remove this restriction from your skill.
Or have the cord-cutters become the geo-isolationists?


#3

The skill availabel for me in Belgium (US amazon account ) UK echo dot , but NOT working ! could only set default server and default player… for al the rest i get answer “oh ohw something went wrong, i have alerted the plex team” …


#4

Same problem I’m facing in Australia with a local Echo Dot. I’ve got Plex Pass but can’t get Alexa to do something because the skill has some bizzare geographical restriction


#5

Plex did not enable this restriction… Amazon did…
Plex is hard at work on the Alexa skill and is looking to bring it to other geographical locations.
Stay tuned… There will be an announcement when it is available.
It is in high demand in just about every country, please be patient.


#6

For me plex is working now…
the problem was Nat related (pub ip not accessible from the inside) even if the dot and plex is one the same internal Lan dot uses the publick IP for the plex Skill…