Alexa stops playing Plex playlist after one song, or before end of one song.

alexa
voice-control

#1

I just set up Plex today (Ubuntu Linux) and it worked great, found and sorted all my local media, showed up in the Web UI, and got connected to Alexa. When i ask Alexa to play my playlist, it starts right up. sounds good. but then after a few minutes it stops playback. If i ask Alexa to Play, Skip, Continue, whatever... its no problem. log files show that Plex seems to think it is being asked to stop playback. but by whom?

'Dec 14, 2017 14:19:36.909 [0x7feec37fb700] DEBUG - Streaming Resource: Timing out session 0x7feeb0215de0:dfpn6imazhss18dl36tem8e4
Dec 14, 2017 14:19:36.909 [0x7feec37fb700] DEBUG - Streaming Resource: Terminated session 0x7feeb0215de0:dfpn6imazhss18dl36tem8e4 with reason Client stopped playback.
Dec 14, 2017 14:19:36.909 [0x7feec37fb700] DEBUG - Streaming Resource: Removing session 0x7feeb0215de0:dfpn6imazhss18dl36tem8e4'

i would love to replace my RaspberryPi/MPD setup with a voice control magic machine but this is stopping me cold.
Any ideas? Anyone?


#2

nothing? ok. i guess ill uninstall Plex and go with something that works with Alexa. thanks for nothing, community.


#3

You are not alone. I have had a 2nd Gen and its painful. I have only just managed to get it to play the albums on my server and it does exactly as you say above. I am searching everywhere and so many people are having the same issue but no one seems to have an answer. My issue is that my Plex is on a Drobo so I cant install Roki or another media server as it would not work. Oh the joys. Keep your eyes out as you may find the answer online.


#4

Library has to be in MP3, no transcoding from FLAC etc. otherwise it cuts off. But it works with MP3 for me!


#5

well perhaps it has been fixed. i had removed plex but downloaded and installed again last night and music keeps playing. so. either universe decided that i can listen to music or someone fixed it. good job plex.

ubuntu plexmediaserver_1.10.1.4602-f54242b6b_amd64.deb