All of a sudden after last few updates, some files buffer and say server isn't fast enough

apple-tv

#1

Having trouble on Apple TV 4 after both updates to the App itself, and the server. My oldest TV files that have worked smoothly for years all of a sudden buffer, stop or take a few minutes to start. Some work right away but the majority transcode even though they are already in the right format. I do notice one thing different in the files that try to transcode even though they don't need to...they say Max Scaling=true. The other files don't say this at all and play fine. I get 250mps service and it shows that i get almost 95 percent of that every time i test. I tried infuse and the files work right away like they used to on plex. What could i possibly be doing any different? Movies that are 15gb large play instantly and these 800mb files buffer and struggle to even start even though a few months ago started as soon as i hit the play button?


#2

Can you please post mediainfo (in xml format) of one such film ?

Also I need to know your PMS version because the transcoding decision for AppleTV4 is managed with the tvOS profile, and there were some changes to it recently.


#3

also PMS version is Version 3.9.1


#4

Also just noticed i have a second computer that isn't the server and this is the version it says is used 3.9.1. On my actual server it is listed as 3.7.0 and recently has been having trouble checking for updates. I have to go to the website and manually download it on the actual server which is on 1.7.3.3937


#5

I need PMS logs please.

The "usual suspects" in this situation are subtitles (are you using them ?) and quality parameters (are you using original quality ?).


#6

I've turned off subtitles on my Apple TV, they don't seem to even be available to select on these files. Also on Apple TV you can choose only from a list of speeds from 4mps to maximum...only once you select the video can you pick original quality. But it seems to only be with 720p video and not with 1080 p


#7

Never downloaded these before, so not sure what to look for to be wrong


#8

Thanks for the logs. I need some more info, but please disable verbose logging, they make my life harder and fill up your disk quickly. And I don’t need the databases.

  1. What is the processor of your windows PC, for example mine is (system settings):

  2. I need logs (debug ON verbose OFF) containning a situation where you could play, and another where you could not. I also need the mediainfo of the two files that you are going to use

The logs that you sent previously show situations where PMS should decide “let’s DirectStream” but has decided “let’s transcode”. This seems to be a bug but I need the above info before contacting development.


#9

Just curious ...

Any chance you've turned ON the new Auto Quality feature?

I had the same thing, until I turned it OFF.... things returned to normal ...

Regards,
Doug


#10

I had the same sort of issues. Latest PMS plex pass version on a Mac mini, ATV4 with latest version of Plex, all networked via ethernet.

Worked well for a year but over the last few versions, have been getting buffering, dropped picture quality and sometimes the dreaded "your network is not fast enough" message....even though I'm playing older files that had played perfectly well as Direct Play or Direct Stream in the past.

I noticed that even though the video would stop and buffer, if I looked at the status on the PMS Web client it would show the transcoder as "throttled" which doesn't make sense.....if it's buffering, why is the transcoder throttled??

I checked the log on PMS on the Mac mini at the time all this was happening and found this constantly repeating in the logs...not sure if its useful (note I replace my username with XXXXX in the logs)

Jun 14, 2017 19:12:23.680 [0x700007e3d000] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
Jun 14, 2017 19:12:23.680 [0x700007e3d000] DEBUG - Auth: Came in with the master token, authorization succeeded.
Jun 14, 2017 19:12:23.680 [0x7000086f0000] DEBUG - Request: [127.0.0.1:51743 (Loopback)] PUT /video/:/transcode/session/D87A31DD-EA13-41FF-A3B7-986E0920BBF2/0cfa4903-e727-474c-aa5f-3bdcd66f8570/progress?progress=71.5&size=-22&remaining=6977 (9 live) Signed-in Token (XXXXXXX)
Jun 14, 2017 19:12:23.681 [0x700007e3d000] DEBUG - Completed: [127.0.0.1:51743] 206 PUT /video/:/transcode/session/D87A31DD-EA13-41FF-A3B7-986E0920BBF2/0cfa4903-e727-474c-aa5f-3bdcd66f8570/progress?progress=71.5&size=-22&remaining=6977 (9 live) 0ms 342 bytes
Jun 14, 2017 19:12:24.197 [0x700007e3d000] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
Jun 14, 2017 19:12:24.197 [0x700007e3d000] DEBUG - Auth: Came in with the master token, authorization succeeded.
Jun 14, 2017 19:12:24.197 [0x700007f43000] DEBUG - Request: [127.0.0.1:51744 (Loopback)] PUT /video/:/transcode/session/D87A31DD-EA13-41FF-A3B7-986E0920BBF2/0cfa4903-e727-474c-aa5f-3bdcd66f8570/progress?progress=71.5&size=-22&remaining=4065 (9 live) Signed-in Token (XXXXXX)

I did turn off the "Auto quality" feature which seemed to have been TERRIBLE and now seem to have this issue a bit less.


#11

Auto quality forces transcoding, at least for the moment, but the logs submitted by the OP indicate that he's not using auto quality. For those having problems with auto quality I suggest to open (or participate in) a separate thread.


#12

System settings AMD E-1 1500 APU with Radoen(tm) HD Graphics 1.48gh
Installed memory 4.00gb (3.71 usable)
64 bit operating system x64 based


#13

also I tried Plex on my samsung app & on my amazon firestick and these same files work normally with no buffering. So it definately is an Apple TV 4 issue right?


#14

I used MKV merge on one season of these files and they now work. I literally changed nothing and the files are 5 to 10mb bigger than originals. But they work instantly like they used to. Still don't know why this happened out of the blue, but an easy fix


#15

The same thing is happening with me as well. I can play these MKV files just fine when I use the Plex MacOS app, but the tvOS app just doesn't budge and keeps telling me that my server isn't powerful enough (which I know isn't true).

Funnily enough, the VLC app for tvOS is also able to handle the file without any issues. welp please!?!?!

Does any one know of a way to fix this? It would suck to have to transcode these files to another 'plex + tvOS friendly' video profile, but if that's our only choice, is anyone aware of any Windows/Mac app that can do this easily?

Thanks in advance for the help!


#16

Same issue over here, four networked apple TV 4's, three of which are experiencing the same issues noted here, one of which has an older version (1.7) which I was able to disable direct play and have it go mostly back to normal (a few hiccups but no more of the dreaded "server is not fast enough" messages.


#17

So is there really no plan to resolve this issue? Is there any data that the dev's need to get this resolved, and if not, can we at least have the setting back for direct play in the Apple TV app?


#18

Same problem here. Very frustrating. It does seem that direct play does not work on Apple TV. I change the setting to make sure direct play.. Still get 'server not fast enough' message :(


#19

Any solution to this problem? This just started happening to us ~1 week ago. Never had issues before