Android Auto won't play synced playlists



Whenever I sync a playlist to my Android phone it says the playlist length is 2 minutes. There are 601 songs in this particular playlist, but it is the same with any playlist. As far as I can tell all of the songs are synced locally to the phone and the playlist plays fine through the normal app interface. This is a newly factory reset phone with a fresh install of Plex. The reason I am concerned is because I can no longer play playlists through the Android Auto interface. I don't know why, but I suspect this issue has something to do with it. Deleting and re-syncing the content has the same result. Any ideas?


Ok I have purchased a new phone but I am still experiencing the same issue. Oddly this issue is not a problem for my wife’s phone (she uses a Moto G4 Plus and we both use the same Plex account and username). I really need to figure out what is going on so I’m going to describe as much of the problem as I can.

My current (new) phone: Moto X4, Android 7.1.1, Plex Android (5ffd4fab), Plex Server version
My previous phone: Moto G4
My wife’s phone: Moto G4 Plus

When I sync a music playlist to my phone it seems to sync just fine (sync status says complete), except when I select the playlist it says the length of the playlist is something like 14 seconds. The music plays fine through the normal Android app interface, but when I try to play the playlist through Android Auto it says there are no items in the playlist so I can’t play it. I can, however, begin playing the playlist on my phone before plugging into the car for the Android Auto interface and it will continue to play, but this sort of defeats the point of Android Auto. I think the two issues (14 sec length and no items in playlist) might be related.

I’ve started to notice that the length of the playlist is proportional to the number of items/songs synced. The ratio is about .22:1. So my playlist for 61 items is 14 seconds (14/61 = .23). Another playlist is has 601 items and a length of 2 min (120/601 = .20). Don’t know if that helps any.

I turned on Network Logging and synced another playlist and then turned off the logging so please check those logs. Do you want my server logs?

Thanks so much for any help, I really really want to solve this issue!


Today I was able to play a playlist through Android Auto because it loaded the song list. However, upon selecting another playlist and navigating back the playlist was empty again. My largest playlist has never loaded properly and always says it is empty.


I should google some of this but do you have external storage on the X4 or G4 and are you using external storage?
Have you tried sync content to a different location?
Can you post your logs including your network logging for the sync?
Does android auto use bluetooth to the phone?


@nokdim said:
I should google some of this but do you have external storage on the X4 or G4 and are you using external storage?
Have you tried sync content to a different location?
Can you post your logs including your network logging for the sync?
Does android auto use bluetooth to the phone?

Yes, I have a 32 GB micro SD card (as well as 32 GB of internal storage). Yes, I am using the external storage for my music sync (I sorta have to since I’m only left with about 15GB of free space on the internal) and the external storage is formatted as Portable Storage (as opposed to formatting as internal storage which doesn’t appear to be an option on my new phone). However, for purposes of this test I could try to use internal storage if you think it could be an issue.

I turned on network logging before I did my last sync. As far as I know all you need is my username to look up those logs, right? Or are you asking for my server logs? I captured those right after the test sync as well, so I just need to understand which file in that zip file you need.

As far as bluetooth, I’m not certain. I physically connect my phone to my car via USB cable. So I would think there is no reason to use bluetooth. However, I know that when I first connect my phone to the car and run the first time setup it automatically pairs with my bluetooth in the car. I’m trying to Google this too, but haven’t found a clear answer yet.


You can upload the whole zip, the main ones are “Plex Media Server.logs” and the remote network capture of your device.

Since its not really working can you try to use internal storage to rule that out? You can sync like 5 or 10 items and see but you will have to delete all synced content to change the location but again broken so probably not a big deal.

Next time in your car maybe leave the USB disconnected and see I assume it powers over USB and can probably use USB as well but if it paired on the initial setup try just using bluetooth and see if that’s even an option.

I ask cause I have an issue sometimes with android and bluetooth to my car stereo on the display but all my content syncs and shows proper in the first place so just a few things.


Ok I’ve attached my server logs. These are from yesterday when I last tried a sync.

I’ll try syncing to internal storage. Actually, just a moment ago my phone got the 8.0 Oreo Update! So that is installing right now so I’ll see if that update happens to make any difference before trying the internal storage thing.

To be clear, in order to use Android Auto in my car I must have it physically connected via USB. I could simply use the Android Auto app on my phone screen (as someone who didn’t have a car that supported Android Auto would do) but that would only be for testing purposes. In other words, I’ll stop using Plex before I stop using the Android Auto that’s built into my car. :wink: But I will try using the Android Auto interface on my phone tomorrow morning. Again, as I said in my second post, if I start playing the playlist on my phone (before connecting to my car) then it will play fine. Then when I connect it to my car it will continue to play fine (even through the Android Auto interface). The problem is only initiating the playback through the Android Auto interface.

Thanks for the help!


The update to 8.0 didn’t change anything unfortunately. I switched to internal storage, but since then I haven’t been able to sync anything to my phone. I tried to sync a playlist and it says “waiting to download” in the sync status. Up above it says “sync complete” and 50%. Not sure how to interpret those seemingly conflicting messages. If I click the circular “refresh” button it says “updating information” in my status bar but then it quickly disappears.

I should add that over the past day my server is crashing regularly. I think it has crashed 3 times. I’m not sure what is going on with that. But the whole syncing issue that I’m talking about here has been going on for months now. Latest server logs attached.

Update: I changed the sync location back to external storage and it will sync again (but still has the same issue of saying the playlist is only 22 seconds long).


I uninstalled the app, reinstalled and then deleted all of the app data and cache to be sure. This time I was able to sync to internal storage, but the results were the same (playlists that say only a handful of seconds long).


@nokdim Have you had a chance to take a look at my server logs? Please note I’m having other server issues that started this past week that I’ve posted about here:

But the issue I’m talking about in this thread, about playlists, has been ongoing for months now.


If any other Plex Ninja is out there… I’m trying to resolve this before the return window for my new phone expires. Thanks.


Unfortunately this issue is still persisting. Anyone have any thoughts?



Same issue on my Nexus 6P (no external storage). My playlist is something like 630 songs, and I’ve never been able to play it through android auto. It either shows up empty or with 2 seconds.