Android sync doesn't work when not connected to plex server



I can sync content to my android app (using external storage) from my plex media server and I can play the content when switching to the device using the drop down menu on the main screen of the app. However as soon as I leave the wireless network and lose contact with the plex server, the app no longer sees any of the synced content and just shows the "no servers available" message when selecting the device in the app. As a side note, I can't sync large items, eg. the full music library. It starts syncing, but crashes the app every few minutes. This is annoying because I bought a 128 SD card specifically to sync my entire music collection. So all in all this feature seems very broken and I would be better served by just copying the files on to my phone and playing them with a different app. Incidentally this has been broken for a long time, I tried sync more then a year ago and gave up as I didn't have a use for it at the time.


It looks like perhaps I can see the synced content when connected to any wireless network, doesn't have to be the one my server is on. How does this get past QA? :-/


I'm looking at your logs. I do see an error with gathering the section data. I'm not sure what's causing it. Will get back to you soon.


Thanks for having a look, let me know if I can provide any other information.


FYI - Still investigating, but I'm not able to reproduce the error on several Android devices I have. Is your device rooted and/or running a custom ROM?


Nope, stock Android 6.0.1 on an Xperia Z2. I have 128GB SD card installed if that makes a difference.


Same here crashes Plex when trying to sync all music library with over 6000 songs.


I have to go one by one album works but tedious.


@adhutch1 said:
Same here crashes Plex when trying to sync all music library with over 6000 songs.

Do you have room on your device to hold all 6,000 songs? You also need room on your PMS computer to hold a copy of these songs before they get transferred to your device.


I have similar problems, mentioned here:

I think that I have identified my problems to being related to a not so good network connection to my server (I live in Guangzhou, China...), or if my server is under heavy load.

The reason to my conclusion is basically this:

  • Almost always when I am in my home wifi network I can see my sync´d libraries.

  • When I am on the go...out in the city or using wifi network (@office, subway, starbucks, etc), the problem occur. Sometimes I can access and sometimes I cannot access my sync´d libraries. Unfortunately most of the time it is the latter, which renders the sync useless.

...thus when I put my phone in "flight mode", I directly I can see my sync´d libraries. I tried this several times and it has always worked.

I am happy to support with logs or anything else that can solve this bug.

_(I have not experience this problem when using my iPad, always seem to work there..). _


I have more than enough space to store everything on the server and the phone.


I'm having the same issue on my oneplus one. Content is showing as synced, but unless I have a wifi connection I can't see any of my music.


Same issue on my new Samsung Galaxy S8 phone. The synced data is there on the SD card, but will not show in the plex app. More than annoying, it is simply broken. I have removed everything and tried to start over several times. I have tried internal and external (SD) storage with the same result. The player simply cannot see the files. It works the same with wifi on or off. It is broken.

When will this be fixed? It is such an obvious bug I find it very hard to believe it cannot be recreated in house by plex. Come on guys!


This flat out's not rocket surgery here, we're talking about just being able to push some tunes down to our mobile devices from our Plex server....come on already!


@dgmelvin said:
When will this be fixed? It is such an obvious bug I find it very hard to believe it cannot be recreated in house by plex. Come on guys!

I truly cannot reproduce this issue. I have some videos and music synced to a Samsung S6. I switch the phone to airplane mode, turn on the Plex app, select my user (only one shown since I have Plex Home and no internet). I can select my local device and my videos and music are there. They play back properly too.

Can you get me the logs from the App with and without internet so I can see if there is something different going on?



I have totally different experience, as mentioned above - and repeated:

I can access my synched content when I am in my "home wifi", if I am not in "home wifi" I need to put the phone in flight mode to access the synched content.

I recently deleted and synched down new content since I moved my PMS from a Mac Mini to a QNAP, still same experience.

When I write this I am at office and my phone is synching content (resuming a synch I started at home) using the "office wifi" but I cannot see any the synched content...


Logs please.


From now attached to this post.

Older one can be found in this thread:


@"MovieFan.Plex" Any comments or if something is missing please let me know..


I see something odd in your logs.

<TITLE>Network Error - tcp_error</title>
For assistance, contact <a href="">IT Service Desk.</a>

Is that your work? Looks like something at your work is interfering with the app.