Android TV 7.1.2 and Plex player sound problem

android-tv
fire-tv

#1

Hi,
I'm using Plex server on a Synolody DS415 (ver 1.10.1.4602) and an Android Plex client on a BeeLink GT1 Ultimate under Android TV 7.1.2.
Actually have no sound !
When I try to activate Passthrough, only stereo movies works fine. When I try Passthrough and 5.1 movie, Plex says the connection to the server was lost.

Before the update, I was using Android TV 6.0 on my Beelink GT1 and all work fine!

Is there a solution to have sound with Android TV 7.1.2 ?
Thx


#2

Another information, when using plex for Kodi on my android TV, sound work fine !
Why didn’t with Plex client !


#3

I just got a Beelink GT1 myself and have the exact same problem. Been using Plex clients for years, iOS, Apple TV, Samsung, etc and never seen this problem.

When I play same video files with Kodi, sound works perfectly fine.

With Plex (6.11.2.3107 build) it doesn’t work - UNLESS I switch the video quality a very low setting then it works fine.

Other than that it doesn’t work.

Any help available for this?

David


#4

I don’t understand why Plex Staff doesn’t help us with this… This is a software bug for sure. :frowning:


#5

I too have a Beelink GT1 (with custom rom android tv) with this problem of sound in ac3 … If at least plex allowed us to force transcoding for this kind of China Android box

sorry for my bad english


#6

I have no sound (AC3, DTS) using Plex on an Alfawise H96Pro plus tv box.
It is using Amlogic S912 chipset. I heard Plex has problems with Amlogic chips.

Workaround: On normal Android if I choose to use the external Android meda player the AC3,DTS audio works. (no audio passthrough)

On Android TV OS unfortunately there is no such option.
If the fix is not possible in the near future could we get at least that option in Android TV version too?


#7

Same problem here

(Android 7.1.2, Plex player 6.11.3.3147, H96 Pro+ Android China box)

No sound through the Plex app, but Plex-for-KODI works fine?


#8

@phillil said:
Same problem here

(Android 7.1.2, Plex player 6.11.3.3147, H96 Pro+ Android China box)

No sound through the Plex app, but Plex-for-KODI works fine?

Plex -for-KODI works, but there are some annoying bug.
The audio/subtitle changing dialog if I used once will be empty if I try to open it again.
+no audio information is shown after this in the movie main page. I think I have to play some video in Kodi to fix this issue.
(tried with latest KODI 17 + plex addon 0.1.3 amd KODI 18 alpha + plex addon 0.1.4)

So it’s not ideal and I like the fact that Plex app can show suggestions beside youtube videos on the Android TV home page.


#9

OK kodi is a temporary solution, but is not The solution… Plex should do something!
Why the TV application is so poor in option compared to the smartphone application… There are also options that disappears over the versions … I find it a shame.
I was interessing to the Plexpass but not with these bug fixed!


#10

I already have a Plex pass and I cannot use my 3 Android TV boxes with the app because I have no sound…


#11

Hi,
My problem: “No sound” (bad chanel mix) for aac 5.1 on android box (Zidoo)
My solution: change audioCodec to mp3 in TranscodeTargets section in file plex_home/Resources/Profiles/Android.xml

This is solution not excellent, if you have many different android devices.
Change setting “internet streaming” to “2M 720p” helps too.


#12

I have the same problem. Is there any permanent fix in sight from Plex?


#13

ok plex worked all last summer on my android box, set it up this year and it didnt work. some error about cant find stream from server. but all my tivo boxes and android phones work great.
so i go buy a new android box and it works, atleast until i powered off the android box and restarted it. i have read the error is to do with audio passthrough. so i turn if off and i get a picture with no sound. i turn it on and i get cant find stream.
is plex working on this? i see lots of posts about ac3 audio and plex.


#14

@HackitZ said:
ok plex worked all last summer on my android box, set it up this year and it didnt work. some error about cant find stream from server. but all my tivo boxes and android phones work great.
so i go buy a new android box and it works, atleast until i powered off the android box and restarted it. i have read the error is to do with audio passthrough. so i turn if off and i get a picture with no sound. i turn it on and i get cant find stream.
is plex working on this? i see lots of posts about ac3 audio and plex.

Have the same problem on my Alfawise H96 Pro+ with Android SCV7A 7.1.2 and Plex for Android 7.0.2.5441(1e95bf1b)


#15

@HackitZ said:
ok plex worked all last summer on my android box, set it up this year and it didnt work. some error about cant find stream from server. but all my tivo boxes and android phones work great.
so i go buy a new android box and it works, atleast until i powered off the android box and restarted it. i have read the error is to do with audio passthrough. so i turn if off and i get a picture with no sound. i turn it on and i get cant find stream.
is plex working on this? i see lots of posts about ac3 audio and plex.

The problem is probably not with PLEX but with Chinese devices people buy which do not have any codec support due to the licenses plus wrong implementation of public audio standards.
Get yourself proper device with licensed codecs like Sony or Philips TV, FireTV stick or nVidia Shield or post logs here for every problem you have because without it nobody can tell what issues you are really facing.


#16

@mmhorda said:

The problem is probably not with PLEX but with Chinese devices people buy which do not have any codec support due to the licenses plus wrong implementation of public audio standards.
Get yourself proper device with licensed codecs like Sony or Philips TV, FireTV stick or nVidia Shield or post logs here for every problem you have because without it nobody can tell what issues you are really facing.

Easy for Plex – classic response (even though they state it is a multi-platform software). If people are buying and using these boxes than it is incumbent on Plex to develop a solution if they wish to continue in business.

If everybody is using these boxes, people will just migrate to Kodi (free) vs Plex Pass ($). Multi-platform software should never dictate what hardware you have to buy and if it does … run away!

Did this ever get resolved? I have the same issue with 2 different brand new android boxes.

A Vorke Z6 Plus and an H96 Pro +. I have Plex Pass but perhaps not for much longer.

Sound works in Kodi and Kodi Plex addon.

Does not work in native Plex for Android.

Both running android 7.12 and Plex is up to date.

Both connected via HDMI to TV and TV has optical to Samsung sound bar.


#17

We can’t control the optical coming out of your TV. Do you get sound if you unplug the optical cable? If so, then Plex is working fine, and your TV is not able to pass the audio through the optical to your speakers. You can try checking your TV’s main audio settings to see what other options you have. If you have a sound bar, it could be a mismatch on the codec support. Turn your TV to output only stereo and see if that helps.