Android TV App has no Sound :-(



Hello Coder

2 of my users have had a problem with your app for some time now.

It is installed on the following Android Box: 9042311.0.0. pAEvIP

No matter what we set, the played video never has sound. However, if we install the plugin for Kodi on the box and look over it, it works until server version 1.6.1. After that there is a playback error, which is already known and obviously worked on.

But as I want to update to the newer server versions we need a solution for this problem. In my opinion, it can't be the server or the box. (Because it runs over Kodi and the video runs flawlessly, only without sound)

What can we do here? The problem has existed for a long time and with every new version we try again but without success. Since my users prefer to watch your app over Kodi, I need a solution.

Hope you can help me find out what might be the cause.


considering it’s different for different users, it’s likely a client setting.
please check…

  1. what kind of audio do those files have?
  2. direct stream / play set to forced?


Since I have put both devices into operation, I can rule out a setting error.

The files have all between AC3, DTS, DTSHD, AAC and MP3 as sources. But nothing works at all, no matter which source, container etc… Picture always perfect but no sound.

As I said before, because there are problems with the Kodi add-on (with Server 1.6.1, but they are solved, according to the forum) running with the same settings, so it has to be the app.
Also, if I read something about the threads here in the forum, there are a lot of problems. I’m just wondering why there’s hardly a thread about it written by the programmers. These are serious problems and should have been solved long ago. As I said, I’ve had the problems for 2 months and here are some older threads. I only reported it now because I would like to update the server version, but this is not yet possible with the Kodi variant and my users would like the solution with the direct app anyway.

I sincerely hope that this problem will be solved soon.


I don’t want to be the judge of that.
Apparently it’s not a general issue. It’s e.g. working just fine for me. I’m aware this fact doesn’t fix your issue.

However I don’t want to rule out it’s a configuration issue on the client. Don’t get me wrong… there’s just too many people in forums claiming their own setup is perfect (hence it must be someone else’s fault). However when looking into their details there’s at least a number of factors contributing to the issue.

I hope you’ll find someone with the right clues to get this sorted.


I don’t know how you figure it’s not a common problem? Alone on the first 3-4 pages of the Android TV Forum here, there are over 10 posts with the same problems.
Furthermore, the sound settings in Plex are generally very limited and sometimes even non-existent.

At first I doubted myself for a long time and really tried everything possible, although as a former IT system technician I am certainly not unfamiliar with the IT sector when it comes to such attitude matters. But the biggest factor that supports me in my thesis is the fact that it works with the same hardware and settings and the Kodi add-on without any problems. As written, this add-on also has a problem with the newer server version, but there is a known problem and a new version is coming soon.

But here it is the case that I have not read in any thread on the part of the programmers that you are working on something or you are doing something at all. I am also aware that there are probably several 100000 different configurations of hardware. Only the Kodi programmers and server people have this problem. So it’s bad support for me and probably with one of the most important apps, because Android is probably very popular.


I really need some help here.

5 of my users simply can’t look anymore when I want to update the server from 1.61 to the latest version. All together we don’t have any sound over the Android TV boxes and we don’t have a way out like with the old server version and Kodi any more, because with the new version the Kodi-Addon doesn’t work anymore. All trailers have sound, the TV-series sounds also come but as soon as you start a video, nothing works anymore. It can’t be that there’s no solution.


Would you be able to grab some client logs from 6our users that are having trouble? Also be sure they are using our latest release as it includes a brand new player with lots of improvements!

Steps on grabbing logs are available here:


Thank you for your feedback.

I’m sorry, but all my users are not able to read such logs. Some of them are already overwhelmed with individual settings. But I still have one of those boxes at home and check on the weekend to see if I can do it with the logs. Though I don’t think there’s gonna be much to see. Because the video is running 1A and the server also reports no errors, the sound is only not played on the TV. If I go over a home cinema and loop the sound through then it works again, so far I could already test with me. I tested everything with the latest versions last weekend, server, box and your Android version.

In comparison, as already mentioned in the Kodi-Addon, it works without any problems, but there is the problem that the new server versions after 1.6.1 are not running and the new version hasn’t been released yet.

The hardware of the box you see as written above. This is actually very good and if it were a hardware problem, it wouldn’t work with the Kodi-Addon or with looping through my home cinema. But these are not solutions for my users: -)


So I was able to test it intensively.

In the meantime it’s clear that everything doesn’t work with AC3 sound. DTS and AAC (when I go to 720p 2mbps) works. This is unfortunately not a solution for my users because it transcodes at all above 720p 2mbps to AC3 and this is not audible. DTS can only be used in my home.

Here is your desired logfile, I hope you will find it hard to find a solution soon:


Unfortunately, in version 6.14 nothing has changed. Furthermore, EAC3 and AC3 5.1 are not played back. As soon as I set the resolution very low and he switches to AAC stereo, I get perfect sound.

Please take care of this problem at last. This is certainly the 10th version I’ve tested and never worked, although extremely many people have this problem and complain all the time and post logs.


These log’s are odd, your device is advertising support for AC3 and EAC3 but looking at the specifications neither are supported. Do all your users that have issues use the same device?


Well. Weird. Can I somehow set it to convert everything to AAC? Is also 5.1 shouldn’t really matter much in terms of quality, should it?

I only want to be able to see that again, because the current solution via the Kodi add-on only works with the age-old server version 1.6.1.

I would be happy if there would be a solution as soon as possible.

Yes all 5 of them have this box (or the previous box but the same manufacturer)


Doesn’t work on mine either. I have to use an external player to get it to work.