Android TV [Philips TV] / unable to stream any video with forced transcoding



Dear Plex support team,

Could you explain me, why there are following settings [Android TV] when they don’t work please?

[All combination of configuration have no effect to do something.]

I tried all combinations, but always my videos are playing under “Direct play” and i am not able to reach playing of any video with “forced transcoding”.

I come out from this similar discussion:

…but i had to create new request because there is not exactly the answer which i am looking for and also has a marked as “Accepted Answer”

Thanks in advance and B.R., Robert


I have the same issue. My workaround for playing AC3 Audio on a Philips TV is not working anymore


I'm in the same boat since ~v5.11 (beta):

5.10 (and lower): works
5.11 (beta only): didn't work
6.0: works
6.1 (and higher): didn't work

Last working version is v6.0.1.523, something after this got changed.

I've already posted an issue in the beta forum ~1 month ago about this issue, so far I can say, that v6.0.1.523 sends the following to Plex Media Server (on disabled direct play):

[0x7f1ee27fe700] DEBUG - Completed: [] 200 GET /video/:/transcode/universal/start.m3u8?audioBoost=100&autoAdjustQuality=0&directPlay=0&directStream=1&directStreamAudio=1&fastSeek=1&hasMDE=1&includeCodecs=1&location=lan&mediaBufferSize=74944&partIndex=0&path=%2Flibrary%2Fmetadata%2F7641&protocol=hls&session=c8b492eb121c1faf-com-plexapp-android&subtitleSize=100 (11 live) TLS GZIP 34ms 489 bytes (pipelined: 1)

Starting from 6.1 it sends:

[0x7f1ee27fe700] DEBUG - Completed: [] 200 GET /video/:/transcode/universal/decision?audioBoost=100&autoAdjustQuality=0&directPlay=1&directStream=1&directStreamAudio=1&fastSeek=1&hasMDE=1&location=lan&maxVideoBitrate=200000&mediaBufferSize=74944&mediaIndex=0&partIndex=0&path=%2Flibrary%2Fmetadata%2F7641&protocol=*&session=c8b492eb121c1faf-com-plexapp-android&subtitleSize=100&videoBitrate=200000&videoQuality=100&videoResolution=3840x2160 (7 live) TLS GZIP 36ms 1642 bytes (pipelined: 9)

Whatever you setted in the settings.

But there isn't any reaction from the devs, yet.


same here.


can confirm, a real deal breaker.


Oh nooo, after last updating of "Plex palayer" on Android TV, both above functions have been removed ;o( I really don't understand, why manual transcoding function has been removed only for Android TV and for another devices, function has leaved still placed and operational without any changes. Really I don't understand. So, currently we [owners of Android TV`s] have no way to force transcoding any movies without losing of any quality. :'( Dear Plex, I would like to know why you came to this decision, thanks in advance.


i want to know this too
same problem my only chance to bypas this issue
is to know how to set up Serenity for Android
this will help to use MX Player for Plex
but i couldnt find anything since days ....


Yup, can confirm here on a Philips 43PUS6401. It was working just fine until late may, when the tv updated the plex client and both direct play / direct stream options where gone, after that none of my vids (mostly mkv with ac3 5.1) have worked again.
I can also confirm the workaround of editing the Android.xml profile in the server to force transcoding on ac3 does not work anymore, no matter how, the server always selects direct play for this tv, when obviously none of this mkvs are compatible with this tv.

Please give us back those options, or let us decide weather to direct play to a particular client or not.

I just want my plex server to transcode EVERYTHING, my server is powerful enough to do it, so why would i care about the client being able to reproduce it or not, just transcode the damn thing. Otherwise i would use dlna, the only use for the plex server for me is to be able to transcode, otherwise i would use kodi or any other better xmbc


On Bravia TV it is the other way around. I used to set "Direct Play: Forced" and every single on of my videos (some downloaded from YouTube) were playing, without any conversion. Now since that option is missing, with some videos it tries to convert them and then I get an error message that the Converter closed/crashed. Which is an old bug.

I seriously wonder why at Plex they keep removing options that were working just fine.


After the latest firmware update for the philips tv i can use the latest plex app without the android.xml Workaround and AC3 5.1 works fine for me now. DTS 5.1 is still converted to stereo