Any plan to add support for Samsung 2015 Tizen TVs?

smart-tv

#47

And no response from devs... No real explanation as to their reasoning for only supporting 2016.


#48

I would love to have the new app fore My 2015 Samsung TV


#49

So I have a 2016 Samsung smart TV UN60JU7090 but only have access to the old app. I would love to have the new app because I have audio issues with the arc capability on my av receiver on the unofficial app so I use an Android TV (Nexus player) which just increases the complexity of my system with another remote. Can I at least get the official app on my 2016 TV please !!!!


#50

Looks like a decent number bought Samsung smart TV in 2015.
;- )=


#51

we are still waiting? this 5 second fix hasn't been taken care of yet?


#52

I've made a post in feature request voting section for your liking.

https://forums.plex.tv/discussion/219835/add-support-for-samsung-2015-tizen-tvs


#53

@pax0707 said:
Looks like a decent number bought Samsung smart TV in 2015.
;- )=

It's worse than that as many 2016 models haven't been released until very recently. I bought a 2015 model two months ago and, at that time, it was a current model.


#54

I find your whole reasoning for not providing the official (Tizen) version of Plex on 2015 Tizen TVs confusing to say the least.

You are not giving 2016 owners a choice from what I understand (ie. they will only get access to the official app) and some of these people may have upgraded from older Samsung TVs and are familiar with the older (Orca) app. So why not just upgrade the app on Tizen 2015 TVs and be done with it. An official app that is not running in an emulation mode (the old Orca app does this on the Tizen OS) with the full set of features has to be the better option. The official app is also likely to be upgraded and enhanced on a more regular basis than Orca’s app.

No disrespect to Orca as I have used his app for years and have greatly appreciated his efforts. The people with pre-2015 Samsung TVs I am sure will continue to use and love his app. But for people who have a 2015, 2016 TV with the Tizen OS the official app should be the one to use.


#55

maybe a stupid question but how do i know which version i am using? now i have a 2015 samsung, so i know im not using the official app. but how do i see this if Plex will create an official for the 2015 TVs?


#56

Just cancelled my Plex Pass.

Thanks for nothing Plex Team...


#57

I can't see the point in obstructing a new app release that supports HD because a lot of people like the old non HD supporting app? At least rename the old to classic if it's such an issue?


#58

@aaronharstine said:
So I have a 2016 Samsung smart TV UN60JU7090 but only have access to the old app. I would love to have the new app because I have audio issues with the arc capability on my av receiver on the unofficial app so I use an Android TV (Nexus player) which just increases the complexity of my system with another remote. Can I at least get the official app on my 2016 TV please !!!!

Not that it alters things but Is that a typo on your model number? If not then you actually have a 2015 model
2016 = K
2015 = J
2014 = H
2013 = F
2012 = E
http://en.tab-tv.com/?page_id=7123


#59

Most of these reactions are based on the assumption that newer = better.
That's not always the case in software land. Tizen is very young and still has issues.
I did build a Tizen version for my app, but I'm still running the old one, because well..it's just works better.

Samsung took away the method of side-loading the app through USB after a firmware update.
That left us with the App Store as the only means to distribute the app.

Before you all say "I'm missing out, give me the latest and greatest" consider this scenario:
- We would strip the current version from the store (we and Samsung only want one Plex app there)
- We gave you the new version that might have some bugs or missing features.

How do you think that would have gone down?
Indeed, there would be another thread saying "We want the old one back!, are you crazy?"

We talked about this and it was decided that the line would be drawn at 2016 so the Plex team would have enough time to add most of the missing features and we wouldn't have any issues with the store transfer.

Now If you think you need to cancel your Plexpass based on this decision, then I can take some conclusions myself. You have had an app for many years, for free, but that doesn't satisfy you anymore because there is something new "and I need to have that". That's not only childish but also disrespectful.
You have forgotten very quickly that there was no app for 2015 to start with (other then the bad Samsung port)
I worked hard to get an app out for the 2015 Tizen models, where I had to convince Samsung to make exceptions and adjustments for us, and the Plex team appreciates that. They showed me the respect to let me have 2015 because of all the work I have put into it.

So instead of blaming them for not releasing the new version on 2015, you can blame me, it's my doing.
Maybe if I just left you in the cold, you would now have the official app.

FYI:
I have access to the new version (1.0.6) and I tested it on my SEK-3500 (2015 Tizen).
If you have a NAS as server, don't bother. The new version isn't optimized to run in Direct play mode (yet) like the current one is. For now you will need a server that has transcoding capability if you want to use the official app. No soft subtitle support yet either. Every subtitle needs transcoding for now.

So just saying: Be careful what you ask for, you just might get it..


#60

@Orca said:
Now If you think you need to cancel your Plexpass based on this decision, then I can take some conclusions myself. You have had an app for many years, for free, but that doesn't satisfy you anymore because there is something new "and I need to have that". That's not only childish but also disrespectful.

As I understand it, Plex never produced a Samsung app and instead left it to you to fill the void. Now they've finally stepped in to remedy the situation and produce their own app, they've taken a spurious decision not to support 2015 Tizen models for no valid reason.

Personally I think pass subscribers are perfectly justified in feeling aggrieved over this and have every right to vote with their wallets.

Don't get me wrong, your efforts have been fantastic and valued by many but shouldn't have been required in the first place. Personally I can't use your app as it won't connect to my PMS over a secure connection.


#61

Orca, I agree with the newer isn’t always better philosophy and agree there will be plenty of teething issues initially with the official app. Eventually, though this period will end and hopefully the official app will provide a good experience. When this happens you have then singled people out who have purchased a 2015 Tizen TV to not receive the newer app. Do you see yourself eventually providing a native Tizen version of your app for 2015 Tizen TV owners?

Heading forward as people with older model TVs upgrade, Tizen will become more and more prevalent and the official app will be the app to use but people with 2015 Tizen TVs are sitting in a very frustrating position where their TV would run the official app but it is not provided.

As I state in my previous post I have used your app for many years and greatly admire and appreciate your effort. I think the best answer for all would be the two names for the different app versions if you want to keep the best experience. Then 2016 Tizen owners could also have the choice of app as they may/will find the same period of frustration as the new app is sorted.


#62

For 2016 there is no other option, since that is Tizen only, so It will not run an Orsay (old platform) app.
Which was one of the reasons to make the split there.


#63

I believe that was a typo and he meant to say 2015..


#64

@Toby Groves said:

@Orca said:
Now If you think you need to cancel your Plexpass based on this decision, then I can take some conclusions myself. You have had an app for many years, for free, but that doesn't satisfy you anymore because there is something new "and I need to have that". That's not only childish but also disrespectful.

Personally I think pass subscribers are perfectly justified in feeling aggrieved over this and have every right to vote with their wallets.

Only PlexPass subscribers? .... That seems to imply that a Plexpass entitles a subscriber haw the right to demand/complain.

.> @Toby Groves said:

Don't get me wrong, your efforts have been fantastic and valued by many but shouldn't have been required in the first place. Personally I can't use your app as it won't connect to my PMS over a secure connection.

Have you done anything to troubleshoot this. In an earlier post you seem to imply that Orca's app and Secure connections don't work, full stop. But they do both locally on my Samsung TV, on a remote Samsung TV and a remote BD Player belonging to people I share my server with. I'm not so active in the Samsung section lately and maybe you have asked for help.

I will add that the new app is a stripped down version but based on a PMP interface. Just as Orca's app is based on PHT. I'm not currently using Orca's app but only because I was bought an I7 NUC and I run PMP embedded,
So between a low-mid range Samsung and an I7 NUC running nothing except PMP its a total no-brainer which will be faster to navigate through your media. Yeah...Orca's app by a country mile. But only half a mile if you're either happy to navigate with a keyboard on invest in a Harmony Hub and remote. The Harmony hub actually has given me hope that PMP will one day be reasonably usable and is the only reason I persevere with it.

And yeah I know you're probably thinking WTF is this guy talking about? Who mentioned d PMP? etc..
Well there's plenty here who seem to want a stripped down version of something that's already stripped to the bones an out of the box is currently a total nightmare to navigate. See the PMP and PHT sections for proof. Each to their own I guess.

Hell @mattseeley 's app (and any other devs who work on it) isn't even available for ALL 2016 models yet.
Like all other apps it will evolve.

One final thing. I'm not sure what you mean by @Orca efforts should never have been required. Do you mean that up until the relatively recent PLEX for Smart TV app was launched that there should never have been a smart TV app at all. Maybe Plex should have pre-empted and created a Smart TV app before Orca did. In essence before a Smart TV existed.

Do have you have any idea how few clients there were back in the day when Orca went to so much trouble to provide something for free? Plex did not leave it to Orca to develop his app.. There was no such thing as a Plex TV app (aside from LG TV's which was basically just DLNA).and was probably at the time not even in the master plan. If it wasn't for the positivity to Orca's app there may still not be an official Smart TV app.
Just my thoughts.


#65

@Orca said:
For 2016 there is no other option, since that is Tizen only, so It will not run an Orsay (old platform) app.
Which was one of the reasons to make the split there.

Sorry, was not aware they had removed the ability to run the old platform for 2016 TVs.

I suppose my concern is that obviously the 2015 TV models are running an emulator under the Tizen OS to allow old Orsay apps to run. Is this not potential limiting access to TV functionality? If I had a movie encoded with HDR information on a 2015 SUHD model TV is the emulator able to access the appropriate settings to display this movie with HDR? Also, is the emulation creating some level of overhead and large high bitrate 4K movies could have issues?


#66

@davehobson said:

@aaronharstine said:
So I have a 2016 Samsung smart TV UN60JU7090 but only have access to the old app. I would love to have the new app because I have audio issues with the arc capability on my av receiver on the unofficial app so I use an Android TV (Nexus player) which just increases the complexity of my system with another remote. Can I at least get the official app on my 2016 TV please !!!!

Not that it alters things but Is that a typo on your model number? If not then you actually have a 2015 model
2016 = K
2015 = J
2014 = H
2013 = F
2012 = E
http://en.tab-tv.com/?page_id=7123

No it's not a typo. The TV was released in January 2016 though