Apple TV 4 transcoding multi-channel AAC audio to AC3

apple-tv

#1

Hi,

I'm not sure why but my Apple TV is always transcoding multi-channel AAC audio to AC3. Even though "Surround Sound" on the Apple TV Audio and Video Preferences is set to "Best Quality Available".

Shouldn't the Plex Player support multi-channel AAC audio on AppleTV natively?

Thank you,
-- Tiago


#2

Try changing the setting from "Best Quality Available" to Dobly Digital Surround (or whatever the wording for that setting is). You would THINK that "Best Quality Available" should automatically equate to use multi-channel if it is available, but this is definitely NOT the case. It was this was on the ATV3 as well as ATV4, and incredibly stupid IMO.

It is worth mentioning this setting could create the same problem in other apps besides Plex. I think HBO NOW was also mixing everything down to AC3 before I changed it. Hope this helps!


#3

I found a solution.

Copy ${PLEX HOME}/Resources/Profiles/tvOS.xml to ${your home folder}/Library/Application Support/Plex Media Server/Profiles (Create the directory if it doesn't exist.

Open tvOS.xml and change the line:

<UpperBound name="audio.channels" value="2" />

to

<UpperBound name="audio.channels" value="6" />

It is working now without transcoding audio. :)


#4

Maybe I'm dumb, but I cannot find the tvOS.xml file on my Mac. When I go to ~/Library/Application Support/Plex Media Server/ I do not have a Resources directory. Any ideas? Thanks in advance!


#5

Its in the Application itself. Go to your Applications folder, right click on the Plex Media Server.app and select "Show Package Contents".