Apple TV app defaults to “Play Original Quality” video won’t play. Only “convert automaticaly” works

apple-tv

#1

tvOS v.11.0
Plex app for tvOS v.1.18.1 (7207)

Apologies if this is already a thread. I was unable to find one on this topic.

Issue: (This following issue did not happen before both the tvOS 11 and complementary Plex updates.)

In Apple TV Plex app almost all videos will no longer play unless I first go into the menu of that media item and select -> settings -> quality -> convert automatically.

The default always seems to be set to “play original quality”. On the plex media server (v.1.9.6.4385) setting -> Web (top tab) -> Quality (side menu) I have already set the default as “Automatically adjust quality” (for web) and then further down under the “Home Streaming” section, selected the “Use recommended setting” check box, which describes its function as “All compatible videos will play at original quality. Incompatible videos will be converted at maximum quality. I also have set my server to use all the hardware power it possibly can, never had an issue of this sort before on my network. Nothing has changed since these recent software updates (October 2017) ...and so now I am curious as to why on the Apple TV app (and for that matter the iOS app as well) the setting keeps defaulting to “play original quality” which actually is preventing the video from playing altogether. The Apple TV app attempts to play the media but without success instead stopping with the message “something went wrong, please try again later”. ... Needless to say, no amount of “trying again” or waiting until “later” comes, fixes the problem.

Obviously the work around I have found is simply what I am detailing here; to make sure to set that specific media item’s quality setting to “convert automatically”. While this is a temporary fix, it does not feel like a solution, an actual solve would be most welcome; something like the ability to set the default to “convert automatically” across All Media, at the very least. (Yes, I have the “Auto Adjust Quality” to “On” in the main settings menu of the Apple TV Plex app as well) - another little bug I noticed while writing this and checking the settings was that in that same menu the “Play Smaller Videos at Original Quality” item is default set to “On”... no matter how many times I set it to “Off” it resets back to “On”.

Incidentally I noticed the opposite of this problem on an Android thread, that the app defaults to convert automatically and the user there seemed to want it to “play at original quality” I thought of warning them that they may not want that if it stops videos playing as it does with me.

Apologies for the length - I was attempting to be precise and thorough about the issue.


#2

can you tell what kind of video file you have problems with?

As to the settings: I observe similar behavior on the “Play Smaller …” … as to your workaround: I have to check wether this works for me as well, my workaround is different as you can read here:

Frank


#3

@fsl2014 said:
can you tell what kind of video file you have problems with?
Frank

.mp4 and .mkv files mostly 720p and 1080p I noticed my plex server never used to handle .mkv files well, so converted most of them to .mp4. File size ranges between 150mb - 4Gb (never larger) these days it does not seem to matter, both .mkv and .mp4 exhibit the same behaviour i outlined above.


#4

Hi,
I can confirm you workaround. In my case the problematic files are interlaced and less than 10GB file size or maybe less than 10Mbits bitrate. Interlaced files have to be transcoded and that is currently only per file setting possible. there is no general setting possible.

Can you check your material:

a) if it is interlaced
b) what is the transcoding status at the end?

And your observation is, that this all came with tvos11? That is not consistent with the reports of other guys, which have same problems with interlace videos.

Frank


#5

I too have this same issue on my Apple TV 4th Gen. It seems like recently any file that is set to play original skips and jumps a lot. As soon as I tell it to convert automatically it works just fine. The Apple TV is hardwired to the same switch as the Plex server and NAS drive. I have not had issues in the past with this and files used to play just fine. It almost seems like it has something to do with one of the updates but I can’t confirm that. All of my files are MKV files.


#6

Wanted to add that I’m experiencing this problem specifically with a bunch of HEVC 10-bit videos. The screen buffers for an unusually long time (~5-10 seconds), then the screen stays black as the video plays at “super speed” (30 minute video plays in about 15 seconds). This only happens if the AppleTV is set for “Original Quality”.

If I change each individual episode to “Convert Automatically” the media plays fine. Unfortunately, I have over 20 TV shows worth of episodes I have to manually change each episode to “Convert Automatically” to make this work.

Definitely seems like there is a bug in the communication between PMS and AppleTV for original quality on that type of video.


#7

I have the same problem with recorded Live TV content. When playing a TV show/ movie in original quality I only get a black screen. I have to convert it to make it play.
This however only happens with TV shows or movies I have recorded with Plex DVR from Live TV.


#8

Another user mentioned downgrading to 1.10.1.4602 temporarily, worked for him and me as well…

Info on how to do that here: https://forums.plex.tv/discussion/223300/osx-rollback-updatea


#9

I too am having issues with this. Apple TV 4th gen.
Playing x265 codec vids that are all .mp4.
All vids play sound but do not have picture until i make the individual file convert automatically then the problem gets solved but I have to do this EVERY TIME i want to play the file. If the file is a blu-ray file, default 1080p, it will play fine at initial startup.

Can give more info if this is unclear.


#10

I’m having the same issue and setting “convert automatically” also worked. If it helps the devs, I got verbose logs from my AppleTV 4k while the issue was happening.