Apple TV audio stops randomly

apple-tv

#1

My setup is Plex 1.9.0.4252 on Ubuntu server, streaming to an Apple TV (tvOS 11.0). With one movie in particular the sound will just stop while the video continues. If I pause and play, the sound will start up again. If I watch through web client, it seems to play (and the sound is) fine. Only thing I notice different is in the plex logs, when streaming to the Apple TV, I see the following message periodically:

DEBUG - Failed to stream media, client probably disconnected: 32 - Broken pipe

Also, the audio doesn't stop at the same point every time. If I start from the beginning it will sometimes pause at 1:23, then the next time it will make it through 5 minutes, or 2, or...

It is highly reproducible with this one video, but as it just started yesterday, I'm not sure if other videos will also have this problem.

I've restarted the Apple TV. Restarted the Plex server.

Any ideas?

Thanks!


#2

Has happened to me too after updating to tvOS 11 (Plex server 1.9.1.4272 on macOS 10.12.6). Never happen before. Hope it can be fixed on the Plex side of things, so waiting for a tvOS update isn’t required.


#3

Same thing happens to me. I think I’m going to try the beta tvOS 11.1 that was just released today for public beta testers.

My setup is Plex app on Apple TV (4th gen) with tvOS 11 and my Plex Server is on Version 1.9.2.4285 Qnap NAS.


#4

Update: tvOS 11.1 does not fix this issue.


#5

I’ve got this as well an it’s on Plex about 40 minutes into almost anything, the audio just drops then comes back but only through one channel, as if it flicked to mono. I’t very odd.

K.


#6

Same Here!!!


#7

I’m going to post this issue the beta forum, hopefully it’ll gain more traction there.


#8

Logs and a video sample of the issue taking place (such as taken by a smartphone) would be helpful. Info on how to get logs to us from Apple TV are in this article. Thanks!


#9

This happens randomly and so far only with HD videos on my system. Audio works fine then will randomly cut out until I pause the video and then unpause the video.
Apple TV Plex version 1.17.1
All versions of tvOS 11 including current public beta
Plex server 1.9.4.4325
Synology NAS 1.9.4.4325

dropbox.com/s/ai4bqzk92nyeo31/IMG_0266.m4v?dl=0


#10

@Kawikanui, thanks. I am filing an internal issue. Since this is reproducible with specific media, can I get some information on the media that is causing this? The “Get Info” information in Plex Web along with the XML.


#11

@kinoCharlino thank you so much! I’ve attached the XML file for your reference.


#12

@Kawikanui, thank you for the XML. I’ve added it to the issue for engineers to investigate.


#13

@kinoCharlino Any word on if this is being fixed? Thank you so much!


#14

@Kawikanui said:
Any word on if this is being fixed? Thank you so much!

It’s been in triage, but engineering has begun investigating this issue. It may be server related and not totally the client.


#15

I have this problem too. Audio just drops-out randomly for no reason. Video keeps playing. Have to pause and play for audio to start up again. Using plex server on Synology DS216play and Apple TV 4K. I also had a WD MyCloud EX2 Ultra, same exact problem. All my bluray library is uncompressed and remuxed to mp4 with audio converted to aac stereo. Direct played to Apple TV. I’ve got everything connected via ethernet cables and tried all sorts of things including upgrading to cat7 cables, highspeed hdmi cable, nothing solves the problem. Tried to remux with different software. My guess it seems to be a Plex server or Apple TV Plex App problem. Tried infuse and movies play just fine all the way through. Maybe uncompressed Bluray mp4 too large for Apple TV to handle? Maybe something having to do with MP4 profile level 4.1 that ATV is not compatible with? Or maybe its just a Plex problem. No idea whats going on.


#16

Hi, I’m having the exact same problem. Audio just stops at random but video keeps going, pausing then playing fixes it.

Has anyone worked out a fix for this yet?


#17

Gone through a number of Plex server, ATV tvOS, and plex app updates for the last 3 months hoping this was fixed but nope, same problem. Something is wrong. I’ve also noticed that if I skip to the end of videos near the end of credits the videos fail to play. I did a re-encode of one of my bluray movies and reduce the file size to 10 gig and noticed video played fine all the way through with no audio cutting off. I also noticed I could skip all the way to credits without the problem described above. Also noticed movie loaded faster no matter where i skipped too. When accessing subtitles on ATV I also noticed drop down menu doesnt take a 3 sec to show up. My guess is plex server doesnt play well with full blown uncompressed bluray movies. Or maybe their ATV app doesnt like the huge files.


#18

@kinoCharlino Been waiting on pins and needles. Any update for us on this issue? Thank you so much!


#19

Yeah I’ve still got the issue also.

Just about 2 minutes from the end of pretty much anything the audio drops out, I think to one channel for a few seconds then jumps back in just as annoyingly.

Which is a real annoyance when it’s in the middle of an important bit of dialogue!! :s

K.


#20

New to Plex, but have been using AppleTV fot a while with no issues. I’ve installed a mac mini server to run Plex, and am using it to record OTA broadcasts from a HDHomrun Extend. Everything is hardwired, trying to leave everything as generic as possible. Running live TV, or playing recorded material, has been continuously unreliable using the Plex app - video stutters, hung playback, audio drop outs - none of which has ever happened when playing Netflix or any other source on the ApTV. We just got a a new Samsung TV, and installed the Plex app on it, and all the media that was a problem on the ApTV is playing perfectly ( and much sharper and better! ) on the Samsung -

I’m pretty well convinced the Plex app on AppleTV is worthless - I’d rather not get another Samsung TV for the bedroom - perhaps a Roku? Any other suggestions?