ATV2 v5.3 Can't See PMS within Network after VPN put on my Network Router



I have an ATV2 with Software Version 5.3 and PlexConnect running as a client. My Plex Media Server is on another computer within my network. Everything was working fine.

I recently installed a VPN on my router so my whole network goes too a proxy. I opened the port at the proxy and plex can now be seen across all my different clients both inside and outside my network - except for my ATV2 within the network.

I have tried to solve this but I have no idea what to do.

If I am signed into MyPlex - ATV2 can't see any servers. If I am not logged in to MyPlex - ATV detects my server but libraries, channels, etc. are not visible.

Can anyone help?



PMS version and IP address ? PlexConnect version and IP address ?

In case you have the latest version from PMS and PlexConnect:

  1. If PlexConnect is logged in to MyPlex it searches available PMS servers in, and PMS must be logged in MyPlex to be found
  2. If PlexConnect is not logged in to MyPlex it finds PMS either by IP or through GDM (dependes on what you have coded in Settings.cfg) but, in addition, you must enable LAN authorization in PMS, otherwise your libraries will appear as empty in the ATV. In my case I have authorized all my local LAN

The second process finds PMS much faster (almost instantaneously) than through, but if you have friends sharing their content with you, then option 1) is the preferred one in order to access their libraries.


@moody_blue Thanks for your reply. Tried it but it didn't work. Also now my VPN has lost its portforward. Cant figure out what is going on here.