Audio File Installation


#1

I have my media files (video, audio, etc) on an external 3TB drive. I put all of my audio files in a folder I call AudioFiles in the external drive. One of the files has a filename of Various Old Tape. After updating the AudioFiles section, I have a very difficult time finding the Various Old Tape file so I can listen to it. I assume it should show up as a black square with Various Old Tape underneath it, but that is not the case. Is my assumption wrong? What is the correct procedure for installing audio files?


#2

I am assuming your files don't have any embedded meta tags.

Plex doesn't know the concept of 'various old tapes.'
It expects to see an Artist, then underneath that artist, an Album and inside that album some Tracks.

You'd have to put your 'tape' files into a folder, and for instance name it 'Old Tapes' -
this will be the 'Artist' name.

Then create a few other folders and name them 'Tape 1', 'Tape 2' and so on (or however you prefer)
These will be the names of the 'Albums'.

Then put the file inside these prepared folders.

So, the end result would look like the following:

Music / <-- music library is pointed to this folder
Old Tapes / <-- 'Artist' folder
artist-poster.jpg <-- a photo of a cassette tape or something like that
Tape 01 / <-- 'Album' folder
cover.jpg <-- cover for the album
1. Side A.mp3
2. Side B.mp3
Tape 02 /
1. Side A.mp3
2. Side B.mp3
...

see also https://support.plex.tv/articles/200265296-adding-music-media-from-folders/

possible 'side car' files for music
https://forums.plex.tv/discussion/comment/1319703/#Comment_1319703


#3

Thanks for your reply, it was very helpful. The black square is now a picture of a 7" tape reel. However, I can't get the text under the square to say Old Tape. It has [Unknown Artist]Ol. How do I get rid of [Unknown Artist] so that Old Tape shows up?


#4

Inspect the embedded metadata of your files. I have a hunch that they do contain [Unknown Artist].
Either:
change that to Old Tapes
(or remove all embedded metadata altogether)
then perform the Plex Dance https://forums.plex.tv/discussion/comment/908454/#Comment_908454

Or
Simply edit the 'Artist'
https://support.plex.tv/articles/201272763-edit-details/
(But you might have to manually edit it every time you add another of those tapes. Better do it right by using the above 'metadata' approach.)


#5

Actually, you might have to tell Plex to prefer your files' file names and metadata.
(By default, Plex prefers metadata from last.fm and Gracenote. But these don't know your tapes and therefore only return [Unknown Artist] as the Album Artist's name.)

Edit the library
https://support.plex.tv/articles/200289266-editing-libraries/
Go to the 'Advanced' tab
and tick 'Use embedded tags'

Then go to
Settings - Server - Agents - Albums - last.fm
drag the line 'Local Media Assets' into the topmost position.
Repeat the same under
Settings - Server - Agents - Albums - Premium Music

After making these changes, perform the Plex Dance (see above)


#6

I'm too much of a novice to follow some of what you have said. First, would my file have metadata? This tape was originated back in c. 1960, and digitized and written to a CD in c. 1990. Will that fact change your previous comments?


#7

@Pdeanb said:
Will that fact change your previous comments?

Nope, not at all.

Because you ripped it off CD again sometime, to put it onto your server, right?
And the software you used to rip and convert it into mp3 has probably put metatags into the files.
(Quite nonsensically so, because it never knew the correct data. One would assume that a ripper software would in such a case not put any tags in, but instead you end up with [Unknown Artist] etc...)


#8

What is the means of seeing (or determining) the "metatags" which my software inserted into the final file? Can it be easily edited? By the way, the file extension is m4a, not mp3. The ripping process was several years ago, so I don't remember how I did it then.


#9

Let’s first determine, where the [Unknown Artist] really comes from.

If you’re on Windows, do a right-click onto one of these files.
Then select Properties - Details

If there is nothing shown for Title, Contributing Artist or Album, then the faulty data come from the online meta data sources.
In this case, perform the steps I listed above to re-order the metadata agents in Plex.

If you instead see [Unknown Artist] under ‘Contributing Artist’, then it is the files’ embedded metadata.
You can either edit them in the above Windows properties dialog,
or you use a specialized software to do it, e.g. mp3tag