Bad aspect ratio for MP4s on a Samsung TV

smart-tv

#1

I rip my DVDs into MP4s using HandBrake 'Super HQ 1080p 30 Surround' preset. I stream Plex from a Windows 10 Ryzen 1700X machine.

It has been working beautifully until a couple days ago when the network connection was broken for a couple hours. When the network was restored, I brought up Plex on my Samsung UN60KU6300F. It had already been active, so it took a second to reset/go back to home screen.

Now every MP4 I've made is stretched wrong on the TV- 16:9 is narrow (shows black bars on the sides), 2.39:1 is narrow (the bars on top and bottom are shorter), 4:3 is wide (black bars on the sides are narrow).

AVIs, MKVs and other MP4s that I didn't create are fine.

I tried exiting and going back in, signing out and signing back in, deleting the app and reloading, and pulling TV power for 60 seconds (soft reboot).

I haven't tried resetting the TV to default- would hate to have to set the whole thing up again if it didn't solve my problem.

Playback is fine through Plex on the PC and iPhone.

Kinda freaking out here. Anyone have any ideas?


#2

Try converting the video to be 'Optimised for TV's'.


#3

The Plex app on the Samsung got updated a couple of days ago and dvd rips in 16:9 are all playing in 4:3. Is a problem with the Plex app not your hardware.


#4

WHEW!!! Thank you!! Have you seen any discussion about correcting it?


#5

There are a few threads on this sub forum about the 3.2.2 Plex app (the latest Samsung app). In the meantime a workaround is to disable direct play and direct stream. The resulting transcode if the right aspect ratio (although this solution is far from ideal).

1080p files appear unaffected by this bug.


#6

Has there been any update on this problem? Disabling Direct Play causes other issues, such as pixilation on 720 files. We need a more permanent solution, and this thread hasn’t been updated in almost a month. Is Plex working on pushing through a solution, or is there a way to go back to the previous version?


#7

+1 Still awaiting a permanent solution


#8

The developer silence is deafening...


#9

+1 Still awaiting a permanent solution