Both video and audio is being transcoded on one of my Android devices, but I don't understand why.

android-mobile

#1

Alright, I'm new to the Plex world and this is my first post, so be gentle :)
I have done my best searching this forum for an answer, but failed to find anything that explains my issue.

My smartphone, a Huawei P10, always transcodes both the video and the audio when watching media which has AC3 or DTS sound (which ~95% of my archive is using). I understand that the audio needs to be transcoded as my device doesn't support AC3 or DTS, but I cannot understand why the video gets transcoded as well, putting a lot of strain on my PMS which I'd like to avoid.

On my Samsung Galaxy Tab A 10.1 the behaviour is correct however. Audio is transcoded, but the video is "direct". I have checked and compared the settings in the PMP app between the devices and cannot find any differences except my phone has H264 maximum level 5.1, while the Samsung tablet has 4.2, both having their values set to what the app recommends.

If I activate Direct Play on the phone, it does actually play it without transcoding, but without sound as expected as DTS isn't supported.

Subtitles is disabled as well as it will need to transcode the video as it burns the subtitles (if I understand it correct).

Attaching part of the logs (the start which has the MDE parts) for both devices, and also the XML for the media used in the logs.

Any help would be highly appreciated!


#2

it is getting what it is getting from the phone itself as what it can play

May 03, 2017 20:33:06.678 [7192] DEBUG - TranscodeUniversalRequest: using augmented profile Android

it is transcoding because of

May 03, 2017 20:33:06.694 [7192] DEBUG - Chappie - video.profile limitation applies: high != baseline|main [list]

but don't recall ever seeing that reason before. usually it is just the level number not wether it is high or baseline that matters

will investigate


#3

Thanks for looking into it. But isn't it weird that it plays fine when forcing direct play?


#4

well something is off- dunno what yet. it is possible to get logs from Plex app on device itself when starting playback of that same movie


#5

Thanks for the tip, I could get the logs through the app with "Email device logs".

Attaching log snippet from a try yesterday with the same movie.

05-03 20:33:07.870 i: [video] The device doesn't support the 'high' profile, only: main
Shows up here as well. But at the same time MediaDecisionEngine says CanDirectStreamVideo: true
05-03 20:33:07.916 i: [MediaDecisionEngine] Decision: CanPlay: true CanDirectPlay: false CanDirectStreamVideo: true CanDirectStreamAudio: false CanDirectPlaySubtitle: false CanTranscodeSubtitle: false Transcode Reason: DTS audio is not supported by the device

Yet the final decision is transcode: true
05-03 20:33:07.955 i: [video] Decision made, transcode: true

In the same log file there was also logs when I played a movie that didn't need audio transcoding (Analyzing media: 1920x800 1343kbps (Container: mkv, Video: hevc, Audio: aac))
But still "The device doesn't support the 'high' profile, only: main" shows in the log here. Decision then was transcode: false.

I hope these logs can be of help.


#6

Any update on this one? Would more logs help?


#7

BigWheel, have you had the chance to look more into this issue? I've enrolled in the android beta, but this is still happening on the latest release.


#8

I recently upgraded to the latest android version and its also transcoding my video all the time too.. Wasn't doing it in 5.8

I discovered that the h264 profile setting is broken in the current android version. Maybe this is what is causing this for you too.

I also have a thread about it.
https://forums.plex.tv/discussion/272599/h264-maxium-level-broken-plex-for-android-5-10-0


#9

Just tried 5.8 by grabbing it from apkmirror, but I'm having the same issues...so I'm not sure the issue is the same :/


#10

@pellz0r said:
Just tried 5.8 by grabbing it from apkmirror, but I'm having the same issues...so I'm not sure the issue is the same :/

Well it was worth a try I guess.. Looks like we both have problems then...


#11

Still no update on this issue? It sucks that it's forcing transcode of video when it's only the AC3 audio that needs transcoding.

On another note, is the "force direct play" option gone now? Using the latest beta version and can't find it any more :/


#12

Installed Kodi on my phone, and then added the KodiPlexConnect addon in Kodi, and it worked fine with Direct play according to the status seen in Plex web. Why is it working in Kodi and not the Plex app? Does Kodi have built in support to decode AC3 etc?

I would prefer using the Plex app as Kodi really isn't optimal for touchscreen...


#13

@pellz0r said:
Does Kodi have built in support to decode AC3 etc?

Kodi will typically package software decoders that can cope with codecs that a device cannot playback natively. In effect Kodi is handling the conversion instead of the server for playback.

Unfortunately, I have no additional information on the status of the report BigWheel put in.


#14

@pellz0r - Unfortunately there isn't a fix for this. Your device reports it does NOT support the H264 High profile. So anytime you try playing a file with this setting, PMS will have to transcode it. It may be that your device will actually playback the file without issue, but Plex follows what your device says it can do. 2 options I can see are 1 - reencode your videos to not use the high profile, or 2 - set the app to use an external player.


#15

Thanks for the explanation @"MovieFan.Plex"!

How exactly is the device reporting this kind of information to the Plex app? Is this something that could be fixed/hardcoded if my device is rooted, or is it on a deeper level? I'm guessing that it's a pain to actually try to report this issue to Huawei, and then actually receive a fix for it... :disappointed:


#16

The Plex app calls an Android API that pulls the information from the device. You can report this to Huawei and see if they can fix it.They can contact us if they need specifics.


#17

@"MovieFan.Plex", I've now managed to get in touch with the Huawei support, and they just confirmed that the Huawei P10 supports high profile up to level 4.2.

I wanted to test this again and made sure to pick a video which had L4.2 or lower with high profile. Without thinking of it I did it through the Chrome browser on the phone, and the video played with direct stream on the video, and the audio was transcoded from dts to aac (as expected as the phone can't decode dts).

I then tried the same video in the Plex Android app, and both video and audio was transcoded. So is this a bug in the app, or why does it behave different using the Chrome browser vs the app?


#18

The Chrome browser doesn't do the same check.


#19

Thanks @"MovieFan.Plex", I've asked Huawei support to check it the phone reports wrong profile. If they need specifics from you, how can they best get in contact? :)


#20

Bringing this topic back to life a bit to get som closure. I enrolled in the Android 8.0 BETA for the my Huawei P10, and now it does seem that the video stream is no longer transcoded, as long as subtitles are off. If subtitles are enabled the video gets transcoded due to burn in. Is there any way to get subtitles to work without having the video transcoded, or am I out of luck there?