Buffering/Stuttering Problems with Subtitles

samsung-smart-hub

#1

Device Model: UN55HU70000 (H Model from 2014)

App Version: 1.015

Network Type: Wireless (WLAN)

Server Platform: Windows

Server Version: 2.3.24

Streaming Type: Local

Media Type: 1080p MKV with AAC Audio

Subtitle Type: PGS

 

CPU: i5-2500k @ 4.0 Ghz

Passmark Score: 6472

Memory Size: 16GB

 

Hi everyone, 

 

I'm having problems specifically with MKV files that use subtitles. Plex and the app work beautifully on 1080p MKV's with no subtitles. But with subtitles, it will buffer. This problem happens with both Transcoding and Direct Streaming

 

I have absolutely no reason to believe that my network connection is the issue because 1080p MKV's without subtitles work just fine, thus I'm thinking it has to do with the PMS/Transcoding. I have included a chunk of the 14000 line log. Please let me know if you need more.

 

 

I'm not sure if this is the place to post this, as it might not be a problem with the Samsung App per say. 


#2

Also, the same file without subtitles has no buffering. Only when enabling subtitles does it cause buffering. I've used the MKV Fixer by Orca as well, and that didn't fix it either.

I don't think it's PGS's fault because..

 

The new transcoder has been added and is working.It supports VOBSUB and PGS now. It now also has a Direct Stream mode that you can use to show embedded subs.

It will just build the stream without any major transcoding. It's the minimum requirement to be able to show these types of subtitles.

The app however is not quite done yet. It gets kind of complicated with 2 types of supported transcoders and an buildin overlay subtitle engine, to let the user make the right choice.

Old transcoder: can play embedded subs but not PGS and VOBSUB, no Direct Play possible, no 3D subtitles.

Universal transcoder: can play all subtitles (that plex supports), no Direct Play possible, no 3D subtitles

My own overlay subtitle engine: Is the only one that can be used with Direct Play and 3D, but only supports SRT/SMI.

This won't be a problem for the veterans, but new users might need something more simple.

 



#3

Bump..


#4

PGS and VOBSUB are supported, but only through transcoding. These are not text files, but images and might use more CPU from your server.

The difference between enabling the subtitles is that when they are PGS, the app will start transcoding because there is no other way to show you the subtitles you selected. The server will have to do the heavy lifting.

If you leave them off, or use external srt subtitles, it will start to Direct Play (if audio and video are supported), which uses the hardware of the TV to show you the video.


#5

 The server will have to do the heavy lifting.

Thanks for the reply, Orca.

Is an i5-2500k not enough of a heavy lifter at 6000+ passmark? I don't even see 100% usage by the CPU  :wacko:..


#6

Is an i5-2500k not enough of a heavy lifter at 6000+ passmark? I don't even see 100% usage by the CPU  :wacko:..

Did you try to do with with wired connection? instead of WiFi one?


#7

I tried a wired connection before my original post. No dice..


#8

After upgrading my PC to a 5820k with a Passmark score of 13565, I'm still receiving buffering on PGS subtitled 1080p MKV video's. Obviously, the issue isn't the CPU as I suspected.

I'm taking a wild guess that PGS subtitles are embedded and the actual "heavy lifting" is done by the TV itself. It would be nice to get a response on whether I am correct in believing the heavy lifting is done by the TV. 

Below is my solution, even though this shouldn't be needed.

---

My solutions after 20 days of messing with this is to just re-encode it with burned in subtitles using Handbrake. Unfortunately, when trying to do a whole folder at once, it does not allow PGS to be burned in. So, in addition to Handbrake, I am using Handbrake Batch Encoder to use the Handbrake Command Line Interface to burn in a whole folder of episodes at once. 

These are the configurations/presets I use to keep around the same quality/file size (if anyone cares).

-f mkv  -w 1920 --crop 0:0:0:0 --loose-anamorphic  --modulus 2 -e x264 -q 21 --vfr -a 3 -E av_aac -6 dpl2 -R Auto -B 160 -D 0 --gain 0 --audio-fallback ac3 --subtitle 1 --subtitle-burned=1 --encoder-preset=faster  --encoder-level=4.0  --encoder-profile=main

You can pick the options you want in Handbrake and then copy the configurations you want from the "Activity Log"


#9

Wow. I STILL have this same problem today.
I wish I could have advised the OP here to just use MKVtoolnix to extract the sub file, then use Subtitle Edit to convert to SRT. Then either remux the srt into your mkv file with mkvmerge or just leave it in the films directory and the TV uses it instead. I seem to have to convert ALL of the vobsub files or plex will not play without buffering…despite a beefy enough processor on the server!
I suppose I, like the guy above, was hoping for a solution by tweaking the buffer numbers or something. I see that isn’t possible now.
Oh well. Maybe my advice will help others.

HERES THE SOLUTION for working files
Get MKVtoolnix (mkvtoolnix.download/downloads.html , and a gui program like gMKVextract gui sourceforge.net/projects/mkvextractgui-2/ and load the file into that(mkvextractgui I mean) , then select the subtitle track and extract. Then you need Subtitle Edit github.com/SubtitleEdit/subtitleedit/releases (You will want the file at the top usually, or the one named SubtitleEdit-3.x.x-Setup.zip. download and run it.
Open the subtitle file with it. Then choose the subtitle stream you want to convert. Then start converting by letting it do its work recognising the images and putting them into text. It will pop up when it cannot recognise something - this requires that you type in the word it is stuck on manually. This happens often on some subtitle files. keep going until the end. then hit OK, then go to Save as srt… and save into your movie directory with the same name as the movie and the srt extension.
Plex will now play with that srt file but if you want to be picky, you can reopen the mkv into mmg.exe and drag the srt file into the window. It will add itself to the tracks in the mkv. You can make the srt the default track. Then save, or remux to a new mkv.
You now are free of the problem.
This can be sped up a lot, especially when working on multiple files… but the subtitle recognition part is annoying!
I came looking for a solution but I hope this has helped someone instead as much as it helps me. And if there IS a real solution please write it here!


#10

Hi,

I have the same problem too, it happen only on my samsung TV, i don’t have this problem on another client.
I don’t want to extract subtitles of all my video to be able to watch something.

3 weeks ago i had no problem.

Thanks


#11

Having same problem. Plex devs wake up and fix this issue plz.


#12

Also have this issue.


#13

I also have this problem but one thing I Did notice was that I originally set up the plex server on a laptop that was running W7. There was no buffering or stuttering with subtitles on. I switched to W8 and now I cant get through a decent 5 minutes. I use plex only to stream through my PS4 I dont use plex for anything else. So PS4 is my only option so I cannot omit it from my scenario. I also have google WIFI which I thought could have contributed to the problem but EVERYTHING runs smoothly and clear without the subs on. I only watch it with foreign subs only but the stuttering is a bit much at this point. I dont want to go back to hooking up the laptop to the TV through HDMI. its so much easier running plex! My guess is…does plex not have all the bugs worked out of W8? On W7 I could watch whatever with subs on and no stuttering!