BUG: audio language not changing

smart-tv

#1

Hello.
I have a SAMSUNG tv, model code UE40KU6450, serial number 0CKB3HFH800016Z, software version T-JZMDEUC-1201.6, BT-S
My plex version is 1.9.4.4325

I have some video files with two audio languages (russian and english) and I'm not able to change between them. I always have the russian language even when I change it to english.

I've played the files in the Android application and I'm able to change the audio, so I'm assuming that it's tv application problem and not a file problem.

Or am I making something wrong in the tv application?

Thank you.

Best regards,
João Paixão Silva


#2

Hi João,

We’ve identified that 2016 Samsung televisions are having trouble changing audio streams. 2017 televisions, in our testing, are working correctly.

You could work around by disabling Settings > Video > Allow Direct Play. This will cause app to avoid attempting to select an audio stream during direct play.

We’re trying to fix behavior on 2016 televisions before updating the app to automatically use Direct Stream for audio track selection support.


#3

Won’t that hit us with NAS equipment that can’t power the transcoding?


#4

Yes it does, I’ve got the same issue on a 2016 ks7000. As a workaround for now I play the video over DLNA directly rather than through plex. Doesn’t effect all videos though for some reason
Do we have an update on the bug?


#5

I have the same problem with my 2014 Samsung smart TV. I have several kids movies with both English and Portuguese. I try to play the Portuguese audio tracks but it insists playing the English track no matter what I do. Some movies are not affected and allow the audio track change. Please fix this.


#6

Hi,

I have this problem for a few months and not on a 2016TV, i have a Samsung UE48H6400, the H is for 2014.

I am surprised that with the years the software deteriorates, 2/3 years ago I made a thread because I can not start the reading (random or not) of the contents of a whole folder (anime for my little girls, Peppa Pig, Franklin, Tchoupi, etc …) I have to make lists of hundreds of files, it’s very boring … So we gave up!

For some months now, this problem of impossibility to change the audio, sometimes it’s just impossible, sometimes it is indicated unknown, but we can change, strange.
Effectively, going into streaming mode solves the problem, but it’s annoying in terms of the quality of the software. The sub are different, bigger, not place very well, not in the color we choose in the parameters.

Tnx for reading, and don’t forget that we are groaning because we are accustomed to the excellence of Plex :wink:


#7

I’m having the exact same problem. I have a 2016 Samsung TV which has played dual language version of movies faultlessly for years. My kids and I wanted to watch several movies which have english and non-english audio however if the non-english is first in the list even with AC3 English defined and displaying it plays the audio non-english track…
As mentioned above when you go into the options for the audio to try and toggle it says ‘unknown’
Transcoding is not a possible work around for me. I run x3 Plex servers, windows, x2 Linux but all get caned when transcoding and the TV just buffers all the time and the movies are unwatchable. This didn’t used to happen so what wet wrong?
The problem does not happen on a PC or mobile device.
Is there a Bug fix in place to address this anytime soon???
If no fix is imminent then I’m considering rolling back to an old version on one of the servers to allow me to play the multi-language enabled movies.


#8

Problems seems resolved…