[bug found] Cannot play some movies on Chromecast if TV is 720p only



I have many movies and series, from many different origins.

I can play all of them in Android, iOS, and browser, no problem at all.

I used to play all of them on Chromecast 1 also. But recently I got a Chromecast 2 and now most movies do not play anymore!

Please help!

Attached, my server logs. I trimmed them before and after the test, to keep them small.

JonnyCast is my CC2, SalaCast is my CC1.

Thanks in advance for any help...

(Edited title to refer to new discoveries in next comments)


I thought I would solve my problem simply swapping CC1 with CC2, but surprise!!! The problem is not on CC, but apparently on TV.

Now I can play my test video on CC1, but not on CC2.

I cannot play video to a 1366x768 resolution TV. But it works perfectly in a 1920x1080p TV. It MUST be some kind of transcode problem.

Here are the newer logs.


Hello anybody! This seens to be a bug!


Note: plexmediaserver- but it’s an old bug…

Server: Linux Fedora 27, usually up to date…


Looking in the logs posted I can see that when you are casting the file - the Chromecast is requesting that the subtitles be burned in to the video stream (which means the computer is re-transcoding the file, which requires a lot of CPU grunt). When you are playing it on your phone or tablet, it will happily handle subtitles without retranscoding the video. The new Plex Web player on the Chromecast that started being used today has better support for subtitles, so give it a try today and see if the problem still happens.

EDIT: The part of the log I am talking about:

Feb 04, 2018 22:42:57.104 [0x7fa0f07fd700] INFO - [Chromecast] [Player] setting src attribute https://192-168-1-10.3e129bbcd8fb4502b4f48fe6bcb39827.plex.direct:32400/video/:/transcode/universal/start?hasMDE=1&path=%2Flibrary%2Fmetadata%2F22&mediaIndex=0&partIndex=0&protocol=http&fastSeek=1&directPlay=0&directStream=1&subtitleSize=100&audioBoost=120&location=lan&maxVideoBitrate=3000&session=3g3fwkebi6se26nn1ewv2fit&offset=1405&subtitles=burn&copyts=1&Accept-Language=en&X-Plex-Session-Identifier=uz4lodfh22qro7ry4a8zbadl&X-Plex-Client-Profile-Extra=add-limitation%28scope%3DvideoCodec%26scopeName%3D%2A%26type%3DupperBound%26name%3Dvideo.bitrate%26value%3D3000%26replace%3Dtrue%29%2Badd-limitation%28scope%3DvideoCodec%26scopeName%3Dh264%26type%3DupperBound%26name%3Dvideo.level%26value%3D42%26replace%3Dtrue%29%2Badd-transcode-target-audio-codec%28type%3DvideoProfile%26context%3Dstreaming%26protocol%3Dhttp%26audioCodec%3Dac3%29%2Badd-limitation%28scope%3DvideoAudioCodec%26scopeName%3Dac3%26type%3DupperBound%26name%3Daudio.channels%26value%3D6%29%2Badd-limitation%28scope%3DvideoAudioCodec%26scopeName%3Daac%26type%3DupperBound%26name%3Daudio.channels%26value%3D2%29&X-Plex-Chunked=1&X-Plex-Product=Plex%20Chromecast&X-Plex-Version=3.25.0&X-Plex-Client-Identifier=bgiqqipkvfij9z1glpjidc8p&X-Plex-Platform=Chromecast&X-Plex-Platform-Version=2.0.0&X-Plex-Device=Chromecast&X-Plex-Device-Name=Chromecast&X-Plex-Token=xxxxxxxx


Upgraded to version 1.12.1 and still no success.

I do not think it is a problem related to subtitles, but to audio.

Every movie I can play has MP3 audio. I cannot play anything with AAC, ac3, vorbis, be it stereo or 5+1…


Just to confirm, @dioni21 - have you tried this in the last week or so? We recently updated the chromecast app.

If you’re still having issues please can you send me one of the files? I have a 720 screen I can test with here.


Hi @“Dom C”, thanks for your attention.

Just to confirm, @dioni21 - have you tried this in the last week or so? We recently updated the chromecast app.

Is yesterday enough? :wink:

As I said, I tried with version 1.12.1. Not sure if it is the real latest, but it is the last one I can download from plex yum repo.

$ rpm -q plexmediaserver.x86_64

I don’t know the internals of chromecast or HDMI, but could it be something related to what audio features the TV can handle? It is a very old LG Time Machine 42LB9RT.

If you’re still having issues please can you send me one of the files? I have a 720 screen I can test with here.

How can I send you such a large file as a video?

BTW: I am willing to run any test code or version you send me. I work with code developing and know how hard it is to debug these things remotely…


Hehe. Thanks.

The Chromecast app is versioned separately from PMS - the latest one should always run, and we did a big change last week and a bug fix on Friday.

https://support.plex.tv/articles/201035968-generating-sample-files-from-media/ gives instructions on how to get a smaller sample. Since I hope it’s the codec/resolution that’s the issue here, I’m hopeful a short sample will show the problem.


Hi again @“Dom C”,

Selected a simple video that does not play and cut 30s from it. Played it to make sure the bug is there.

This file, named plex.mkv, apparently could not be uploaded. Not even if I generate it with a smaller size, like 1s (67k). How Can I send it?

Doing some more tests, I noticed that Plex Transcoder is never called. I renamed it and put a shell wrapper in its place to log every time it is called, but it has never been called:


echo /usr/lib/plexmediaserver/'Plex Transcoder.old' "$@" >> /tmp/plex.log
exec /usr/lib/plexmediaserver/'Plex Transcoder.old' "$@"


Please, find attached a log excerpt. It has ben taken with the following procedure:

restart plexmediaserver (at
wait some time to settle
tail -n 0 -f /all-log-files | tee /tmp/plex-all.log
start plex android app (at
search for plex.mkv
wait some time to settle
indicate that I want to play to Chrome Cast
at this point, I had to click “device refresh”, because it was not showing my chromecast
Select my chromecast (SalaCast,
Audio is auto selected in English AAC Stereo, no subtitle available
Start to play
Nothing happens on Android (just a looping circle), not even after error on TV
On TV, It looks like it will start, but after some time:


Just after this I stopped generating plex-all.log

BTW: I took the liberty to enable verbose mode, since this is the second time I send logs.

In these I could see:

Apr 01, 2018 15:03:40.352 [0x7fecc9fff700] VERBOSE - We didn’t receive any data from in time, dropping connection.
Apr 01, 2018 15:03:41.794 [0x7fecc97fe700] VERBOSE - We didn’t receive any data from in time, dropping connection.

Thanks for you help and attention.


@dioni21 said:
This file, named plex.mkv, apparently could not be uploaded

Found the instructions. Here is the download link:



Hello? Any news, @“Dom C”?