Bug: LG WebOS player does not support Secure connections

smart-tv

#1

This is not a huge issue for my server, but Plex Cloud requires secure connections.


#2

We'd love to be able to support secure connections in all of our on all platforms. Unfortunately, platform limitations with how network connections are allowed to be made currently prevent us from being able to support secure connections on LG webOS. We're certainly hopeful that the situation will change in the future to allow secure connection support.


#3

Related, is there any possibility of Plex Cloud getting insecure connections then?

Can you elaborate on whats missing from webOS that is blocking this issue? I would like to open a ticket, I'm a registered developer with them.

Also, XPlay supports secure connections, did they have to use their own http stack or something?


#4

it is really annoying that LG WebOS 3.0 and PLEX cloud is not working with the official PLEX app.


#5

Any news in this regard? I find it incredible that the Plex application for LG Netcast (old) IF support secure connection, and the application of Plex for LG WebOS, do not.

It is incomprehensible. A newer product, more current, theoretically one of the best Smart TV on the market, and you can not use Plex resources than in previous versions if you can.

Any idea when this will improve?


#6

We don't have an ETA on this. The issue is not as simple as you state it @kennysamuerto with regard to new TVs and smart TV OS's not being able to support secure connections. We have tested secure connections on various LG TVs and the results have not been satisfactory for a release yet. Some newer LG models work fine but there are a number that have experienced issues in our testing. Since the release goes out to all webOS LG TVs, we need to ensure it works better across more models before making a public release.


#7

@kinoCharlino, If you would like, I am happy to beta test this on my OLED65C6P,


#8

@kinoCharlino - I could support you with beta testing on my LG OLED65E6 TV - it is a shame that I have to use XPLAY to watch plex on my tv ...


#9

Hi everyone, has there been any solution to this problem?

I have the same error in my LG Webos 3.0.


#10

Just joining the discussion.

We just set up our new LG OLED65C7P and the first thing that everyone wanted to use was Plex. Like others have said, the native Plex app does not show Cloud Plex servers; however, XPlay does. Unfortunately, XPlay does not seem to support folder views and we would really like to stay with the official app if possible.

The Plex developers are doing great work. Not having a LG webOS 3.5 client that supports Cloud seems like something that Plex would want to support and perhaps could bump up the priority. These OLED TVs are some of the hottest sets sold this Christmas and they really show off the content in Plex.

+1 for getting the official Plex app to work. Perhaps the XPlay guys could share how they did it with the Plex developers. shrug


#11

This is a show stopper for LG TV in remote location; at least let the user “try it out - in development” I suspect this is not an issue on 2017 models… :frowning:


#12

Plex Cloud is a winning feature and is the sole reason for me purchasing the Plex Pass. My comment on adding support on LG’s WebOS is that this should released as a configurable option under settings with a disclaimer. Until then I’ll test give Plex a try on Xbox One.


#13

I agree. If there is a beta version that could work on some TV, please release it as an option with a disclaimer. You would have lots of people that could provide valuable insights that could make the LG client even better.


#14

I didn’t see this mentioned anywhere, so thought I’d drop a note.

You can use Plex Cloud in the LG WebOS player by running a proxy locally.

One way to do it is to install i.e. nginx or apache on an ubuntu (i.e. a raspberry pi will suffice).

Basically the idea is to get the hostname for your Cloud PMS (available at https://plex.tv/users/cpms), and insert it into the proxy configuration (for nginx/ubuntu this is in /etc/nginx/sites-enabled/default):

    location / {
            proxy_pass http://<very-many-hex-digits>-<even-more-hex-digits>.ric.plex.services/;
    }

I simply use a http:// link for the Cloud PMS here, but you can use https:// if you see fit.

After a nginx restart, insert the ip of the raspberry pi and port 80 into settings -> local ips.

The Cloud PMS will now show up in the LG WebOS player app and work without any further ado.


#15

Same problem here. I have to keep firing up the PS4 just to see my friends shared Plex Server, yet xplay will work fine.