BUG: No DTS Audio for Android TV

android-tv
fire-tv

#1

I have a 2015 Sony Android TV X850C and downloaded the latest version of Plex in the App Store. I configured the player for forced Direct Play. DD 5.1 AC3 works but DTS 5.1 doesn't. If I remove the AC3 track from the mkv file, it doesn't play audio at all. I have tried Audio Passthrough with both Auto and Off configuration.

I read the release notes and I thought DTS passthrough was working in an earlier build. Am I missing something?

mkvinfo on the DTS track

| + A track
| + Track number: 2 (track ID for mkvmerge & mkvextract: 1)
| + Track UID: 2
| + Track type: audio
| + Codec ID: A_DTS
| + Default duration: 10.667ms (93.750 frames/fields per second for a video track)
| + Name: Surround 5.1
| + Audio track
| + Sampling frequency: 48000
| + Channels: 6

If you need more information, please feel free to ask. DTS Audio is something I really looked forward to.

UPDATE:
I gave up on it. It may work now that both Android TV and Plex had significant updates since I first posted this. Using an external Plex player now and it's working fine for me. For those using ARC, ARC implementations are limited to Dolby Digital at the most. For most using ARC, it's stereo.


#2

Media Info on the DTS Track

    Audio
    ID                                       : 2
    Format                                   : DTS
    Format/Info                              : Digital Theater Systems
    Format profile                           : ES
    Mode                                     : 16
    Format settings, Endianness              : Big
    Codec ID                                 : A_DTS
    Duration                                 : 2h 0mn
    Bit rate mode                            : Constant
    Bit rate                                 : 1 509 Kbps
    Channel(s)                               : 6 channels
    Channel positions                        : Front: L C R, Side: L R, LFE
    Sampling rate                            : 48.0 KHz
    Bit depth                                : 24 bits
    Compression mode                         : Lossy
    Stream size                              : 1.27 GiB (7%)
    Title                                    : Surround 5.1
    Language                                 : English
    Default                                  : Yes
    Forced                                   : No
    DURATION                                 : 02:00:06.998000000
    NUMBER_OF_FRAMES                         : 675656
    NUMBER_OF_BYTES                          : 1359419872
    _STATISTICS_WRITING_APP                  : mkvmerge v8.6.1 ('Flying') 64bit
    _STATISTICS_WRITING_DATE_UTC             : 2016-01-03 23:19:59
    _STATISTICS_TAGS                         : BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES

#3

I also want to add that the Video App plays the file just fine with DTS Audio. So the TV supports it.


#4

Read this thread: forums.plex.tv/discussion/49299/the-thing-about-direct-play-and-dts#latest

DTS is not working in Plex under Android TV for now...


#5

Thank you for replying. That is odd. Because last month December 2015:

Plex for Android v4.16.0.472

NEW:
- Add preference to disable using secure connections to servers.
- Allow layout selection for home libraries (grid, list, folder).
- Add support for MPEG2 decoding when supported by the local device.
- Inform the user when the app activates as the result of a previous purchase being detected.
- [Android TV] Add support for DTS/DTS-HD Passthrough.

I am wondering if this is considered regression.


#6

Indeed, we are now at v4.17.2.488 and still no mention of a fix for this issue.

So far, the only viable solution for me is to disable pass-through of the audio in the app. Which results in stereo sound output, whatever the original source has (AC3, DCA, AAC, etc.)


#7

THere is a new version of Plex App.
Plex for Android v4.18.0.502

Can anybody check for some improvments with DTS 5.1?!


#8

Checked. Unfortunately, DTS is still an issue.


#9

No Plex Employee Responded, so go here:
https://forums.plex.tv/discussion/165024/sony-android-tv-dolby-ac3-pass-through#latest


#10

PLEX customer support. What a fucking joke. Do thye even have a phone number one can call?
This is not free software. This is expensive as hell and all they do are ignoring customers.


#11

I'm frustrated too. If you are going to blame Sony or Google, please give us a bit more detail on why you are blaming Sony or Google. Also there are ways to file bug reports to both of them. If filed already, let's see the bug report that was filed. If we can see the bug report, we can look forward to updates on the specific topic. I don't think that is too much to ask for.


#12

Yup, still an issue.


#13

Thanks for checking.

@bsmack said:
Yup, still an issue.


#14

@brianjwd said:
Thanks for checking.

@bsmack said:
Yup, still an issue.

Any time.


#15

Anyone tried the new update?

Good: Seems like they are attempting to fix!!!!
Bad: No surround sound audio works now for me.


#16

Yeah i tried it. It detects dts-hd on some movies now, but not all.
Dont know if they fixed the 24hz stutter problem with transcoded audio.


#17

24hz+transcoded audio still stutters.

Plex still does not pass through directly to a TV (with DD/DTS support).


#18

Latest update fixed the audio pass-through for me on my Sony Android TV. DD + DTS finally work.


#19

Are you transcoding, direct streaming, or direct playing?

Direct Play didn't work for me. I'm going to go ahead and setup a system powerful enough to Transcoding.


#20

@BenjiZombie said:
Latest update fixed the audio pass-through for me on my Sony Android TV. DD + DTS finally work.

So you tried DTS? I set the Direct Play to auto from forced and I am only seeing DD 5.1 (yay! which is more than before). DTS is still not working.

Do you mind sharing your configuration settings?