BUG: Samsung Plex app won't play video with 4.1/5.0 DTS audio

smart-tv

#1

TV: Samsung 55KS8005
TV update: 1201
Plex app: 3.1.0 (3.8.0)
Plex server: 1.8.4.4249

When I try to play a video with 4.1/5.0 DTS audio I get the error message "Conversion failed. The transcoder crashed or failed to start up." This error doesn't come up if I try to play the video in my browser, only when playing on the TV app.

I don't have this issue with any other of my video files with regular 5.1 DTS. The video in question is "Ace Ventura: When Nature Calls" with the DTS-HD audio file.


#2

Any subs ? There is an issue that is being investigated to do with subtitles and transcoder crashes

In any case, these problems are media file specific and would need logs, sample that has the problem (eg 5 minute clip)

See
https://support.plex.tv/hc/en-us/articles/201998867-Investigate-Media-Information-and-Formats
https://support.plex.tv/hc/en-us/articles/201035968-Generating-Sample-Files-from-Media

https://support.plex.tv/hc/en-us/articles/216955788-Logging-for-Smart-TVs-TiVo
https://support.plex.tv/hc/en-us/articles/201643703-Reporting-issues-with-Plex-Media-Server
https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files


#3

No, file doesn't contain any subtitles. The file is supposed to be 5.0 but Plex thinks it's 4.1, maybe that could be the issue.

Sample with the issue: https://drive.google.com/file/d/0B4hwzCPvWTaHeXpaXzFDVUREZ28/view?usp=sharing


#4

I noticed that if I enable DTS (DCA) in the app it works but I dunno if it's something I should have enabled or not and my other DTS files work without it.

I hope that's all the info you needed.


#5

I attached the logs and media info you wanted to my other comment but it got hidden, hopefully you can still see the other comment above this one.


#6

@The-Choo-Choo-Shoe said:
I attached the logs and media info you wanted to my other comment but it got hidden, hopefully you can still see the other comment above this one.

if you used the forum e-mail interface to post then that would not add the attachments

There are no attachments in your first post


#7

Please also provide media info xml (save as text file and attach) - I have given you the link for how to get that

And see if issue remains after re-analyzing the media item
See https://support.plex.tv/hc/en-us/articles/200289336-Analyze-Media


#8

It was my 3rd post, it got hidden because I edited it and it said it has to be approved to be shown. I attached media info and the Plex logs in that comment. I'll attached them to this comment as well.

I've tried to analyze it and I also tried making a new library, it was suggested when I googled the issue and that didn't work either.


#9

Thanks for the logs and media info. I would like to see logs with verbose logging for a test after analyzing the media file and just do one test.

The logs provided show the last analyze done at 02:40
Also you were disabling and re-enabling debug logging

So please lets do the following
- enable debug logging and verbose logging on the server.
(That will allow to see all the parameters for the requests. The log was showing references to the Samsung Tizen profile bit also to Samsung - so i want to be sure the right profile is used)
- Restart the server
- Wait 2 minutes
- Do Media Analyze on E:\Movies\Ace Ventura When Nature Calls (1995) (1080P).mkv through the Plex Web Analyze Media Item interface
- At the end, re-capture the xml - you can actually do it this way on the server but you need to find the server token first
(http://127.0.0.1:32400/library/metadata/26351?checkFiles=1&includeBandwidths=1&X-Plex-Token=xxxxxxxxxxxxxxxxxxxxxxxxxx)
- Enable logging on the Samsung App
- Start to play the video
- When the error occurs, download the server logs and attach with the media info xml
- Disable verbose logging once the evidence is captured


#10

@sa2000 said:
Thanks for the logs and media info. I would like to see logs with verbose logging for a test after analyzing the media file and just do one test.

The logs provided show the last analyze done at 02:40
Also you were disabling and re-enabling debug logging

So please lets do the following
- enable debug logging and verbose logging on the server.
(That will allow to see all the parameters for the requests. The log was showing references to the Samsung Tizen profile bit also to Samsung - so i want to be sure the right profile is used)
- Restart the server
- Wait 2 minutes
- Do Media Analyze on E:\Movies\Ace Ventura When Nature Calls (1995) (1080P).mkv through the Plex Web Analyze Media Item interface
- At the end, re-capture the xml - you can actually do it this way on the server but you need to find the server token first
(http://127.0.0.1:32400/library/metadata/26351?checkFiles=1&includeBandwidths=1&X-Plex-Token=xxxxxxxxxxxxxxxxxxxxxxxxxx)
- Enable logging on the Samsung App
- Start to play the video
- When the error occurs, download the server logs and attach with the media info xml
- Disable verbose logging once the evidence is captured
Probably because I had to redo all the logs to upload them again in my last comment, that's why it's enabled/disabled over again, I think I did it 3 times.

I got the new files anyway.


#11

@The-Choo-Choo-Shoe said:

@sa2000 said:
Thanks for the logs and media info. I would like to see logs with verbose logging for a test after analyzing the media file and just do one test.

The logs provided show the last analyze done at 02:40
Also you were disabling and re-enabling debug logging

So please lets do the following
- enable debug logging and verbose logging on the server.
(That will allow to see all the parameters for the requests. The log was showing references to the Samsung Tizen profile bit also to Samsung - so i want to be sure the right profile is used)
- Restart the server
- Wait 2 minutes
- Do Media Analyze on E:\Movies\Ace Ventura When Nature Calls (1995) (1080P).mkv through the Plex Web Analyze Media Item interface
- At the end, re-capture the xml - you can actually do it this way on the server but you need to find the server token first
(http://127.0.0.1:32400/library/metadata/26351?checkFiles=1&includeBandwidths=1&X-Plex-Token=xxxxxxxxxxxxxxxxxxxxxxxxxx)
- Enable logging on the Samsung App
- Start to play the video
- When the error occurs, download the server logs and attach with the media info xml
- Disable verbose logging once the evidence is captured
Probably because I had to redo all the logs to upload them again in my last comment, that's why it's enabled/disabled over again, I think I did it 3 times.

I got the new files anyway.

Thank you. I will discussing this with the development teams and raise an issue with the relevant team. Please keep the sample on the provided google drive link folder


#12

Awesome. Yepp, I'll keep it on my drive no problem.


#13

@sa2000 said:

@The-Choo-Choo-Shoe said:

@sa2000 said:
Thanks for the logs and media info. I would like to see logs with verbose logging for a test after analyzing the media file and just do one test.

The logs provided show the last analyze done at 02:40
Also you were disabling and re-enabling debug logging

So please lets do the following

  • enable debug logging and verbose logging on the server.
    (That will allow to see all the parameters for the requests. The log was showing references to the Samsung Tizen profile bit also to Samsung - so i want to be sure the right profile is used)
  • Restart the server
  • Wait 2 minutes
  • Do Media Analyze on E:\Movies\Ace Ventura When Nature Calls (1995) (1080P).mkv through the Plex Web Analyze Media Item interface
  • At the end, re-capture the xml - you can actually do it this way on the server but you need to find the server token first
    (http://127.0.0.1:32400/library/metadata/26351?checkFiles=1&includeBandwidths=1&X-Plex-Token=xxxxxxxxxxxxxxxxxxxxxxxxxx)
  • Enable logging on the Samsung App
  • Start to play the video
  • When the error occurs, download the server logs and attach with the media info xml
  • Disable verbose logging once the evidence is captured
    Probably because I had to redo all the logs to upload them again in my last comment, that’s why it’s enabled/disabled over again, I think I did it 3 times.

I got the new files anyway.

Thank you. I will discussing this with the development teams and raise an issue with the relevant team. Please keep the sample on the provided google drive link folder

Any update on this?
I don’t know if you still need me to keep the file on my drive or if I can delete it.


#14

@The-Choo-Choo-Shoe said:

@sa2000 said:

@The-Choo-Choo-Shoe said:

@sa2000 said:
Thanks for the logs and media info. I would like to see logs with verbose logging for a test after analyzing the media file and just do one test.

The logs provided show the last analyze done at 02:40
Also you were disabling and re-enabling debug logging

So please lets do the following

  • enable debug logging and verbose logging on the server.
    (That will allow to see all the parameters for the requests. The log was showing references to the Samsung Tizen profile bit also to Samsung - so i want to be sure the right profile is used)
  • Restart the server
  • Wait 2 minutes
  • Do Media Analyze on E:\Movies\Ace Ventura When Nature Calls (1995) (1080P).mkv through the Plex Web Analyze Media Item interface
  • At the end, re-capture the xml - you can actually do it this way on the server but you need to find the server token first
    (http://127.0.0.1:32400/library/metadata/26351?checkFiles=1&includeBandwidths=1&X-Plex-Token=xxxxxxxxxxxxxxxxxxxxxxxxxx)
  • Enable logging on the Samsung App
  • Start to play the video
  • When the error occurs, download the server logs and attach with the media info xml
  • Disable verbose logging once the evidence is captured
    Probably because I had to redo all the logs to upload them again in my last comment, that’s why it’s enabled/disabled over again, I think I did it 3 times.

I got the new files anyway.

Thank you. I will discussing this with the development teams and raise an issue with the relevant team. Please keep the sample on the provided google drive link folder

Any update on this?
I don’t know if you still need me to keep the file on my drive or if I can delete it.

A Plex Media Server fix has been produced and i think it may get included in release 1.9.6