[Bug] Stuttering Playblack with movies encoded with M4VGear

server-synology

#1

Hey,

when I buy a iTunes movie and convert it with M4VGear (Windows) the Playback on iOS, tvOS and the Webplayer is stuttering.

On tvOS it where it runs best. Every 3 to 10 Minutes is a very small interrupt (around 0.5 to 1 sec). On iOS and the Webplayer is much more frequent.

If I copy the same movie to iTunes and play it on the AppleTV with the "Computer" app it's absolutely stutter free.

If I convert the movie with M4VGear (MacOS) it's also with Plex stutter free. But converting a movie with MacOS M4VGear is a bad idea... because it takes hours instead of minutes like on Windows and even more worse: there is a visible quality loose in the picture quality (but the same file size).

All streams are direct plays

I think the issue is caused the Plex Server, after the issue appears only when I play the movie via Plex.


Setup:

Plex Server 1.9.2.4285 (@Synology DS415play)
Apple TV 4k with tvOS 11.0 (Plex App 1.17.1 )

iMac 5k with macOS 11.13
Windows 7 via Parallels Desktop running M4VGear 5.3.4


#2

Let me get this right? You are taking copyrighted material (iTunes) and converting it to bypass the DRM?


#3

@ChuckPA Yes, this is the idea of M4VGear. This allows people to use their legally bought movies with software like plex. It's basically the same like ripping a blue ray.


#4

Okay... I think I found a solution.
I tried Emby and found the same stuttering as in Plex.

After that I remuxed the suttering movies with ffmpeg and after that the stuttering was gone.
I used for remuxing the mp4tool (http://www.emmgunn.com/mp4tools-home/).

But it's still strange that the stuttering did not appear in the Computer app on the AppleTV or QuickTime/VLC on MacOs...
I'm still not sure if the error comes from the windows version of m4vgear or Plex/Emby...


#5

I have exactly the same problem. Can you explain what remuxing is/does and what settings to use in mp4tools (I cannot see remuxing discussed in the user guide)?

thanks!
J.