Camera upload fails on the same file over and over (Logs)

ios

#1

I love the camera upload, when it works. I don't even care if it works in the background or not... I have no problems going into the camera upload and wait for it to upload, but it HAS to work.

I get these errors ALL the time. I have to go into debug, download the file, extract it, look at what file it is, delete it and then move on when it a total pain. Most of the time, this file has already been uploaded, and it's trying to upload it again. If there is an issue with the file, DELETE it and upload it again or make a copy of it. It can't just CHECK the file and STOP all other uploads from happening.

As soon as I clean out that file (delete it), it starts up load again but this seems to happen about every week and I have to go through the process again to FIX it.

Give me a PROMPT saying, do you want to overwrite this file. Give me an option to SKIP this bad file (nothing ever wrong with the file BTW). Just make sure it works.

Anyone have any thoughts on this?

2017/12/08 08:26:49.961 (177 MB) (1458404) I PMKCameraUploadEngine.m:1798 | Created data transfer task to check for 2017-12-03 17.30.25.HEIC
2017/12/08 08:26:49.961 (177 MB) (1458404) I PMKCameraUploadEngine.m:2170 | Ending background task.
2017/12/08 08:26:49.962 (177 MB) (1458410) I PMKCameraUploadEngine.m:360 | Saving storage info for server PlexNAS
2017/12/08 08:26:49.972 (177 MB) (1458410) I PMKCameraUploadEngine.m:381 | Saved storage info for server PlexNAS
2017/12/08 08:26:50.689 (177 MB) (1458515) I PMKCameraUploadEngine.m:1300 | Beginning background task.
2017/12/08 08:26:50.691 (177 MB) (1458515) I PMKCameraUploadEngine.m:2619 | Asset not found. Checking for partial upload.
2017/12/08 08:26:50.835 (182 MB) (1458616) I PMKFileCopier.m:102 | EOF
2017/12/08 08:26:50.844 (179 MB) (1458616) I PMKCameraUploadEngine.m:1803 | Created data transfer task to check partial upload for 2017-12-03 17.30.25.HEIC
2017/12/08 08:26:50.844 (179 MB) (1458616) I PMKCameraUploadEngine.m:2170 | Ending background task.
2017/12/08 08:26:51.423 (179 MB) (1458616) V PMKEventSourceManager.m:177 | Event received: {}
2017/12/08 08:26:51.424 (179 MB) (1457982) V PMKEventSourceManager.m:177 | Event received: {}
2017/12/08 08:26:52.277 (179 MB) (1458373) I PMKCameraUploadEngine.m:1300 | Beginning background task.
2017/12/08 08:26:52.278 (179 MB) (1458373) I PMKCameraUploadEngine.m:2648 | Found partial upload for asset. Beginning from offset 3794538
2017/12/08 08:26:52.292 (179 MB) (1458616) I PMKFileCopier.m:226 | EOF
2017/12/08 08:26:52.305 (179 MB) (1458374) I PMKCameraUploadEngine.m:1808 | Created data transfer task to upload 2017-12-03 17.30.25.HEIC
2017/12/08 08:26:52.305 (179 MB) (1458374) I PMKCameraUploadEngine.m:2170 | Ending background task.
2017/12/08 08:26:52.489 (179 MB) (1458515) I PMKCameraUploadEngine.m:1300 | Beginning background task.
2017/12/08 08:26:52.490 (179 MB) (1458515) I PMKCameraUploadEngine.m:2675 | Something went wrong. Starting process over.
2017/12/08 08:26:52.491 (179 MB) (1458515) I PMKCameraUploadEngine.m:1906 | Ending upload.
2017/12/08 08:26:52.491 (179 MB) (1458515) I PMKCameraUploadEngine.m:1932 | In the middle of the upload process, attempting to finish up.
2017/12/08 08:26:52.491 (179 MB) (1458515) I PMKCameraUploadEngine.m:1936 | No more tasks, all done.
2017/12/08 08:26:52.491 (179 MB) (1458515) I PMKCameraUploadEngine.m:1967 | Upload ended.


#2

I got LOGS and everything and only 11 people have looked at this!!! SIGH…


#3

I also rely heavily on the camera upload feature but since Dec 12 it hasn’t worked on any off our iOS devices. I’ve tried different versions of pms but still doesn’t work and there has been another iOS update since which I had hoped would jump start it again. Can you tell me what logs I need to look at to see if it’s a problem file that’s stopping it from working. As a workaround I’ve started uploading to OneDrive and downloading them from there into my plex library but it’s a bit of a faff


#4

Hi @ASiDiE

Sorry for taking so long to get back to you, lots of staff catching up on things after the holiday break.

I’ve passed this issue on to the iOS team to investigate.


#5

I posted about this again… SAME THING happening… this has not been fixed or even looked at.


#6

I am seeing exactly the same error.
This is super annoying and happens for me every month.
And every month I need to chase down the file that is holding the upload queue.

Plex-Support, please fix this. What do you need from us apart from the logs??

Please note:
To workaround it, go to the file that has the “partial upload” and delete that file in the Photos app.
In your case you need to delete the photo from “2017-12-03 17.30.25.HEIC”


#7

@drzoidberg33 any update on this issue?


#8

Hi, can we have at least some acknowledgment that this is a bug?