Camera Upload not working



I setup camera upload on my iPhone 6S and it worked fine, and backed up all of my photos. Fast forward a few weeks, and I've noticed that it will no longer back up my photos. I tried resetting the camera upload feature. I tried uninstalling the app. Nothing seems to work. The app is acting as if there are no photos to upload. When I force it to run the upload process, it finishes instantly, as if there were nothing to upload. But I know there are new photos and videos which haven't been uploaded. The server logs don't have any errors. Please help.

Another strange thing: I've been trying every few days to make it work, and sometimes when I open the app on my phone, it tells me that camera upload isn't setup. I know for a fact that I always leave it setup. It seems the app is occasionally forgetting the Library and Album which I've set as the destination.

The Server is Windows 10, latest version of Plex Media Server as of this writing.


The feature is useless on iOS. Not sure if it works on other platforms, but it’s broken here. Even when it’s “working” it won’t upload when the iOS device locks the screen or goes to sleep. If you have managed users, you must also set the iOS app to auto login otherwise even when you come back to the app it won’t continue uploading.

Coming back to an upload mid-way might lose the upload settings (which you’ve mentioned, plus see other people’s posts) and again, when it’s “working” it’s just painfully slow. I’ve been going all morning, some 4 hours, to upload 230 photos and a few short (1-2 minute 720p videos).

I’m just testing at the moment with the desire to se up a seamless upload process for my mother, but it doesn’t look like thats ever going to work. On top of these issues, even at the most basic level, having to go into “settings” to initiate the sync/upload is already one step too many. Contrast with the Flickr app - you just OPEN the app. That’s it. And it happily continues to upload when the screen locks.

The alternative I’ve been looking at is an app called PhotoSync - it works well, BUT is a completely manual process. You even have to choose where to upload the photos every time. It takes a simple concept and makes it so extremely complicated that there’s absolutely ZERO possibility of anyone with less than a serious enthusiast-level technical level to even begin to configure it. No problem for me (though time consuming) but a complete non starter for anyone else I know, let alone my mom.


Photo upload has now been going about 8 hours and still not done 250 images. The app Photosync finished 250 images in the time Plex uploaded less than 20. Just absolutely useless and an embarrassment.

The biggest issue with Plex and why it’s not ready for mainstream is that features keep getting added, but not one single part of the entire experience is at 100% functionality yet. I can’t recommend this to family or friends if I don’t want to be responsible for maintaining their systems on a regular basis. I’m even leery of setting clients up with it because after detailed setup there’s still so much that can go wrong at any time.