Can not setup plex on fresh Ubuntu 16.04



I have installed Plex several times in the past and never had an issue but this time I can't seem to get things to work. I have a server with a fresh install of Ubuntu 16.04 and I have tried 4 times now to install latest Plex on it. Every time the package installation goes perfectly but the problem starts when I access the web interface for the first time.

I connect to the server from another machine in Chrome (http://192.168.x.x:32400/web) and am provided with the How Plex Works then Server Setup page. I enter a name for the server, click next, then get an error popup telling me my settings could not be saved. Doesn't matter how many times I try, or uninstall/reinstall I get the same thing.

I noticed in Chrome developer tools it is trying to make requests to which doesn't make sense since I'm not on the Plex server so I went ahead and created an ssh tunnel and forward port 32400 to the Plex server. Doing this breaks the setup page and prevents me from even entering a name. Through a combination of using the tunnel and server's IP I can finally get to the settings page where it tells me I have an unclaimed server on my network. When I try to claim the server through the tunnel it errors out and tells me I can't. If I use the servers actual IP to claim it, the server disappears and can no longer be found on my network.

I'm at a loss here of what to do next.


You're on the right track. You do need the SSH tunnel.

  1. SSH into the box
  2. Stop PMS
  3. sudo rm -f "/var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml" (clears out the false-start)
  4. Start PMS
  5. Open a new SSH tunnel ssh -L 8888:
  6. On local browser, open

For reference, the procedure is documented here
Scroll down to On a Different Network


Hey ChuckPA,

thanks for the quick reply. I took a look at your steps and the linked document and gave it a try but no luck, I get the same end result. The exact steps I took are

  1. ssh into server ssh plex@192.168.x.x
  2. stop pms systemctl stop plexmediaserver
  3. delete old preference file rm "/var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml"
  4. start pms systemctl start plexmediaserver
  5. exit ssh session exit
  6. create tunnel ssh -L 8888:localhost:32400 plex@192.168.x.x
  7. open chrome tab to

I get to the setup page and it fails to save the settings like previous attempts. I should also note, my server is on the same network as my laptop so I shouldn't actually need the tunnel, I just attempted it to make sure I tried everything.


Ok, if it's on your network, why don't you open on the actual server machine?

If it doesn't have a graphics head, you'll need the ssh tunnel to handle redirection to your laptop's display. PMS requires a 'local' head to get started. Once it's signed in to your account, you can open it by IP without tunnel.

For the setup, if you a Windows laptop, you'll need to perform the port forward with Putty.

Also, if the server's IP and your IP are not on the same subnet mask, AND you're not (what the tunnel provides), PMS will refuse to authenticate you as the owner while in the unclaimed (not signed in) state. This was done to prevent someone from hijacking your machine when it's in a remote center somewhere.


My server is headless, which is why I had gone through the effort of using the tunnel initially instead of pulling it up on the server directly. As for the subnet, my machine and the server are on the same subnet so that shouldn't be what is wrong either.

I really don't understand what is wrong at this point.


Thank you for that. Instead of using user plex, the only difference, which makes no actual sense unless your Linux config is unique. Is this i n a Docker or LXC?

Try ssh as root.


I have run this in docker and natively with the same results. I even just went so far as to install unity on the server and try the setup process locally but with the same result.

As for the root user suggestion, root access over ssh is disabled but many of the commands were run as root to install Plex and start/stop it.


I'm starting to think this may be an issue on Plex's end of things. I have been trying to log in with my username this whole time as I have done for the year+ I have had my account. When I go ahead and use my email address instead, I am able to claim the media server temporarily. I say temporarily because I lose access to it if I click Settings -> Server. It also shows up in the list of plex servers I can access on the homepage but says it's unavailable, along with several other instances I had tried to claim. As for these other instances, if I remove them from the home page, they show back up again next time I clear my preferences file and claim the new instance so it seems like something is not saving on the plex side of things.


I have also now tried using a claim code with the official docker container. It skipped the setup screen but does not show up in my list of servers.


We need a fresh set of eyes. This is no longer just a Linux issue.

@OttoKerner Can you assist please? What did I overlook?


I have managed to get this to work on my non-server by following the standard linux install steps. The only difference really is the server was fresh 16.04 install and my machine is 17.04. I scp'd the Library files from my machine over to my server and now everything works. I don't know why this was such an issue on the server but this has resolved it for me.


Just an update, I ended up installing Ubuntu Server 17.04 on my server and everything works like it should have from the start. I have not been able to replicate the original issue.