Cannot play 5.1 content on new Windows HTPC

plex-media-player

#1

I have a new Windows PC with an 8th Gen Intel i3 and a motherboard that says it supports up to 7.1 audio. When plugging the machine into either my TV or my Vizio soundbar, Windows will only show stero as an option and no matter what I choose in plex it will downmix to stero. What do I do to enable 5.1 on Windows? I've updated the BIOS and graphics drivers on the PC and all other device's firmwares are up to date.


#2

@AgentDrTran said:
I have a new Windows PC with an 8th Gen Intel i3 and a motherboard that says it supports up to 7.1 audio.

This usually refers to the on-board analog audio output.
Do you have your speakers connected to these analog audio outputs on the back of your PC?

Please detail which type of connection is between your PC and your TV. (HDMI, optical, coax)

How are the speakers/soundbar connected?
directly to the PC or daisy-chained to the TV? Again, which type of connection?


#3

@OttoKerner said:

@AgentDrTran said:
I have a new Windows PC with an 8th Gen Intel i3 and a motherboard that says it supports up to 7.1 audio.

This usually refers to the on-board analog audio output.
Do you have your speakers connected to these analog audio outputs on the back of your PC?

Please detail which type of connection is between your PC and your TV. (HDMI, optical, coax)

How are the speakers/soundbar connected?
directly to the PC or daisy-chained to the TV? Again, which type of connection?

The PC is connected to the TV with HDMI, and the soundbar is connected to the TV with HDMI (ARC) as well. The built-in roku, my Switch, and my Chromecast can all play 5.1. The soundbar doesn't support 4K passthrough which is why the PC is plugged into the TV.

edit: I've tried contacting both Vizio and MSI but neither were helpful - Vizio told me it was a PC issue and MSI told me it was a soundbar issue.


#4

Try this:
put PMP into its ‘fullscreen mode’

Click on your user name, top, right
Settings
Audio
Device Type = HDMI
Channels = 5.1
Device = try ‘Autoselect’ first

Then activate the checkbox for ‘Dolby Digital’ below and all other formats for which your soundbar has support.
Keep in mind that not all of the higher-quality codecs are supported over a HDMI-ARC connection.


#5

@OttoKerner said:
Try this:
put PMP into its ‘fullscreen mode’

Click on your user name, top, right
Settings
Audio
Device Type = HDMI
Channels = 5.1
Device = try ‘Autoselect’ first

Then activate the checkbox for ‘Dolby Digital’ below and all other formats for which your soundbar has support.
Keep in mind that not all of the higher-quality codecs are supported over a HDMI-ARC connection.


It looks like plex is playing 5.1 now, but I can’t hear anything except the clicks in the UI. What other connection method should I use? My soundbar has optical and ARC. Would the optical/laser connection be better?


#6

@AgentDrTran said:

Output driver : null doesn’t look like it has the right device.
Can you try and select a particular sound interface under
Settings - Audio - ‘Device’
(it should have ‘HDMI’ in its name, I suppose.)

A second thing to try would be:
‘Device Type’ = Optical
Channels = 5.1
Only a checkmark in ‘Dolby Digital’ below


#7

@OttoKerner said:

@AgentDrTran said:

Output driver : null doesn’t look like it has the right device.
Can you try and select a particular sound interface under
Settings - Audio - ‘Device’
(it should have ‘HDMI’ in its name, I suppose.)

A second thing to try would be:
‘Device Type’ = Optical
Channels = 5.1
Only a checkmark in ‘Dolby Digital’ below

screenshot (this still shows as null when playing a video):

screenshot after switching to optical:

Thanks for your help, by the way.


#8

@AgentDrTran said:
screenshot after switching to optical:

This looks like expected (mostly).
Does your PC have several HDMI outputs?

You didn’t mention if you now hear audio or not.

As a last resort, try the optical connection between TV and soundbar.


#9

Was the TV switched on, when you started PMP?


#10

@OttoKerner said:
Was the TV switched on, when you started PMP?

sorry, should have been clear - I did not hear anything. And yes the TV was turned on when PMP was started. My PC has one HDMI out. I'll try the optical connection again.


#11

Do you have several player softwares running at the same time? They might fight over the HDMI port.

Do also not set Windows' default audio output to the HDMI audio.


#12

@OttoKerner said:
Do you have several player softwares running at the same time? They might fight over the HDMI port.

Do also not set Windows’ default audio output to the HDMI audio.

I only have Plex running. and here’s my windows
. What do I set the default as? I can’t choose the disabled one.


#13

I’ve tried the optical cable and still nothing from Windows or Plex. I get the same error as before with the Optical option in Plex:

When selecting Basic I get this (no audio):


#14

Other observation:

Turning off exclusive mode forced (working) stero audio, turn off exclusive mode with Optical gave me this:


#15

Could you use a different test video?
The one you have uses multi-channel flac (flac is not very widely supported).
Pick one with a AC3 or maybe a DTS (normal) audio track.


#16

@OttoKerner said:
Could you use a different test video?
The one you have uses multi-channel flac (flac is not very widely supported).
Pick one with a AC3 or maybe a DTS (normal) audio track.

does this work? there was still no audio.


#17

Please get the PMP logfile and attach it.

Another idea:
While in full screen, go to settings - main
Scroll down to the bottom
There should be a checkbox labeled 'OpenGL' (or similar). Toggle it, then restart PMP and try again.


#18

Here's the logs. Enabling webgl presented the same issue.


#19

Repeat the above tests with 'Exclusive mode' disabled.


#20


Tried this time with it disabled, same thing